Subject: [Stackevo] IP Stack Evolution Program Review

From: Brian Trammell <[email-masked]>
Date: Mon, 15 Feb 2016 11:14:48 +0100

Greetings, all,

The IAB is now reviewing all its programs once per meeting cycle, to allow the whole Board to have visibility into the working of the programs, to compare notes across programs, to review the membership of the Programs to see if the right people are involved, and to see what works (and what doesn't) in order to help things run more smoothly.

The IAB will review the IP Stack Evolution program at its telechat on Wednesday 2 March 2016, and I'm preparing my presentation for this review now. Here's what I think I'm going to say:

(1) We've done a lot since we were "rebooted" following the May 2014 IAB retreat in Cancun, but much of this happens through the initial coordination of smaller groups of individual Program members, as opposed to official actions of the Program. Much of this involves workshop / BarBoF / BOF organization:

  - SEMI workshop in Zurich in January 2015, which led to:
  - SPUD non-WG BoF in Dallas in March 2015
  - HOPS BarBoF in Dallas in March 2015, and the HOPSRG/MAPRG proposed RG afterward
  - MaRNEW workshop in Atlanta in September 2015

  - IOTSI workshop in San Jose in March 2016

  - SEMI workshop proposed to SIGCOMM 2016; proposal rejected.
  - ACCORD non-WG BoF proposed for Buenos Aires in April 2016

Indeed, I'm not sure we've had a conversation on the list that didn't lead to some of us going off and proposing a workshop of BoF somewhere. IOTSI came out of discussions about polishing up Point 5 on our program description, which *still* reads, in part: "[Erik and Ralph to provide text to flesh this out]".

(2) We have sent no correspondence, and no statements up to the IAB for approval, though we've discussed the possibility of doing so. Discussion on proposed communication on traffic characterization, still pending, led to another BoF proposal (ACCORD).

(3) We have no official program documents, and no current plans for any. There is one document for consideration as a "program work item", draft-trammell-stackevo-explicit-coop, but it's not clear where the boundary between "architecture" and "engineering" is here.

(4) We have no regular program meetings outside IETF meetings. It's not clear whether we should.

(5) The membership is largely active in areas of interest to the program.

First, I'd like to ask the program whether there's anything I'm missing here that should be included in the review.

Second, I'd like to ask the membership if there's anything less (or more) we should be doing: what would you like to see out of the program as members?

Thanks, cheers,

Brian

---

From: Aaron Falk <[email-masked]>
Date: Mon, 15 Feb 2016 17:18:55 -0500

Thinking about your questions...

I don't recall discussion of an ACCORD BoF.  What is it?  Has it been
approved?

--aaron

On Mon, Feb 15, 2016 at 5:14 AM, Brian Trammell <[email-masked]> wrote:

> Greetings, all,
>
> The IAB is now reviewing all its programs once per meeting cycle, to allow
> the whole Board to have visibility into the working of the programs, to
> compare notes across programs, to review the membership of the Programs to
> see if the right people are involved, and to see what works (and what
> doesn't) in order to help things run more smoothly.
>
> The IAB will review the IP Stack Evolution program at its telechat on
> Wednesday 2 March 2016, and I'm preparing my presentation for this review
> now. Here's what I think I'm going to say:
>
>
> (1) We've done a lot since we were "rebooted" following the May 2014 IAB
> retreat in Cancun, but much of this happens through the initial
> coordination of smaller groups of individual Program members, as opposed to
> official actions of the Program. Much of this involves workshop / BarBoF /
> BOF organization:
>
> Indeed, I'm not sure we've had a conversation on the list that didn't lead
> to some of us going off and proposing a workshop of BoF somewhere. IOTSI
> came out of discussions about polishing up Point 5 on our program
> description, which *still* reads, in part: "[Erik and Ralph to provide text
> to flesh this out]".
>
> (2) We have sent no correspondence, and no statements up to the IAB for
> approval, though we've discussed the possibility of doing so. Discussion on
> proposed communication on traffic characterization, still pending, led to
> another BoF proposal (ACCORD).
>
> (3) We have no official program documents, and no current plans for any.
> There is one document for consideration as a "program work item",
> draft-trammell-stackevo-explicit-coop, but it's not clear where the
> boundary between "architecture" and "engineering" is here.
>
> First, I'd like to ask the program whether there's anything I'm missing
> here that should be included in the review.
>
> Second, I'd like to ask the membership if there's anything less (or more)
> we should be doing: what would you like to see out of the program as
> members?
>
> Thanks, cheers,
>
> Brian
>
> _______________________________________________
> Stackevo mailing list
> [email-masked]
> https://www.iab.org/mailman/listinfo/stackevo
>
>

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Mon, 15 Feb 2016 21:28:25 -0600

Hi, Aaron,

> I don't recall discussion of an ACCORD BoF.  What is it?  Has it been

I'm not the smart guy about this, but I can point out that the ACCORD BOF
description is in http://tools.ietf.org/bof/trac/wiki, and the BOF request
cutoff isn't until this coming Friday, so nothing has been approved yet ...

Spencer, as AD who is holding the bag on ACCORD.

>> The IAB is now reviewing all its programs once per meeting cycle, to
>> allow the whole Board to have visibility into the working of the programs,
>> to compare notes across programs, to review the membership of the Programs
>> to see if the right people are involved, and to see what works (and what
>> Indeed, I'm not sure we've had a conversation on the list that didn't
>> lead to some of us going off and proposing a workshop of BoF somewhere.
>> IOTSI came out of discussions about polishing up Point 5 on our program

---

From: Natasha Rooney <[email-masked]>
Date: Tue, 16 Feb 2016 08:16:37 +0000

Hey Brian!

I had an awesome chat with Spencer the other day about the outputs from MaRNEW and their status. We know of some things which are actively happening (LURK from the Keyless SSL idea, Zero bit / 1 bit for latency / bandwidth as an idea which came from MaRNEW and will be discussed at ACCORD, etc.) but there are a number of items which either aren’t going anywhere or are not being tracked.

As a result I’m going to make a super helpful (and hopefully not super complicated) table showing all the items suggested at MaRNEW, their status, where they belong (IETF / GSMA and which WG) and some notes. I’ll try to not to make it two colourful (maybe just half a my-little-pony).

I want to get this done in the week after next (more commonly known as the week after MWC), but this doesn’t work so well with your timeline, so I’ll try and get something to you quicker then, and you can choose whether to use it or not!

Thanks!

Natasha

Natasha Rooney | Technologist, Web and Internet, W3C & IETF | GSMA | [email-masked]<mailto:[email-masked]> | +44 (0) 7730 219 765 | @thisNatasha | Skype: [email-masked]<mailto:[email-masked]>

On Feb 15, 2016, at 6:14 PM, Brian Trammell <[email-masked]<mailto:[email-masked]>> wrote:

Greetings, all,

Thanks, cheers,

Brian
_______________________________________________
Stackevo mailing list
[email-masked]<mailto:[email-masked]>
https://www.iab.org/mailman/listinfo/stackevo

This email and its attachments are intended for the above named only and may be confidential. If they have come to you in error you must take no action based on them, nor must you copy or show them to anyone; please reply to this email or call +44 207 356 0600 and highlight the error.

---

From: Brian Trammell <[email-masked]>
Date: Tue, 16 Feb 2016 13:40:28 +0100

Hi, Natasha, all

> On 16 Feb 2016, at 09:16, Natasha Rooney <[email-masked]> wrote:
> 
> Hey Brian!
> 

Ooh, this'd be great to have! I'm not sure how much detail we'll go into on MaRNEW during the review though, so don't go to heroic efforts to get it done before 2.3.

FYI: attached is the first draft of slides I'm planning to show. (The voiceover for the captionless Gemini launch is "I prefer to think of us as a highly efficient launchpad for new work, as opposed to a rusty pickup truck that bits of work fall off of", in reference to the fact that most of what we do is "oooh let's have a workshop!").

Feedback welcome -- let me know if there's anything I'm missing here (at this level of detail).

Cheers,

Brian

> Thanks!
> 
> Natasha
> 
> 
> Natasha Rooney | Technologist, Web and Internet, W3C & IETF | GSMA | [email-masked] | +44 (0) 7730 219 765 | @thisNatasha | Skype: [email-masked]
> 
> 
>> On Feb 15, 2016, at 6:14 PM, Brian Trammell <[email-masked]> wrote:
>> 
>> Greetings, all,
>>

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Tue, 16 Feb 2016 08:12:30 -0600

Hi, Brian,

On Feb 16, 2016 06:40, "Brian Trammell" <[email-masked]> wrote:
> > I had an awesome chat with Spencer the other day about the outputs from
MaRNEW and their status. We know of some things which are actively
happening (LURK from the Keyless SSL idea, Zero bit / 1 bit for latency /
bandwidth as an idea which came from MaRNEW and will be discussed at
ACCORD, etc.) but there are a number of items which either aren’t going
anywhere or are not being tracked.
> >
> > As a result I’m going to make a super helpful (and hopefully not super
complicated) table showing all the items suggested at MaRNEW, their status,
where they belong (IETF / GSMA and which WG) and some notes. I’ll try to
not to make it two colourful (maybe just half a my-little-pony).
> >
> > I want to get this done in the week after next (more commonly known as
the week after MWC), but this doesn’t work so well with your timeline, so
I’ll try and get something to you quicker then, and you can choose whether
to use it or not!
>
> Ooh, this'd be great to have! I'm not sure how much detail we'll go into
on MaRNEW during the review though, so don't go to heroic efforts to get it
done before 2.3.
>
> FYI: attached is the first draft of slides I'm planning to show. (The
voiceover for the captionless Gemini launch is "I prefer to think of us as
a highly efficient launchpad for new work, as opposed to a rusty pickup
truck that bits of work fall off of", in reference to the fact that most of
what we do is "oooh let's have a workshop!").
> Feedback welcome -- let me know if there's anything I'm missing here (at
this level of detail).

The slides you sent seemed pretty clear, except for the first
bullet/sub-bullet. I spent a bit of time trying to match up the names with
the categories.

If it's important to include the names on the first slide, could I suggest
combining them, so it's one bullet that looks like

3 workshops (names go here),   1 BoF and 1 pending (names go here), etc.

?

Thanks,

Spencer

> Cheers,
>
> Brian
>
>
>
>
>
>
> > Thanks!
> >
> > Natasha
> >
> >
> > Natasha Rooney | Technologist, Web and Internet, W3C & IETF | GSMA |
[email-masked] | +44 (0) 7730 219 765 | @thisNatasha | Skype:
[email-masked]
Wednesday 2 March 2016, and I'm preparing my presentation for this review
now. Here's what I think I'm going to say:
> >>
> >>
> >> (1) We've done a lot since we were "rebooted" following the May 2014
IAB retreat in Cancun, but much of this happens through the initial
coordination of smaller groups of individual Program members, as opposed to
official actions of the Program. Much of this involves workshop / BarBoF /
> >>
> >> (2) We have sent no correspondence, and no statements up to the IAB
for approval, though we've discussed the possibility of doing so.
Discussion on proposed communication on traffic characterization, still
pending, led to another BoF proposal (ACCORD).
> >>
> >> (3) We have no official program documents, and no current plans for
any. There is one document for consideration as a "program work item",
draft-trammell-stackevo-explicit-coop, but it's not clear where the
boundary between "architecture" and "engineering" is here.
> >> First, I'd like to ask the program whether there's anything I'm
missing here that should be included in the review.
> >>
> >> Second, I'd like to ask the membership if there's anything less (or
more) we should be doing: what would you like to see out of the program as
members?
> > This email and its attachments are intended for the above named only
and may be confidential. If they have come to you in error you must take no
action based on them, nor must you copy or show them to anyone; please
reply to this email or call +44 207 356 0600 and highlight the error.

---

From: Mirja Kühlewind <[email-masked]>
Date: Tue, 23 Feb 2016 09:16:35 +0100

We have also published the SEMI workshop report. Not sure if you want to mention that separately…

Mirja

> Am 16.02.2016 um 13:40 schrieb Brian Trammell <[email-masked]>:
> 
> Hi, Natasha, all
> 
> <program-review-mar16.pdf>
> 
> 
>> Thanks!
>> 
>> Natasha
>> 
>>

---

From: Brian Trammell <[email-masked]>
Date: Tue, 23 Feb 2016 10:12:59 +0100

hi Mirja,

It's on there (RFC 7663), but I'll call it out explicitly as SEMI.

Thanks, cheers,

Brian

> On 23 Feb 2016, at 09:16, Mirja Kühlewind <[email-masked]> wrote:
>