Subject: [Stackevo] Stack Evolution call on 21 June

From: Brian Trammell <[email-masked]>
Date: Thu, 23 Jun 2016 15:33:53 +0200

Greetings, all,

Below, my cleaned-up notes from the Stack Evolution program meeting on 21 June:

We spoke about two topics: what we as the program can do, or what the IAB can do, with respect to "slouching toward catenets", or the replacement of end-to-end with islands of networking; and what we as the program should do, or what the IAB should do, in reply to the ETSI NGP ISG white paper on next generation protocols, and with respect to the ISG in general.

We deferred one topic: continuation/finalization of draft-iab-protocol-transitions-01, as Dave Thaler (editor) couldn't make the call.

Slouching toward Catenets
-------------------------

On the catenet topic, Ted identified two possible issues we discussed. First, that the ubiquitous sensor-hub-cloud model in the IoT space is a textbook example of a catenet, in that the sensor-hub segment is often not based on the Internet protocol stack at all, and that there is a need for architectural guidance to ensure this non-Internet design pattern doesn't leak into the hub-cloud segment. It's not clear what form this architectural guidance should take, though.

The second issue is more fundamental: due to the fact that inter-AS information exchange in the control plane is all folded into BGP, there is less information available at the border than would be useful to allow true end-to-end management of traffic. This, in some ways, is the promise of SDN in the interdomain space, and we should have an answer here. To some extent this involves socializing the idea that this is a problem. Ted and I will take the pen on a problem statement on n-tuple routing as the beginning of this effort.

Raised during this discussion is the possibility that alto could provide a way to augment interdomain control-plane information flows; alto will have a rechartering discussion in Berlin.

ETSI NGP ISG
------------

There is no consensus in the program about what to do with respect to this effort. Many program members see any engagement with the ISG directly as risking an enormous amount of time for zero gain. We might be able to influence people who are slouching toward catenets, but it is difficult to have influence over those who are marching toward them, and the whitepaper clearly envisions displacing the Internet protocol stack with something future-internetty and not very well defined. In addition, given the extremely... forward position this work was given in ETSI press releases at its inception, even engaging with them might be misread or mis-advertised as IAB/IETF endorsement of their vision.

There does seem to be rough consensus that, to the extent that the ideas coming out of the NGP ISG might influence work under the "5G" hydra, that we should be engaging with various players in the 5G space to make them aware of relevant work going on in the IETF; Spencer suggested leveraging our relationship with 3GPP might make sense here. So instead of engaging with the group, it might be more productive to engage with their intended audience.

And in case all of this is just a big miscommunication, Natasha suggested that Andy Sutton could be invited to speak to the Program (either at a Program meeting at the IETF, or during a program telecon).

Stackevo folks: anything I'm missing here?

Cheers,

Brian

---

From: Dave Thaler <[email-masked]>
Date: Fri, 24 Jun 2016 22:00:04 +0000

Yep, I couldn't make the call but I will repeat my usual arm-twisting about contributions to
the transitions document
(Lee, I'm looking at you for helping with IPv6 text...
Suzanne, I think you volunteered to help with CIDR text...)

Dave

> -----Original Message-----
> From: IAB [mailto:[email-masked]] On Behalf Of Brian Trammell
> Sent: Thursday, June 23, 2016 6:34 AM
> To: Stackevo <[email-masked]>
> Cc: IAB <[email-masked]>
> Subject: [IAB] Stack Evolution call on 21 June
> 
> Greetings, all,
> 
> We spoke about two topics: what we as the program can do, or what the IAB
> can do, with respect to "slouching toward catenets", or the replacement of
> end-to-end with islands of networking; and what we as the program should
> do, or what the IAB should do, in reply to the ETSI NGP ISG white paper on
> next generation protocols, and with respect to the ISG in general.
> 
> We deferred one topic: continuation/finalization of draft-iab-protocol-
> transitions-01, as Dave Thaler (editor) couldn't make the call.
> 
> On the catenet topic, Ted identified two possible issues we discussed. First,
> that the ubiquitous sensor-hub-cloud model in the IoT space is a textbook
> example of a catenet, in that the sensor-hub segment is often not based on
> the Internet protocol stack at all, and that there is a need for architectural
> guidance to ensure this non-Internet design pattern doesn't leak into the
> hub-cloud segment. It's not clear what form this architectural guidance
> should take, though.
> 
> The second issue is more fundamental: due to the fact that inter-AS
> information exchange in the control plane is all folded into BGP, there is less
> information available at the border than would be useful to allow true end-
> to-end management of traffic. This, in some ways, is the promise of SDN in
> the interdomain space, and we should have an answer here. To some extent
> this involves socializing the idea that this is a problem. Ted and I will take the
> pen on a problem statement on n-tuple routing as the beginning of this
> effort.
> 
> Raised during this discussion is the possibility that alto could provide a way to
> augment interdomain control-plane information flows; alto will have a
> rechartering discussion in Berlin.
> 
> ETSI NGP ISG
> ------------
> 
> There is no consensus in the program about what to do with respect to this
> effort. Many program members see any engagement with the ISG directly as
> risking an enormous amount of time for zero gain. We might be able to
> influence people who are slouching toward catenets, but it is difficult to have
> influence over those who are marching toward them, and the whitepaper
> clearly envisions displacing the Internet protocol stack with something
> future-internetty and not very well defined. In addition, given the
> extremely... forward position this work was given in ETSI press releases at its
> inception, even engaging with them might be misread or mis-advertised as
> IAB/IETF endorsement of their vision.
> 
> There does seem to be rough consensus that, to the extent that the ideas
> coming out of the NGP ISG might influence work under the "5G" hydra, that
> we should be engaging with various players in the 5G space to make them
> aware of relevant work going on in the IETF; Spencer suggested leveraging
> our relationship with 3GPP might make sense here. So instead of engaging
> with the group, it might be more productive to engage with their intended
> audience.
> 
> And in case all of this is just a big miscommunication, Natasha suggested that
> Andy Sutton could be invited to speak to the Program (either at a Program
> meeting at the IETF, or during a program telecon).
> 
>