Subject: [Stackevo] Fall-backs and best effort

From: Michael Welzl <[email-masked]>
Date: Thu, 14 Jul 2016 23:37:26 +0200

Hi,

I hesitate to say something for fear of people forcing me to contribute text… please don’t.
I’ll say something anyway:

I looked at draft-iab-protocol-transitions and didn’t find phrases such as “fall-back” or “best effort” in it, and I think that’s a mistake.
See https://wiki.tools.ietf.org/html/rfc7305#section-3.5
and the reference:
https://www.iab.org/wp-content/IAB-uploads/2013/06/itat-2013_submission_8.pdf

Now, finally, "DSCP usage in a best effort style” is beginning to happen with WebRTC (and within it, yet another fall-back is now being discussed) - and IPv6 usage has surely benefitted from Happy Eyeball code? Note this paper on HE in the ANRW workshop:  https://irtf.org/anrw/2016/anrw16-final9.pdf

Personally, I think that the TCP/IP suite is notoriously bad at trying stuff and falling back, which would all be possible in our best effort Internet.
I’m not saying it’s easy to fix but I say it’s an important element when trying to deploy something new.
QUIC has a version negotiation mechanism - this is a way of explicitly incorporating the ability to upgrade the protocol in the design… shouldn’t such mechanisms be discussed in draft-iab-protocol-transitions too?

(and this is where i REALLY don’t volunteer  :-(   apologies!  )

Cheers,
Michael

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Sat, 16 Jul 2016 10:18:41 +0200

Hi, Michael,

On Thu, Jul 14, 2016 at 11:37 PM, Michael Welzl <[email-masked]> wrote:

> I looked at draft-iab-protocol-transitions and didn’t find phrases such as
> “fall-back” or “best effort” in it, and I think that’s a mistake.
> Now, finally, "DSCP usage in a best effort style” is beginning to happen
> with WebRTC (and within it, yet another fall-back is now being discussed) -
> and IPv6 usage has surely benefitted from Happy Eyeball code? Note this
> paper on HE in the ANRW workshop:
> https://irtf.org/anrw/2016/anrw16-final9.pdf
>
> Personally, I think that the TCP/IP suite is notoriously bad at trying
> stuff and falling back, which would all be possible in our best effort
> Internet.
> QUIC has a version negotiation mechanism - this is a way of explicitly
> incorporating the ability to upgrade the protocol in the design… shouldn’t
> such mechanisms be discussed in draft-iab-protocol-transitions too?

Not just for Michael - I hope this question does come up during TSVAREA,
where Mirja and I have Dave speaking on this draft (
https://www.ietf.org/proceedings/96/agenda/agenda-96-tsvarea), with
discussion time to follow (plus, that meeting is on Monday, so we have all
week in the hallway).

Spencer