Subject: [Stackevo] Fwd: question about the 2013's Workshop on Reducing Internet Latency hosted by Internet Society

From: Brian Trammell <[email-masked]>
Date: Tue, 25 Oct 2016 13:35:02 +0200

Hi, all,

I just got this message from Linda Dunbar; the ask is for an IAB workshop on latency, which seems  directed at the Stack Evolution program more than any other.

Personally, I think the transport aspects of this are transitioning to engineering (L4S); I'm not sure what another IAB workshop here would do. Other thoughts?

Cheers,

Brian

> Begin forwarded message:
> 
> From: Linda Dunbar <[email-masked]>
> Subject: question about the 2013's Workshop on Reducing Internet Latency hosted by Internet Society
> Date: 25 October 2016 at 06:48:05 GMT+2
> To: "[email-masked]" <[email-masked]>
> 
> Brian,
> 
> Lately, the industry has been exploring technologies and innovations at various layers to reduce latency. At the upper layer, we have things like QUIC/L4S. At the link layer, we have DETNET, IEEE 802.1 TSN (Time Sensitive Networking), Flex Ethernet (OIF). At the network layer, we have IP/MPLS Hardened pipe (RFC 7625), latency optimized router design, and BBF’s Broadband Assured Services (BAS). <>
> 
> During the discussion with Bob Briscoe on a suggestion to ask IAB to host a workshop to take an architectural oversight on latency from various angles, Bob shared this Reducing Internet Latency workshop hosted by Internet Society 3 years ago. And you were one of the contributors. I find the findings of the workshop was very helpful.
> 
> With the latest development progress on latency, do you think if it is a good time for IAB to have another workshop? To educate the industry of the potentials available.
> 
> With your experience of the workshop 3 years ago, do you have any advices?
> 
> Linda
> 
> From: Bob Briscoe [mailto:[email-masked] <mailto:[email-masked]>]
> Sent: Tuesday, October 18, 2016 12:08 PM
> To: Linda Dunbar <[email-masked] <mailto:[email-masked]>>
> Subject: Re: What do you think of the problem space of Low Latency need across packet network?
> 
> Linda,
> 
> Sorry for missing both your emails about this over the last month.
> 
> Short answer: Yes.
> 
> Longer answer:
> 
> Attendee community
> In 2013, Mat Ford and I organised an action-oriented latency workshop in London (jointly funded by ISOC and the RITE project) with an invited group of experts from industry/academia. I would expect many of those people to be on the list of candidates to invite for an IAB workshop.
> 
> One lesson was to involve someone from the app layer (e.g. HTTP2 folks, VR/AR people) early on, cos none of those invited to be on the organising committee did anything, and none turned up on the day.
> 
> This morning I happen to be on my way to a meeting with Huawei's VR/AR people involved in standards - in London for VR/AR World. I will mention this.
> 
> One problem we would have is that the RITE project is finished, so a number of the attendees would no longer be funded to be working on latency, altho a few of us are apply for further funding.
> 
> Purpose
> Regarding your list of potential topics, I think it's biased too much towards the latency introduced by individual elements, which are easier to solve unilaterally, so it's not really necessary to have any coordination --- companies have generally attacked these areas well anyway. Whereas the main outstanding problems are "whole system", e.g. stuff like caching structure (particularly in the developing world), and e2e queuing.
> 
> A second workshop was planned. A number of the actions identified then have now been done, and I think now it is clearer where the architectural gaps are. Indeed since then we have published this useful survey paper giving the relative sizes of different aspects of latency in different scenarios. See section IX particularly Fig 21 "Reducing Internet Latency: A Survey of Techniques and their Merits <http://www.bobbriscoe.net/pubs.html#latency_survey>".
> 
> I wrote up the outcome in this CCR article:
> http://www.bobbriscoe.net/pubs.html#1309latws-report-ccr <http://www.bobbriscoe.net/pubs.html#1309latws-report-ccr>
> which was a reformatting of the summary written jointly be the attendees, edited by Mat Ford.
> Mat also gave a summary presentation in the Transport Area plenary.
> 
> Summary: Yes, but we need to work on what the purpose of such a workshop would be, so it's not just a talking shop. Focusing on issues that inherently need co-ordination (e.g. cross layer), would be a good start.
> 
> 
> 
> Bob
> 
> On 29/09/16 23:05, Linda Dunbar wrote:
> Bob,
> 
> You’ve done a lot of work in reaching the low latency via network. There are a lot of other SDOs doing work in Link/Port/Node layer to reach low latency.
> 
> Earlier I sent you an inquiry on starting a mailing list, but we think it is more effective for IAB to have an architectural workshop or program on Low Latency service over packet network. IAB would like a list of people who agree the low latency problem space and give a implicit “YES” to participate (and potentially contribute to the topics) when IAB sends out a formal “Call For Participation”.
> 
> Can you look at the following problem space and give your opinion? Specifically, if it is OK to list your name in the list of the people who agree on the problem space?
> 
> Thanks, Linda
> 
> 
> 
> 
> Low Latency Services Provided by Packet Network
> 
> 
> Problem Space
> 
> With the rising of AR/VR and V2V services, there are already technologies developed at different layers to ensure low & deterministic latency, which can be used to build small scale and special purposed low latency networks. However, the deployment of those technologies would be very limited if their technologies can only be used for special purposed networks. The key question is how to carry those low latency services over WAN or internet given various pockets/segments of the network already having some capabilities, so that more services can be delivered.
> 
> Low latency over WAN is obviously more challenging technically than LAN or special purposed networks (like dedicated factory network). Not only WAN has more hops, longer links and various protection/re-route mechanisms which all increase latency, but also more mixed traffic with some being not latency sensitive and mixed nodes with different capabilities. Some problems specific to WAN include how to isolate the various service traffic on a public network, and provide maximum manageability to tenants (or upper layers).
> 
> Here are some examples that require particularly stringent latency requirements, as well as long standing real-time interactive voice and video requirements:
> 
> -    Wireless’ RAN (Radio Access Network), the RRH-BBU traffic etc. (e.g. CPRI interface requires 100 us latency).
> -    CoMP (eX2 interface) requirements of 100s us latency
> -    Augmented / Virtual Reality low latency
> -    V2V control applications with stringent latency and reliability requirements.
> 
> 
> TECHNOLOGIES BEING DEVELOPED
> 
> The industry has been exploring technologies and innovations at various layers to meet these latency requirements. At the upper layer, we have things like QUIC/L4S. At the link layer, we have DETNET, IEEE 802.1 TSN (Time Sensitive Networking), Flex Ethernet (OIF). At the network layer, we have IP/MPLS Hardened pipe (RFC 7625), latency optimized router design, and BBF’s Broadband Assured Services (BAS).
> 
> 
> QUESTIONS
> 
> There are multiple SDOs, multiple layers activities/initiatives in developing technologies to achieve low latency. It would be beneficial to the entire industry to have an architectural oversight across different layers and SDOs on low and deterministic latency across packet network to answer questions like:
> -        Can we provide low latency end-to-end services over the packet network or Internet with mixed traffic and technologies? What are the hops/distance limits for those latency sensitive services over packet networks? At what cost? If Yes, what are the mechanisms needed to be in place to carry those low latency services over WAN or internet given various pockets/segments of the network already having some capabilities?
> 
> -        Are there advantages to be gained from taking a broader view of these different technologies at different layers and how they might interact? For example, is there any value gained by upper layer expressing that they would rather have fixed latency than losing packets? Are there any effective interaction/coordination between upper layer and lower layer to achieve more efficient optimization for latency sensitive services?
> 
> Although the IETF and IEEE 802 are well coordinated, should there be more coordination with other SDOs such as OIF, 3GPP, BBF? Are there gaps that should be addressed?
> 
> 
> WORKSHOP (and Potentially an on-going program)
> 
> Having an industry wide Low Latency workshop can help the world more aware of available technologies in achieving low latency, which can stimulate more technology development in this area and more applications to go through internet, creating a bigger network market.
> 
> Topics could include
> 
> -        Low Latency use cases & requirement (e.g. by 3GPP on use cases and requirement for packet network used for wireless traffic, ITU 2020 IMT use cases and requirement for 5G, or by various application layers use cases).
> 
> -        What can we learn from how low-latency services are provided across specific technologies? This can be provided by various SDOs (e.g. IEEE 802, OIF and others) demonstrating their state of the art advancement in achieving ultra low latency packet transport through a link or a switch, such as OIF’s Flex Ethernet, IEEE802.1’s TSN.
> 
> -        What are the contributing factors that cause latency across packet network: from forwarding delay within a node/segment, the physical layer delay, transmission delay, to protection/reroute delay? What kind of latency characteristics that can be reliably exposed by different layers (from links, ports, network elements or segments, to upper layers)?
> 
> -        Router vendors demonstrating latency optimized router internal architecture, mechanisms in providing minimal latency and their constraints (e.g. the maximum percentage of capacity that can get the minimal latency).
> 
> -        Characterizing different contributing factors that cause latency across packet network: from forwarding delay within a node, the physical layer delay, to transmission delay.
> 
> -        The current practices of latency compensation mechanisms at various layers.
> 
> -        Exploring methods and control plane mechanisms to stitch available technologies to achieve end-to-end low latency across network infrastructure.
> 
> -        Exploring current (and future) tool kits for more optimized interaction between the network and application layers to achieve optimized end-to-end low latency services.
> 
> 
> 
> 
> From: Linda Dunbar
> Sent: Thursday, September 15, 2016 3:55 PM
> To: 'Bob Briscoe'
> Subject: what do you think about having a mailing list for exploring various latency characteristics and control plane mechanisms to achieve end to end low latency across the network?
> 
> Bob,
> With more and more services requiring ultra low latency (such as Cloud RAN front haul, Augmented Reality), we’ve seen technologies and innovations in achieving low latency at various layers, such as the application layer’s QUIC, the link layer’s IEEE802.1 TSN & Flex Ethernet (OIF), latency optimized switch architecture & interface design, the IETF’s DETNET for small scoped industrial networks, and IP/MPLS Hardened pipe (RFC7625).
> 
> With the optimized switching architecture and interface design, IEEE802.1TSN, and Flex Ethernet, it becomes feasible for network elements/segments to expose reliable deterministic upper bound latency.
> 
> What do you think about having an IETF mailing list for people to showcase various latency characteristics that can be exposed by network elements or segments, and to discuss control plane mechanisms for achieving end to end low latency across the network?
> 
> The Scope of work can start with
> 
> –       various latency characteristics that can be exposed by network elements or segments.
> 
> –       methods in determine or/and characterize latency through a network element or a segment.
> 
> –       Latency Optimized Control Plane mechanisms.
> 
> 
> What do you think? Are you willing to be included in the initiative?
> 
> Linda
> 
> 
> 
> --
> ________________________________________________________________
> Bob Briscoe                               http://bobbriscoe.net/ <http://bobbriscoe.net/>

---

From: Ralph Droms <[email-masked]>
Date: Tue, 25 Oct 2016 13:38:27 -0400

I received pretty much the same e-mail from Linda.

My reaction was similar to yours - I'm also not sure what an IAB workshop might contribute on this topic.

- Ralph

> On Oct 25, 2016, at 7:35 AM, Brian Trammell <[email-masked]> wrote:
> 
> Hi, all,
> 
>> Lately, the industry has been exploring technologies and innovations at various layers to reduce latency. At the upper layer, we have things like QUIC/L4S. At the link layer, we have DETNET, IEEE 802.1 TSN (Time Sensitive Networking), Flex Ethernet (OIF). At the network layer, we have IP/MPLS Hardened pipe (RFC 7625), latency optimized router design, and BBF’s Broadband Assured Services (BAS).
>>  
>> From: Bob Briscoe [mailto:[email-masked]] 
>> To: Linda Dunbar <[email-masked]>
>> A second workshop was planned. A number of the actions identified then have now been done, and I think now it is clearer where the architectural gaps are. Indeed since then we have published this useful survey paper giving the relative sizes of different aspects of latency in different scenarios. See section IX particularly Fig 21 "Reducing Internet Latency: A Survey of Techniques and their Merits".
>> 
>> http://www.bobbriscoe.net/pubs.html#1309latws-report-ccr
>> Bob Briscoe                               http://bobbriscoe.net/
> 
> _______________________________________________
> Stackevo mailing list
> [email-masked]
> https://www.iab.org/mailman/listinfo/stackevo

---

From: Ted Hardie <[email-masked]>
Date: Tue, 25 Oct 2016 10:40:32 -0700

There's already an action item to discuss this on the IAB agenda for this
week, because she approached me and Andrew about it some time ago.  I
suspect other folks are getting queries because we said we'd be looking for
interested IAB folks.  But let's discuss tomorrow,

Ted

On Tue, Oct 25, 2016 at 10:38 AM, Ralph Droms <[email-masked]> wrote:

> > I just got this message from Linda Dunbar; the ask is for an IAB
> workshop on latency, which seems  directed at the Stack Evolution program
> more than any other.
> >
> > Personally, I think the transport aspects of this are transitioning to
> engineering (L4S); I'm not sure what another IAB workshop here would do.
> Other thoughts?
> >
> > Cheers,
> >
> > Brian
> >
> >
> >> Begin forwarded message:
> >>
> >> Lately, the industry has been exploring technologies and innovations at
> various layers to reduce latency. At the upper layer, we have things like
> QUIC/L4S. At the link layer, we have DETNET, IEEE 802.1 TSN (Time Sensitive
> Networking), Flex Ethernet (OIF). At the network layer, we have IP/MPLS
> Hardened pipe (RFC 7625), latency optimized router design, and BBF’s
> Broadband Assured Services (BAS).
> >>
> >> During the discussion with Bob Briscoe on a suggestion to ask IAB to
> host a workshop to take an architectural oversight on latency from various
> angles, Bob shared this Reducing Internet Latency workshop hosted by
> Internet Society 3 years ago. And you were one of the contributors. I find
> the findings of the workshop was very helpful.
> >>
> >> With the latest development progress on latency, do you think if it is
> a good time for IAB to have another workshop? To educate the industry of
> the potentials available.
> >>
> >> In 2013, Mat Ford and I organised an action-oriented latency workshop
> in London (jointly funded by ISOC and the RITE project) with an invited
> group of experts from industry/academia. I would expect many of those
> people to be on the list of candidates to invite for an IAB workshop.
> >>
> >> One lesson was to involve someone from the app layer (e.g. HTTP2 folks,
> VR/AR people) early on, cos none of those invited to be on the organising
> committee did anything, and none turned up on the day.
> >>
> >> This morning I happen to be on my way to a meeting with Huawei's VR/AR
> people involved in standards - in London for VR/AR World. I will mention
> this.
> >>
> >> One problem we would have is that the RITE project is finished, so a
> number of the attendees would no longer be funded to be working on latency,
> altho a few of us are apply for further funding.
> >>
> >> Purpose
> >> Regarding your list of potential topics, I think it's biased too much
> towards the latency introduced by individual elements, which are easier to
> solve unilaterally, so it's not really necessary to have any coordination
> --- companies have generally attacked these areas well anyway. Whereas the
> main outstanding problems are "whole system", e.g. stuff like caching
> structure (particularly in the developing world), and e2e queuing.
> >>
> >> A second workshop was planned. A number of the actions identified then
> have now been done, and I think now it is clearer where the architectural
> gaps are. Indeed since then we have published this useful survey paper
> giving the relative sizes of different aspects of latency in different
> scenarios. See section IX particularly Fig 21 "Reducing Internet Latency: A
> Survey of Techniques and their Merits".
> >>
> >> Summary: Yes, but we need to work on what the purpose of such a
> workshop would be, so it's not just a talking shop. Focusing on issues that
> inherently need co-ordination (e.g. cross layer), would be a good start.
> >>
> >>
> >>
> >> Bob
> >>
> >> You’ve done a lot of work in reaching the low latency via network.
> There are a lot of other SDOs doing work in Link/Port/Node layer to reach
> low latency.
> >>
> >> Earlier I sent you an inquiry on starting a mailing list, but we think
> it is more effective for IAB to have an architectural workshop or program
> on Low Latency service over packet network. IAB would like a list of people
> who agree the low latency problem space and give a implicit “YES” to
> participate (and potentially contribute to the topics) when IAB sends out a
> formal “Call For Participation”.
> >>
> >> Can you look at the following problem space and give your opinion?
> Specifically, if it is OK to list your name in the list of the people who
> agree on the problem space?
> >>
> >> Thanks, Linda
> >>
> >>
> >>
> >>
> >> With the rising of AR/VR and V2V services, there are already
> technologies developed at different layers to ensure low & deterministic
> latency, which can be used to build small scale and special purposed low
> latency networks. However, the deployment of those technologies would be
> very limited if their technologies can only be used for special purposed
> networks. The key question is how to carry those low latency services over
> WAN or internet given various pockets/segments of the network already
> having some capabilities, so that more services can be delivered.
> >>
> >> Low latency over WAN is obviously more challenging technically than LAN
> or special purposed networks (like dedicated factory network). Not only WAN
> has more hops, longer links and various protection/re-route mechanisms
> which all increase latency, but also more mixed traffic with some being not
> latency sensitive and mixed nodes with different capabilities. Some
> problems specific to WAN include how to isolate the various service traffic
> on a public network, and provide maximum manageability to tenants (or upper
> layers).
> >>
> >> Here are some examples that require particularly stringent latency
> requirements, as well as long standing real-time interactive voice and
> video requirements:
> >>
> >> -    Wireless’ RAN (Radio Access Network), the RRH-BBU traffic etc.
> (e.g. CPRI interface requires 100 us latency).
> >> The industry has been exploring technologies and innovations at various
> layers to meet these latency requirements. At the upper layer, we have
> things like QUIC/L4S. At the link layer, we have DETNET, IEEE 802.1 TSN
> (Time Sensitive Networking), Flex Ethernet (OIF). At the network layer, we
> have IP/MPLS Hardened pipe (RFC 7625), latency optimized router design, and
> BBF’s Broadband Assured Services (BAS).
> >>
> >>
> >> QUESTIONS
> >>
> >> There are multiple SDOs, multiple layers activities/initiatives in
> developing technologies to achieve low latency. It would be beneficial to
> the entire industry to have an architectural oversight across different
> layers and SDOs on low and deterministic latency across packet network to
> answer questions like:
> >> -        Can we provide low latency end-to-end services over the packet
> network or Internet with mixed traffic and technologies? What are the
> hops/distance limits for those latency sensitive services over packet
> networks? At what cost? If Yes, what are the mechanisms needed to be in
> place to carry those low latency services over WAN or internet given
> various pockets/segments of the network already having some capabilities?
> >>
> >> -        Are there advantages to be gained from taking a broader view
> of these different technologies at different layers and how they might
> interact? For example, is there any value gained by upper layer expressing
> that they would rather have fixed latency than losing packets? Are there
> any effective interaction/coordination between upper layer and lower layer
> to achieve more efficient optimization for latency sensitive services?
> >>
> >> Although the IETF and IEEE 802 are well coordinated, should there be
> more coordination with other SDOs such as OIF, 3GPP, BBF? Are there gaps
> that should be addressed?
> >>
> >>
> >> Having an industry wide Low Latency workshop can help the world more
> aware of available technologies in achieving low latency, which can
> stimulate more technology development in this area and more applications to
> go through internet, creating a bigger network market.
> >>
> >> Topics could include
> >>
> >> -        Low Latency use cases & requirement (e.g. by 3GPP on use cases
> and requirement for packet network used for wireless traffic, ITU 2020 IMT
> use cases and requirement for 5G, or by various application layers use
> cases).
> >>
> >> -        What can we learn from how low-latency services are provided
> across specific technologies? This can be provided by various SDOs (e.g.
> IEEE 802, OIF and others) demonstrating their state of the art advancement
> in achieving ultra low latency packet transport through a link or a switch,
> such as OIF’s Flex Ethernet, IEEE802.1’s TSN.
> >>
> >> -        What are the contributing factors that cause latency across
> packet network: from forwarding delay within a node/segment, the physical
> layer delay, transmission delay, to protection/reroute delay? What kind of
> latency characteristics that can be reliably exposed by different layers
> (from links, ports, network elements or segments, to upper layers)?
> >>
> >> -        Router vendors demonstrating latency optimized router internal
> architecture, mechanisms in providing minimal latency and their constraints
> (e.g. the maximum percentage of capacity that can get the minimal latency).
> >>
> >> -        Characterizing different contributing factors that cause
> latency across packet network: from forwarding delay within a node, the
> physical layer delay, to transmission delay.
> >>
> >> -        Exploring methods and control plane mechanisms to stitch
> available technologies to achieve end-to-end low latency across network
> infrastructure.
> >>
> >> -        Exploring current (and future) tool kits for more optimized
> interaction between the network and application layers to achieve optimized
> end-to-end low latency services.
> >>
> >>
> >>
> >>
> >> From: Linda Dunbar
> >> Subject: what do you think about having a mailing list for exploring
> various latency characteristics and control plane mechanisms to achieve end
> to end low latency across the network?
> >>
> >> Bob,
> >> With more and more services requiring ultra low latency (such as Cloud
> RAN front haul, Augmented Reality), we’ve seen technologies and innovations
> in achieving low latency at various layers, such as the application layer’s
> QUIC, the link layer’s IEEE802.1 TSN & Flex Ethernet (OIF), latency
> optimized switch architecture & interface design, the IETF’s DETNET for
> small scoped industrial networks, and IP/MPLS Hardened pipe (RFC7625).
> >>
> >> With the optimized switching architecture and interface design,
> IEEE802.1TSN, and Flex Ethernet, it becomes feasible for network
> elements/segments to expose reliable deterministic upper bound latency.
> >>
> >> What do you think about having an IETF mailing list for people to
> showcase various latency characteristics that can be exposed by network
> elements or segments, and to discuss control plane mechanisms for achieving
> end to end low latency across the network?
> >>

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Tue, 25 Oct 2016 14:42:47 -0500

Hi, Brian,

On Tue, Oct 25, 2016 at 6:35 AM, Brian Trammell <[email-masked]> wrote:

> Hi, all,
>
> I just got this message from Linda Dunbar; the ask is for an IAB workshop
> on latency, which seems  directed at the Stack Evolution program more than
> any other.
>

I'm sure the IAB will do the right thing, but as you folks figure out what
that is ...

I'd agree that many transport aspects of this topic are well into the
engineering domain.

I was reading Linda's note as more like

   - A lot of people in multiple working groups in multiple areas plus
   multiple other SDOs are working on various parts of this problem, with
   varying amounts of coordination between those people.
   - Taken together, do those efforts solve the problem sufficiently?
   - If anything else is needed, what would that be?

I'm carefully not expressing an opinion about whether an IAB workshop is
the right way to have that conversation, of course.

Thanks,

Spencer

> Cheers,
>
> Brian
>
>
> Begin forwarded message:
>
> *From: *Linda Dunbar <[email-masked]>
> *Subject: **question about the 2013's Workshop on Reducing Internet
> Latency hosted by Internet Society*
> *Date: *25 October 2016 at 06:48:05 GMT+2
> *To: *"[email-masked]" <[email-masked]>
>
> Brian,
>
> During the discussion with Bob Briscoe on a suggestion to ask IAB to host
> a workshop to take an architectural oversight on latency from various
> With the latest development progress on latency, do you think if it is a
> good time for IAB to have another workshop? To educate the industry of the
> potentials available.
>
> *From:* Bob Briscoe [mailto:[email-masked] <[email-masked]>]
> *Sent:* Tuesday, October 18, 2016 12:08 PM
> *To:* Linda Dunbar <[email-masked]>
> *Subject:* Re: What do you think of the problem space of Low Latency need
> across packet network?
>
>
> Linda,
>
> *Attendee community*In 2013, Mat Ford and I organised an action-oriented
> latency workshop in London (jointly funded by ISOC and the RITE project)
> with an invited group of experts from industry/academia. I would expect
> many of those people to be on the list of candidates to invite for an IAB
> workshop.
>
> *Purpose*Regarding your list of potential topics, I think it's biased too
> much towards the latency introduced by individual elements, which are
> easier to solve unilaterally, so it's not really necessary to have any
> coordination --- companies have generally attacked these areas well anyway.
> Whereas the main outstanding problems are "whole system", e.g. stuff like
> caching structure (particularly in the developing world), and e2e queuing.
>
> scenarios. See section IX particularly Fig 21 "Reducing Internet Latency:
> A Survey of Techniques and their Merits
> <http://www.bobbriscoe.net/pubs.html#latency_survey>".
>
> *Summary:* Yes, but we need to work on what the purpose of such a
> You’ve done a lot of work in reaching the low latency via network. There
> are a lot of other SDOs doing work in Link/Port/Node layer to reach low
> latency.
>
> Earlier I sent you an inquiry on starting a mailing list, but we think it
> is more effective for IAB to have an architectural workshop or program on
> Low Latency service over packet network. IAB would like a list of people
> *Low Latency Services Provided by Packet Network*
>
>
> *Problem Space*
>
> With the rising of AR/VR and V2V services, there are already technologies
> developed at different layers to ensure low & deterministic latency, which
> can be used to build small scale and special purposed low latency networks.
> However, the deployment of those technologies would be very limited if
> their technologies can only be used for special purposed networks. The
> key question is how to carry those low latency services over WAN or
> internet given various pockets/segments of the network already having some
> capabilities, so that more services can be delivered.
>
> Low latency over WAN is obviously more challenging technically than LAN or
> special purposed networks (like dedicated factory network). Not only WAN
> *TECHNOLOGIES BEING DEVELOPED*
>
> *QUESTIONS*
> -        Are there advantages to be gained from taking a broader view of
> these different technologies at different layers and how they might
> Although the IETF and IEEE 802 are well coordinated, should there be more
> coordination with other SDOs such as OIF, 3GPP, BBF? Are there gaps that
> should be addressed?
>
>
> *WORKSHOP (and Potentially an on-going program)*
>
> Having an industry wide Low Latency workshop can help the world more aware
> of available technologies in achieving low latency, which can stimulate
> more technology development in this area and more applications to go
> through internet, creating a bigger network market.
>
> Topics could include
>
> -        Characterizing different contributing factors that cause latency
> across packet network: from forwarding delay within a node, the physical
> layer delay, to transmission delay.
>
> *From:* Linda Dunbar
> *Sent:* Thursday, September 15, 2016 3:55 PM
> *To:* 'Bob Briscoe'
> *Subject:* what do you think about having a mailing list for exploring
> With more and more services requiring ultra low latency (such as Cloud RAN
> front haul, Augmented Reality), we’ve seen technologies and innovations in
> achieving low latency at various layers, such as the application layer’s
> What do you think about having an IETF mailing list for people to showcase
> various latency characteristics that can be exposed by network elements or
> segments, and to discuss control plane mechanisms for achieving end to end
> low latency across the network?
>