Subject: [Stackevo] FW: draft-iab-protocol-transitions-05.txt

From: Dave Thaler <[email-masked]>
Date: Tue, 21 Feb 2017 21:58:06 +0000

Forwarding Cameron's feedback to the IAB and the Stackevo program

-----Original Message-----
From: Dave Thaler 
Sent: Tuesday, February 21, 2017 1:42 PM
To: 'Byrne, Cameron' <[email-masked]>
Cc: Lee Howard <[email-masked]>
Subject: RE: draft-iab-protocol-transitions-05.txt

Most of the IPv6 text was written by Lee (I'm the editor), so cc'ing him.

I agree that the key was getting multiple competitors to do it simultaneously.

-----Original Message-----
From: Byrne, Cameron [mailto:[email-masked]] 
Sent: Tuesday, February 21, 2017 1:07 PM
To: Dave Thaler <[email-masked]>
Subject: draft-iab-protocol-transitions-05.txt

Dave,

I consider myself one of the early instigators of world ipv6 day, if not the earliest.  I floated the idea at an isoc  event / round table in Seattle.  The problem was economic, not technical. And, your i-d should emphasize that. The altruistic dual-stack approach failed, and economic market forces slowed adoption as each actor waited for someone else to absorb the cost of launching ipv6. 

In 2011, there was the common belief that launching ipv6 would break ~1% of users

I heard yahoo and google say their primary impediment of launching was they could not break 1% of users and lose 1% of revenue because customers have zero loyalty and zero economic switching cost. If google fails, use bing. If yahoo fails use google, and so on.  Nobody wanted to give 1% to their competitor in the name of IPv6.

So the reward for launching ipv6 early was a gift to your competitors. This was a business deal breaker. 

The genius of world ipv6 launch is that an anti-competitive monopoly / union was formed.  But yahoo, google, and bing all enabling ipv6 at the same time, the cost of failure was not transferred between competitors, the cost of failing ipv6 was passed to the consumer. Consumers with broke ipv6 connectivity could not pursue a zero cost switch to a competitor.  Bing, yahoo, and google were all broken at the same time to a user with impaired ipv6. The user has to accept the issue was on their end , and the consumer had to assume the cost of fixing (disabled ipv6 on the pc ...).

Economic incentives to reduce latency also pushed SPDY / QUIC / HTTP2.  It is well known folk-lore in tech that decreasing latency drives up revenue, the business approves of these methods.  

----------------
Cameron Byrne
425-444-1965

---

From: Dave Thaler <[email-masked]>
Date: Tue, 21 Feb 2017 22:56:44 +0000

I am adding additional text to the "Communicating the Plan" section to address Cameron's
feedback (along with previous comments from Dave Crocker and Eliot Lear whose comments
on this section were incorporated into the version already on github).

The proposed updated section would read:

	Communicating the Plan

	Many of the entities involved in a protocol transition may not
               be aware of the IETF or the RFC series, so dissemination
               through other channels is key for sufficiently broad
               communication of the transition plan. While flag days are
               impractical at Internet scale, coordinated "events" such as
               World IPv6 Launch may improve general awareness of an ongoing
               transition.

	Also, there is often a need for an entity facilitating the transition
               through advocacy and focus. Such an entity, independent of the IETF,
               can be key in communicating the plan and its progress.

	Some transitions have a risk of breaking backwards compatibility
               for some fraction of users.  In such a case, when a transition
               affects competing entities facing the risk of losing customers to
               each other, there is an economic disincentive to transition.  Thus,
               one role for a facilitating entity is to get competitors to transition
               during the same timeframe, so as to mitigate this fear.  For example,
               ISOC's role in making World IPv6 Launch successful was largely due to
               this reason.

-----Original Message-----
From: Byrne, Cameron [mailto:[email-masked]] 
Sent: Tuesday, February 21, 2017 1:07 PM
To: Dave Thaler <[email-masked]>
Subject: draft-iab-protocol-transitions-05.txt

Dave,

----------------
Cameron Byrne
425-444-1965

---

From: Martin Thomson <[email-masked]>
Date: Wed, 22 Feb 2017 13:27:38 +1100

FWIW, we've found that this works well when you are able to agree with
your competitors that a particular change is worth doing despite the
potential for it to cause an early mover to lose users.  We did this
when we turned off SSL version 3.  All browsers moved within a few
weeks of each other.

Not sure if it's worth all that text though.  The point is simple:
competitors can still see advantages from a new technology despite the
risks/costs if they are willing to coordinate on a transition
timeframe.  That might require external help (a facilitator), or they
might be able to agree as a group.

> For example, ISOC's role in making World IPv6 Launch successful was largely due to this reason.

I don't actually understand what the last sentence actually means.  Is
this that ISOC was critical as a facilitator?  Is it that ISOC thought
that being a facilitator was critical?

On 22 February 2017 at 09:56, Dave Thaler <[email-masked]> wrote:
> _______________________________________________
> Stackevo mailing list
> [email-masked]
> https://www.iab.org/mailman/listinfo/stackevo

---

From: Dave Thaler <[email-masked]>
Date: Wed, 22 Feb 2017 02:29:37 +0000

-----Original Message-----
From: Martin Thomson [mailto:[email-masked]]
Sent: Tuesday, February 21, 2017 6:28 PM
To: Dave Thaler <[email-masked]>
Cc: Stackevo <[email-masked]>; Lee Howard <[email-masked]>
Subject: Re: [Stackevo] draft-iab-protocol-transitions-05.txt

FWIW, we've found that this works well when you are able to agree with your competitors that a particular change is worth doing despite the potential for it to cause an early mover to lose users.  We did this when we turned off SSL version 3.  All browsers moved within a few weeks of each other.

competitors can still see advantages from a new technology despite the risks/costs if they are willing to coordinate on a transition timeframe.  That might require external help (a facilitator), or they might be able to agree as a group.

> For example, ISOC's role in making World IPv6 Launch successful was largely due to this reason.

I don't actually understand what the last sentence actually means.  Is this that ISOC was critical as a facilitator?  Is it that ISOC thought that being a facilitator was critical?

Yeah it was confusingly worded.  I reworded the last sentence before submitting -06, to read:

For example, the success of World IPv6 Launch was largely due to ISOC playing this role.

Dave