Subject: [Stackevo] Stackevo program meeting minutes + interim program meeting

From: Brian Trammell (IETF) <[email-masked]>
Date: Tue, 25 Jul 2017 14:41:30 +0200

Greetings, all,

Two points; first, some draft minutes from the stackevo program meeting in Prague appear below; I'd like to post these on our website, so if there's something missing (or too detailed) here please let me know.

Second, let's pick a time to do an interim program meeting, agenda TBD, in early September:

http://doodle.com/poll/dsimhqxazbifg966

The times are at 20:00 UTC to minimize pain of attendance on the Sydney - West Coast - East Coast - Europe axis.

---

IP Stack Evolution Program Meeting
18 July 2017
Prague

Attending:

Jari Arkko
Spencer Dawkins
Aaron Falk
Lee Howard
Suresh Krishnan
Mirja Kuehlewind
Gabriel Montenegro
Cindy Morgan (scribe)
Erik Nordmark
Mark Nottingham
Thomas Pauly (invited visitor)
Natasha Rooney
Jeff Tantsura
Dave Thaler
Martin Thomson
Brian Trammell

1. Path Signals Draft:

The program will investigate the possibility of turning its work on path signals (draft-hardie-path-signals) into a short IAB document / IAB statement saying, essentially, that explicitness is preferable to implicitness in information exposure to the network; and a longer document digging into the specifics of path signals within the Path Aware Networking proposed RG, which had its first meeting as a PRG in Prague.

2. Following up from MaRNEW:

The draft workshop report draft-iab-marnew-report needs an update to reflect developments since the workshop, and there has been some community feedback that still needs addressing. Spencer Dawkins will serve as co-editor with Natasha Rooney to complete this document. The program discussed the continuing tension between increasing encryption and network management needs, noting that 5G requirements will make more use of different bearers for IP traffic.

3. Endpoint draft (https://github.com/stackevo/endpoint-draft)

The program discussed a proposed draft that started at the Montreal IAB retreat on the definition of an endpoint. It was agreed that the current framing is not particularly useful, but that the discussion will continue on the program list, and at an upcoming interim meeting.

ACTION ITEMS
-------------

- Natasha to push the latest version of the MaRNEW workshop report to GitHub.

- Brian to send out Doodle poll to schedule a midterm Stackevo Program call. (see above)

- Brian to figure out how to get GitHub notifications sent to the Stackevo list automatically (still working on it)

---

From: Eliot Lear <[email-masked]>
Date: Tue, 25 Jul 2017 14:57:56 +0200

Hi Brian,

I apologize for not being able to be there.  I have a question or two
for the group, and perhaps you may wish to ask the board for some
additional details:

We started this discussion on list, but the notion of an endpoint is
something of a matter of perspective.  So for instance, an endpoint
could be-

  * An interface on an IP-based network element;
  * The IP-based network element itself;
  * <<SOME>> device or its CPU;
  * the identity of an network element, regardless of where it sits (IP,
    non-IP, inside a box, etc);
  * And many more things...

It seems to me that there are two ways the IAB might wish to consider
this question:

 1. A single definitive answer within the bounds of some purpose; or
 2. Multiple answers that might all begin with the phrase, “For the
    purpose of...” or some such.

It might be also good to draw out a few questions, such as-

  * What is the relationship between the endpoint's identity and various
    functions, including security context and transport protocol context?
  * What does mobility mean to an endpoint?  Consider various forms of
    mobility, including physical, virtual mobility and process
    migration.  This is probably where the NSRG document is the
    strongest, even if it is dusty, because of the orthonogalities it
    discusses.
  * What are the scaling implications of each definition?

What would the IAB like, and what in particular are they *not* looking for?

Regards,

Eliot

On 7/25/17 2:41 PM, Brian Trammell (IETF) wrote:
> _______________________________________________
> Stackevo mailing list
> [email-masked]
> https://www.iab.org/mailman/listinfo/stackevo

---

From: Robert Sparks <[email-masked]>
Date: Thu, 27 Jul 2017 15:28:24 -0500

On the Marnew report:

The "reflect developments since the workshop" comment is a red-flag - 
apologies if this was already discussed (I had a conflict for the 
meeting in Prague).

A workshop report should talk about the workshop, not what happened 
after the workshop (unless it is immediate followup on actions taken at 
the workshop). Trying to encompass related things that have happened in 
the many months since the workshop was held isn't the right thing to do. 
If there are things that need to be said on that front, perhaps it 
should be said in a different place?

RjS

---

From: "Brian Trammell (IETF)" <[email-masked]>
Date: Thu, 27 Jul 2017 16:31:32 -0400

hi Robert,

> On 27 Jul 2017, at 16:28, Robert Sparks <[email-masked]> wrote:
> 
> On the Marnew report:
> 
> The "reflect developments since the workshop" comment is a red-flag - apologies if this was already discussed (I had a conflict for the meeting in Prague).
> 
> A workshop report should talk about the workshop, not what happened after the workshop (unless it is immediate followup on actions taken at the workshop). Trying to encompass related things that have happened in the many months since the workshop was held isn't the right thing to do. If there are things that need to be said on that front, perhaps it should be said in a different place?

This means less than it sounds like: there's a lot of language that says things will happen. Some of them HAVE happened, some haven't. Section 8, next steps, needs editing.

Cheers,

Brian

>> 3. Endpoint draft (
>> https://github.com/stackevo/endpoint-draft
>> )
>>