Subject: [Stackevo] meeting in Bangkok?

From: "Brian Trammell (IETF)" <[email-masked]>
Date: Wed, 3 Oct 2018 23:43:23 +0200

Greetings, all,

It's time to start (finish) planning the agenda for IETF 103 in Bangkok. The last two IETF meetings, we've had very little in the way of a formal agenda but scheduled a meeting anyway and had a discussion that, if not extremely productive, was always interesting.

I won't be in Bangkok -- my second child is due sometime during the hackathon, so I doubt I'll even be able to be remote -- so if someone would like to lead a stackevo all-topics meeting, please let me know and (if the volunteer is a non-IAB program member) I can work to get it  scheduled.

Cheers,

Brian

---

From: Tommy Pauly <[email-masked]>
Date: Wed, 10 Oct 2018 08:39:26 -0700

Hello stackevo,

For those of us who will be at IETF 103, I think it would be useful to have a discussion! So, let's figure out when we can all actually meet =)

Please respond to this email indicating which times you'd be available or not to have a meeting in Bangkok. Let's start with the following options:

Monday 11/5 - 8am breakfast
Tuesday 11/6 - 8am breakfast
Wednesday 11/7 - 8am breakfast
Thursday 11/8 - 8am breakfast
Friday 11/9 - Morning, somewhere between 8am-10am
Friday 11/9 - Afternoon, somewhere between 12pm-onwards

Best,
Tommy

> On Oct 3, 2018, at 2:43 PM, Brian Trammell (IETF) <[email-masked]> wrote:
> 
> Greetings, all,
> 
> _______________________________________________
> Stackevo mailing list
> [email-masked]
> https://www.iab.org/mailman/listinfo/stackevo

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Wed, 10 Oct 2018 14:02:53 -0500

Hi, Tommy,

On Wed, Oct 10, 2018 at 10:39 AM Tommy Pauly <[email-masked]> wrote:

> Hello stackevo,
>
> For those of us who will be at IETF 103, I think it would be useful to
> have a discussion! So, let's figure out when we can all actually meet =)
>
> Please respond to this email indicating which times you'd be available or
> not to have a meeting in Bangkok. Let's start with the following options:
>

The IESG has this slot, so ADs would not be present.

> Wednesday 11/7 - 8am breakfast

The IESG has this slot, so ADs would not be present.

> Friday 11/9 - Afternoon, somewhere between 12pm-onwards

The IESG and IAB are trying to figure out when we will actually have the
Week in Review session that is usually after the last session on Friday. I
don't know what the IAB is thinking (the IAB members would), but the IESG
is supposed to talk about this on tomorrow's telechat.

So I'm all in for Tuesday or Thursday, and for whatever slot on Friday the
IESG and IAB aren't occupying.

Of course, meeting without us could be a bug, or a feature. Make good
choices ;-)

Spencer

> > It's time to start (finish) planning the agenda for IETF 103 in Bangkok.
> The last two IETF meetings, we've had very little in the way of a formal
> agenda but scheduled a meeting anyway and had a discussion that, if not
> extremely productive, was always interesting.
> >
> > I won't be in Bangkok -- my second child is due sometime during the
> hackathon, so I doubt I'll even be able to be remote -- so if someone would
> like to lead a stackevo all-topics meeting, please let me know and (if the
> volunteer is a non-IAB program member) I can work to get it  scheduled.
> >
> > Cheers,
> >
> > Brian

---

From: Ted Hardie <[email-masked]>
Date: Wed, 10 Oct 2018 12:16:33 -0700

On Wed, Oct 10, 2018 at 12:03 PM Spencer Dawkins at IETF <
[email-masked]> wrote:

> is supposed to talk about this on tomorrow's telechat..
>
>
The original plan was to have it between 10:00 and 11:30 on Friday (so
folks could either sleep in or have breakfast meetings), so that's
nominally what the IAB is thinking.  I understand that the IESG is
reconsidering after some questions on side meetings came up, but I asked
Tommy to hold that slot aside because of the original plan.   If the plan
shifts, this will need to get folded into the schedule planning.

If folks are okay missing the WG chairs lunch, Wednesday lunch may also be
a possibility.

Ted

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Wed, 10 Oct 2018 14:34:30 -0500

Hi, Ted,

> shifts, this will need to get folded into the schedule planning.

Thanks for the clues - and I wasn't sure what IESG discussion had made it
to the IAB. You and Tommy definitely handled this correctly - I hope that
was clear in my note.

Spencer

---

From: Tommy Pauly <[email-masked]>
Date: Fri, 19 Oct 2018 10:35:00 -0700

Thanks, Spencer!

So, it looks like the best options are Tuesday breakfast, Thursday breakfast, or Friday (late?) breakfast.

If you have a conflict with one of those, please reply, otherwise we can just select one of those to meet.

Best,
Tommy

> On Oct 10, 2018, at 12:34 PM, Spencer Dawkins at IETF <[email-masked]> wrote:
> 
> Hi, Ted, 
> 
> On Wed, Oct 10, 2018 at 2:17 PM Ted Hardie <[email-masked] <mailto:[email-masked]>> wrote:
> On Wed, Oct 10, 2018 at 12:03 PM Spencer Dawkins at IETF <[email-masked] <mailto:[email-masked]>> wrote:
> Hi, Tommy, 
> 
> The IESG and IAB are trying to figure out when we will actually have the Week in Review session that is usually after the last session on Friday. I don't know what the IAB is thinking (the IAB members would), but the IESG is supposed to talk about this on tomorrow's telechat.. 
> 
> 
> The original plan was to have it between 10:00 and 11:30 on Friday (so folks could either sleep in or have breakfast meetings), so that's nominally what the IAB is thinking.  I understand that the IESG is reconsidering after some questions on side meetings came up, but I asked Tommy to hold that slot aside because of the original plan.   If the plan shifts, this will need to get folded into the schedule planning.
> 
> Thanks for the clues - and I wasn't sure what IESG discussion had made it to the IAB. You and Tommy definitely handled this correctly - I hope that was clear in my note.
> 
> Spencer
>  
> If folks are okay missing the WG chairs lunch, Wednesday lunch may also be a possibility.
> 
> Ted
> 
> So I'm all in for Tuesday or Thursday, and for whatever slot on Friday the IESG and IAB aren't occupying. 
> 
> Of course, meeting without us could be a bug, or a feature. Make good choices ;-)
> 
> Spencer
>

---

From: Mirja Kühlewind <[email-masked]>
Date: Mon, 22 Oct 2018 12:11:02 +0200

Ted, when are the IAB breakfast meeting?

I’m usually more awake Tuesday breakfast than Thursday breakfast, so I would go for that option if the IAB does not have a breakfast there…

Mirja

> Am 19.10.2018 um 19:35 schrieb Tommy Pauly <[email-masked]>:
> 
> Thanks, Spencer!
> 
>> On Wed, Oct 10, 2018 at 12:03 PM Spencer Dawkins at IETF <[email-masked]> wrote:
>> Hi, Tommy, 
>>

---

From: Ted Hardie <[email-masked]>
Date: Mon, 22 Oct 2018 08:19:12 -0700

Monday and Thursday are the scheduled breakfasts, LLC is Tuesday, taking
over the IAOC slot.

Ted

Mobile/Terse

On Mon, Oct 22, 2018 at 3:11 AM Mirja Kühlewind <
[email-masked]> wrote:

> I’m usually more awake Tuesday breakfast than Thursday breakfast, so I
> would go for that option if the IAB does not have a breakfast there…
>
> Mirja
>
>
>
> >> The IESG and IAB are trying to figure out when we will actually have
> the Week in Review session that is usually after the last session on
> Friday. I don't know what the IAB is thinking (the IAB members would), but
> the IESG is supposed to talk about this on tomorrow's telechat..
> >>
> >>
> >> Thanks for the clues - and I wasn't sure what IESG discussion had made
> it to the IAB. You and Tommy definitely handled this correctly - I hope
> that was clear in my note.
> >>
> >> Spencer
> >>

---

From: Mirja Kühlewind <[email-masked]>
Date: Mon, 22 Oct 2018 17:22:51 +0200

:-( 

Wednesday lunch then?

> Am 22.10.2018 um 17:19 schrieb Ted Hardie <[email-masked]>:
> 
> Monday and Thursday are the scheduled breakfasts, LLC is Tuesday, taking over the IAOC slot.
> 
> Ted
> 
> Mobile/Terse
> 
> On Mon, Oct 22, 2018 at 3:11 AM Mirja Kühlewind <[email-masked]> wrote:

---

From: "Aaron Falk" <[email-masked]>
Date: Mon, 22 Oct 2018 11:27:16 -0400

Works for me.

On 22 Oct 2018, at 11:22, Mirja Kühlewind wrote:

>> I’m usually more awake Tuesday breakfast than Thursday breakfast, 
>> so I would go for that option if the IAB does not have a breakfast 
>> there…
>>
>> Mirja
>>
>>
>>
>>>> The IESG and IAB are trying to figure out when we will actually 
>>>> have the Week in Review session that is usually after the last 
>>>> session on Friday. I don't know what the IAB is thinking (the IAB 
>>>> members would), but the IESG is supposed to talk about this on 
>>>> tomorrow's telechat..
>>>>
>>>>
>>>> The original plan was to have it between 10:00 and 11:30 on Friday 
>>>> (so folks could either sleep in or have breakfast meetings), so 
>>>> that's nominally what the IAB is thinking.  I understand that the 
>>>> IESG is reconsidering after some questions on side meetings came 
>>>> up, but I asked Tommy to hold that slot aside because of the 
>>>> original plan.   If the plan shifts, this will need to get folded 
>>>> into the schedule planning.
>>>>
>>>> Thanks for the clues - and I wasn't sure what IESG discussion had 
>>>> made it to the IAB. You and Tommy definitely handled this correctly 
>>>> - I hope that was clear in my note.
>>>>
>>>> Spencer
>>>>
>>>> So I'm all in for Tuesday or Thursday, and for whatever slot on 
>>>> Friday the IESG and IAB aren't occupying.
>>>>

---

From: Tommy Pauly <[email-masked]>
Date: Wed, 24 Oct 2018 06:36:26 -0700

Wednesday lunch works for me too. That does conflict with the WG chair forum—would that be a hard blocker for anyone?

It looks like the IAB room also may not be available then so we’d need to find a space. 

Tommy

> On Oct 22, 2018, at 8:27 AM, Aaron Falk <[email-masked]> wrote:
> 
> Works for me.
>

---

From: "Brian Trammell (IETF)" <[email-masked]>
Date: Wed, 24 Oct 2018 15:38:03 +0200

We often do Wednesday lunches, WG chair forum notwithstanding.

> On 24 Oct 2018, at 15:36, Tommy Pauly <[email-masked]> wrote:
>

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Wed, 24 Oct 2018 08:42:36 -0500

Brian/Tommy,

On Wed, Oct 24, 2018 at 8:38 AM Brian Trammell (IETF) <[email-masked]>
wrote:

> > Wednesday lunch works for me too. That does conflict with the WG chair
> forum—would that be a hard blocker for anyone?
> >

The IESG room is available. Want me to grab it?

Spencer

---

From: "Brian Trammell (IETF)" <[email-masked]>
Date: Wed, 24 Oct 2018 15:43:49 +0200

yeah, let's do this, and hand it back if we find other space. thanks!

> On 24 Oct 2018, at 15:42, Spencer Dawkins at IETF <[email-masked]> wrote:
> 
> Brian/Tommy,
> 
> On Wed, Oct 24, 2018 at 8:38 AM Brian Trammell (IETF) <[email-masked]> wrote:

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Wed, 24 Oct 2018 08:50:31 -0500

> yeah, let's do this, and hand it back if we find other space. thanks!

I grabbed it from 12:30 to 13:30, which is roughly the same duration as the
WG Chairs lunch. It's in Meeting 5.

Spencer

> > >> I’m usually more awake Tuesday breakfast than Thursday breakfast, so
> I would go for that option if the IAB does not have a breakfast there…
> > >>
> > >> Mirja
> > >>
> > >>
> (so folks could either sleep in or have breakfast meetings), so that's
> made it to the IAB. You and Tommy definitely handled this correctly - I
> hope that was clear in my note.
> > >>
> > >> Spencer
> > >>

---

From: "Brian Trammell (IETF)" <[email-masked]>
Date: Wed, 24 Oct 2018 15:51:31 +0200

Is it too late to arrange lunch there at that time?

> On 24 Oct 2018, at 15:50, Spencer Dawkins at IETF <[email-masked]> wrote:
> 
> 
> 
> On Wed, Oct 24, 2018 at 8:43 AM Brian Trammell (IETF) <[email-masked]> wrote:
> I grabbed it from 12:30 to 13:30, which is roughly the same duration as the WG Chairs lunch. It's in Meeting 5.
> 
> Spencer
> 
>

---

From: Suresh Krishnan <[email-masked]>
Date: Wed, 24 Oct 2018 10:59:47 -0400

Wednesday lunch works for me too.

Thanks
Suresh

> On Oct 24, 2018, at 9:50 AM, Spencer Dawkins at IETF <[email-masked]> wrote:
> 
> 
> 
> On Wed, Oct 24, 2018 at 8:43 AM Brian Trammell (IETF) <[email-masked] <mailto:[email-masked]>> wrote:
> > On 24 Oct 2018, at 15:42, Spencer Dawkins at IETF <[email-masked] <mailto:[email-masked]>> wrote:
> > 
> > Brian/Tommy,
> > 
> > On Wed, Oct 24, 2018 at 8:38 AM Brian Trammell (IETF) <[email-masked] <mailto:[email-masked]>> wrote:
> > > On 24 Oct 2018, at 15:36, Tommy Pauly <[email-masked] <mailto:[email-masked]>> wrote:
> > >
> > > On Oct 22, 2018, at 8:27 AM, Aaron Falk <[email-masked] <mailto:[email-masked]>> wrote:
> > >
> > >> Works for me.
> > >>
> > >> Am 22.10.2018 um 17:19 schrieb Ted Hardie <[email-masked] <mailto:[email-masked]>>:
> > >>
> > >> On Mon, Oct 22, 2018 at 3:11 AM Mirja Kühlewind <[email-masked] <mailto:[email-masked]>> wrote:
> > >> Am 19.10.2018 um 19:35 schrieb Tommy Pauly <[email-masked] <mailto:[email-masked]>>:
> > >>
> > >> Thanks, Spencer!
> > >>
> > >> On Oct 10, 2018, at 12:34 PM, Spencer Dawkins at IETF <[email-masked] <mailto:[email-masked]>> wrote:
> > >>
> > >> Hi, Ted,
> > >>
> > >> [email-masked] <mailto:[email-masked]>
> > >> https://www.iab.org/mailman/listinfo/stackevo <https://www.iab.org/mailman/listinfo/stackevo>
> > >>
> > >> [email-masked] <mailto:[email-masked]>
> > >> https://www.iab.org/mailman/listinfo/stackevo <https://www.iab.org/mailman/listinfo/stackevo>
> > >>
> > >> [email-masked] <mailto:[email-masked]>
> > >> https://www.iab.org/mailman/listinfo/stackevo <https://www.iab.org/mailman/listinfo/stackevo>
> > 
>

---

From: Cindy Morgan <[email-masked]>
Date: Wed, 24 Oct 2018 09:05:04 -0700

Spencer, thanks for reserving the IESG room. We can get lunch in, but it will be box lunches. I'll put in the catering request.

One note: this will conflict with the IAB Plenary Planning Program (in the IAB room), which I think only affects Brian, Mark, and Gabriel. Brian, are you planning to call in to this meeting (ie, will we need a speakerphone)?

Thanks,
Cindy

> On Oct 24, 2018, at 6:51 AM, Brian Trammell (IETF) <[email-masked]> wrote:
>

---

From: Lee Howard <[email-masked]>
Date: Wed, 24 Oct 2018 12:23:18 -0400

I won't be in Bangkok, and that will be 1:30am local time for me, so 
I'll miss.

Is there an agenda?

Lee

---

From: Jeff Tantsura <[email-masked]>
Date: Wed, 24 Oct 2018 09:27:42 -0700

Wednesday does overlap with WG chairs meeting, which is unfortunate…
I’ll try to make it

Cheers,
Jeff

---

From: Tommy Pauly <[email-masked]>
Date: Mon, 29 Oct 2018 09:53:38 -0700

> On Oct 24, 2018, at 9:23 AM, Lee Howard <[email-masked]> wrote:
> 
> I won't be in Bangkok, and that will be 1:30am local time for me, so I'll miss.
> 
> 
Yes, 1:30am is not a great time to call into meetings. We’ll miss you!
> Is there an agenda?

Regarding the agenda, I think we should keep it informal as it’s been for the past few meetings. However, I did want to make a topic proposal for people to think about and hopefully discuss.

There are a few different relevant drafts that we’ve been discussing as insights and techniques to encourage stack evolution: draft-iab-path-signals, draft-iab-wire-image, draft-thomson-use-it-or-lose-it. Many of these are currently embodied in QUIC.

If we look at QUIC as our primary experiment in testing these stack evolution techniques, how can we measure and evaluate their success as QUIC gets deployed? For example, how can we determine that the wire image that QUIC is designed to have (with its invariants and traffic patterns) is indeed what the network treats as its wire image? How do we get feedback from greasing techniques to determine their coverage and effectiveness? Can we request that deployments and implementations include some standard set of measurements to help provide feedback on the tolerance of networks to QUIC as a means of protocol evolution?

Best,
Tommy
>>> On 24 Oct 2018, at 15:36, Tommy Pauly <[email-masked]> <mailto:[email-masked]> wrote:
>>> 
>>> On Oct 22, 2018, at 8:27 AM, Aaron Falk <[email-masked]> <mailto:[email-masked]> wrote:
>>> 
>>>> Works for me.
>>>> 
>>>> Am 22.10.2018 um 17:19 schrieb Ted Hardie <[email-masked]> <mailto:[email-masked]>:
>>>> 
>>>> On Mon, Oct 22, 2018 at 3:11 AM Mirja Kühlewind <[email-masked]> <mailto:[email-masked]> wrote:
>>>> Am 19.10.2018 um 19:35 schrieb Tommy Pauly <[email-masked]> <mailto:[email-masked]>:
>>>> 
>>>> Thanks, Spencer!
>>>> 
>>>> On Oct 10, 2018, at 12:34 PM, Spencer Dawkins at IETF <[email-masked]> <mailto:[email-masked]> wrote:
>>>> 
>>>> Hi, Ted,
>>>> 
>>>> On Wed, Oct 10, 2018 at 2:17 PM Ted Hardie <[email-masked]> <mailto:[email-masked]> wrote:
>>>> On Wed, Oct 10, 2018 at 12:03 PM Spencer Dawkins at IETF <[email-masked]> <mailto:[email-masked]> wrote:
>>>> Hi, Tommy,
>>>>