Subject: [stir] Comment on draft-jennings-stir-rfc4474bis-00

From: Anton Baskov <[email-masked]>
Date: Thu, 30 Jan 2014 12:49:55 +0200

Some notes about phone number canonization described in Cullen’s STIR Signaling presentation and section “7.  Identity and Telephone Numbers” of draft-jennings-stir-rfc4474bis:

There is a problem with telephone number canonization that in some cases we can’t assume right number judging on sip uri, because some countries uses international access codes different that recommended by ITU. For example, at Russia dial out code is “8” for long distance calls and “8 - 10” for international calls, and most local operators use such number representation in their voip systems, so looking at “sip:8495...” number we can’t suppose is that call from Moscow (+7495...) or it’s from Vietnam (+84...). Also I saw two voip operators that use internal account number as right side of client sip uri – it’s make a possibility to make false phone number assumption by clients. In this case I think that we should have at least information header with full tel: uri or limit canonization procedure only to “sip:+..@domain”-like uri.

-- 
Anton Baskov <[email-masked]>
+7 (911) 254-77-92, +7 (916) 716-89-46

---

From: Brian Rosen <[email-masked]>
Date: Fri, 31 Jan 2014 10:21:29 -0500

This is a good point.

We probably have to say that if the rules we agree to do not result in a a proper e.164, and the call is sent beyond the local domain, that the From must be changed to be able to be canonicalized by the rules.

Brian

On Jan 30, 2014, at 5:49 AM, Anton Baskov <[email-masked]> wrote:

> _______________________________________________
> stir mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/stir