Subject: [stir] MIME (Certs draft)

From: Eric Burger <[email-masked]>
Date: Sun, 19 Jul 2015 20:38:58 -0400

Hello! We are specifying new SIP UA behavior. If we are specifying new SIP UA behavior, it means that developers will be changing the behavior (a.k.a. code) of conforming SIP UA’s. Stating that we do not want to use MIME in the Certificates draft (p. 5) is kind of silly. If we are telling someone to write a whole bunch of code to do remote resolution of URI’s, enter into possibly multiple SUBSCRIBE/NOTIFY dialogs, and (finally!) implement X.509 certificates, I think we can mandate MIME support.

---

From: Henning Schulzrinne <[email-masked]>
Date: Mon, 20 Jul 2015 07:38:30 +0000

Eric,

MIME has been a  huge implementation hurdle in practice, for two reasons:

(1) Many UAs use standard SIP libraries and don't touch the actual SIP header (or body). It's a lot easier to add external header processing in that case since this can be layered on top, without mucking with the SIP library. This is also true for server-based libraries (JAIN SIP, SIP servlets, e.g., in Mobicents).

(2) Many UAs and SBCs choke on multipart. This makes people reluctant to deploy new things since even entities that don't need or want to use the new feature need to be upgraded or they break things.

I've seen multiple instances of this, e.g., in the VRS context.

Since we want to get 4474bis deployed incrementally and with dispatch, this would argue for having a "we really can't do this any other way" justification for using multi-part.

Henning

________________________________________
From: stir <[email-masked]> on behalf of Eric Burger <[email-masked]>
Sent: Sunday, July 19, 2015 8:38 PM
To: [email-masked]
Subject: [stir] MIME (Certs draft)

---

From: "Peterson, Jon" <[email-masked]>
Date: Mon, 20 Jul 2015 07:49:42 +0000

Moreover, the certs draft does not say "don't use MIME." It says that multipart/MIME is one way to convey certificates, but that it has known problems (as Henning observes) and that there are other ways. Suggesting that the certs draft discourages that SIP implementations from using MIME or what have you is just bizarre. The certs draft actually allows MIME as a transport for certs. 

Jon Peterson
Neustar, Inc,

Sent from my iPad

> On Jul 20, 2015, at 9:38 AM, Henning Schulzrinne <[email-masked]> wrote:
> 
> Eric,
> 
> _______________________________________________
> stir mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/stir

---

From: Eric Burger <[email-masked]>
Date: Mon, 20 Jul 2015 06:24:27 -0400

I can buy the argument. Sounds like an opportunity to add to the open source resources.

> On Jul 20, 2015, at 3:49 AM, Peterson, Jon <[email-masked]> wrote:
>