Subject: [stir] Nits in draft-ietf-stir-passport-08

From: Anders Kristensen <[email-masked]>
Date: Sun, 2 Oct 2016 16:25:49 -0700

* 4.2.1: s/only have one/have exactly one/ ?

The "orig" JSON object MUST only have one key value pair

* 4.2.1.4: Why is "Single Originator", "Single Destination" etc.
capitalized?

* 5: "above" is actually below (also in Section 8).

   For the JWS Payload and the JWS Protected Header,
   the lexicographic ordering and white space rules described above, and
   JSON serialization rules in Section 8
<https://tools.ietf.org/html/draft-ietf-stir-passport-08#section-8> of
this document MUST be
   followed.

* 8.1: Delete leading whitespace:

   {"dest":{"uri":["sip:[email-masked]"],"iat":1443208345,"mky":
     [{"alg":"sha-256","dig":"021ACC5427ABEB9C533F3E4B652E7D463F5442CD5
     4F17A03A27DF9B07F4619B2"},{"alg":"sha-256","dig":"4AADB9B13F82183B5
     40212DF3E5D496B19E57CAB3E4B652E7D463F5442CD54F1"}],
     "orig":{"tn":"12155551212"}}

* 9.1: s/the the/the/

* 9.2: Looks like this paragraph was meant to be rendered as a bulleted
list.

* 9.2: s/the end user the asserted identity represents/the end user
represented by the asserted identity/

* 12.1: I think technically speaking this doc does not depend on 4474bis so
could make that ref informational.

* App A: Remove leading whitespace:

   {"alg":"ES256","typ":"passport","x5u":"https://cert.example.org
       /passport.cer"}

---

From: Chris Wendt <[email-masked]>
Date: Mon, 3 Oct 2016 21:53:16 -0400

Thanks Anders for your comments, will incorporate them in next version.

> On Oct 2, 2016, at 7:25 PM, Anders Kristensen <[email-masked]> wrote:
> 
> 
> * 4.2.1.4 <http://4.2.1.4/>: Why is "Single Originator", "Single Destination" etc. capitalized?
> 
>    JSON serialization rules in Section 8 <https://tools.ietf.org/html/draft-ietf-stir-passport-08#section-8> of this document MUST be
>    followed.
> 
>    {"dest":{"uri":["sip:[email-masked] <mailto:[email-masked]>"],"iat":1443208345,"mky":
> * 9.2: Looks like this paragraph was meant to be rendered as a bulleted list.
> 
> * 9.2: s/the end user the asserted identity represents/the end user represented by the asserted identity/
> 
> * 12.1: I think technically speaking this doc does not depend on 4474bis so could make that ref informational.
> 
>    {"alg":"ES256","typ":"passport","x5u":"https://cert.example.org <https://cert.example.org/>
>        /passport.cer"}
> _______________________________________________
> stir mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/stir

---

From: Alan Ford <[email-masked]>
Date: Tue, 11 Oct 2016 12:09:25 +0100

Agree on the 4.2.1 feedback, and indeed there's some small rewording which could be done in Section 4.2.1 to make this easier to understand (IMHO anyway):

   The "dest" JSON object MUST have at least have one key value pair,
   but could have multiple identity types (i.e. "tn" and/or "uri") but
   only one of each.  If both "tn" and "uri" are included, the JSON
   object should list the "tn" array first and the "uri" array second.
   Within the "tn" and "uri" arrays, the identity strings should be put
   in lexicographical order including the scheme-specific portion of the
   URI characters.  Additionally, in the case of "dest" only, the
   identity type key value MUST be an array signaled by standard JSON
   brackets, even when there is a single identity value in the identity
   type key value.

The requirement to be an array should be introduced earlier, since it’s mentioned in passing half way through and only confirmed at the end. Instead I’d propose putting a second sentence in, something like this, and then losing the last sentence:

   The "dest" JSON object MUST have at least have one key value pair,
   but could have multiple identity types (i.e. "tn" and/or "uri") but
   only one of each.  Each value in the key value pair is an array, 
   containing one or more identity strings of this identity type. If both "tn” 
   and "uri" are included, the JSON object should list the "tn" array first 
   and the "uri" array second. Within the "tn" and "uri" arrays, the 
   identity strings should be put in lexicographical order, including the 
   scheme-specific portion of the URI characters.  

Other than that this, I have re-read this document again and it reads well and I believe it to be ready for publication.

Regards,
Alan

> On 3 Oct 2016, at 00:25, Anders Kristensen <[email-masked]> wrote:
> 
>

---

From: Chris Wendt <[email-masked]>
Date: Wed, 12 Oct 2016 15:28:35 -0400

Thanks Alan,

Yes that is more appropriate, I will incorporate that change in wording.  

> On Oct 11, 2016, at 7:09 AM, Alan Ford <[email-masked]> wrote:
> 
>> On 3 Oct 2016, at 00:25, Anders Kristensen <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>> 
>> [email-masked] <mailto:[email-masked]>