Subject: [stir] I-D Action: draft-ietf-stir-passport-shaken-04.txt

From: [email-masked]
Date: Wed, 17 Oct 2018 15:58:59 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Secure Telephone Identity Revisited WG of the IETF.

        Title           : PASSporT SHAKEN Extension (SHAKEN)
        Authors         : Chris Wendt
                          Mary Barnes
	Filename        : draft-ietf-stir-passport-shaken-04.txt
	Pages           : 8
	Date            : 2018-10-17

Abstract:
   This document extends PASSporT, which is a token object that conveys
   cryptographically-signed information about the participants involved
   in communications, to include information defined as part of the
   SHAKEN specification from ATIS (Alliance for Telecommunications
   Industry Solutions) and the SIP Forum IP-NNI Joint Task Force.  These
   extensions provide a level of confidence in the correctness of the
   originating identity for a telephone network that has communications
   coming from both STIR participating originating communications as
   well as communications that does not include STIR information.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-stir-passport-shaken/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-stir-passport-shaken-04
https://datatracker.ietf.org/doc/html/draft-ietf-stir-passport-shaken-04

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-stir-passport-shaken-04

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Mary Barnes <[email-masked]>
Date: Wed, 17 Oct 2018 18:24:27 -0500

This version addresses Robert's shepherd review comments:
https://www.ietf.org/mail-archive/web/stir/current/msg03550.html

Regards,
Mary

On Wed, Oct 17, 2018 at 5:59 PM <[email-masked]> wrote:

> _______________________________________________
> I-D-Announce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i-d-announce
> Internet-Draft directories: http://www.ietf.org/shadow.html
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
>

---

From: "Asveren, Tolga" <[email-masked]>
Date: Thu, 18 Oct 2018 18:58:32 +0000

Security section looks good to me. It really is just how things should be IMHO if a key in a claim is not used outside of the context of STIR. Verification against a SIP header is needed only if the content of that header is used for some other purpose, e.g. displaying caller information.

Thanks,
Tolga

From: stir <[email-masked]> On Behalf Of Mary Barnes
Sent: Wednesday, October 17, 2018 7:24 PM
To: [email-masked] Mail List <[email-masked]>
Subject: Re: [stir] I-D Action: draft-ietf-stir-passport-shaken-04.txt

________________________________
NOTICE: This email was received from an EXTERNAL sender
________________________________

This version addresses Robert's shepherd review comments:
https://www.ietf.org/mail-archive/web/stir/current/msg03550.html<https://www.ietf.org/mail-archive/web/stir/current/msg03550.html>

Regards,
Mary

On Wed, Oct 17, 2018 at 5:59 PM <[email-masked]<mailto:[email-masked]>> wrote:

Abstract:

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-stir-passport-shaken/<https://datatracker.ietf.org/doc/draft-ietf-stir-passport-shaken/>

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-stir-passport-shaken-04<https://tools.ietf.org/html/draft-ietf-stir-passport-shaken-04>
https://datatracker.ietf.org/doc/html/draft-ietf-stir-passport-shaken-04<https://datatracker.ietf.org/doc/html/draft-ietf-stir-passport-shaken-04>

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-stir-passport-shaken-04<https://www.ietf.org/rfcdiff?url2=draft-ietf-stir-passport-shaken-04>

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org<http://tools.ietf.org>.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/<ftp://ftp.ietf.org/internet-drafts/>

_______________________________________________
I-D-Announce mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/i-d-announce<https://www.ietf.org/mailman/listinfo/i-d-announce>
Internet-Draft directories: http://www.ietf.org/shadow.html<http://www.ietf.org/shadow.html>
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt<ftp://ftp.ietf.org/ietf/1shadow-sites.txt>

-----------------------------------------------------------------------------------------------------------------------
Notice: This e-mail together with any attachments may contain information of Ribbon Communications Inc. that
is confidential and/or proprietary for the sole use of the intended recipient.  Any review, disclosure, reliance or
distribution by others or forwarding without express permission is strictly prohibited.  If you are not the intended
recipient, please notify the sender immediately and then delete all copies, including any attachments.
-----------------------------------------------------------------------------------------------------------------------