Subject: [stir] I-D Action: draft-ietf-stir-passport-divert-05.txt

From: [email-masked]
Date: Tue, 19 Feb 2019 13:58:51 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Secure Telephone Identity Revisited WG of the IETF.

        Title           : PASSporT Extension for Diverted Calls
        Author          : Jon Peterson
	Filename        : draft-ietf-stir-passport-divert-05.txt
	Pages           : 16
	Date            : 2019-02-19

Abstract:
   This document extends PASSporT, which conveys cryptographically-
   signed information about the people involved in personal
   communications, to include an indication that a call has been
   diverted from its original destination to a new one.  This
   information can greatly improve the decisions made by verification
   services in call forwarding scenarios.  Also specified here is an
   encapsulation mechanism for nesting a PASSporT within another
   PASSporT that assists relying parties in some diversion scenarios.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-stir-passport-divert/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-stir-passport-divert-05
https://datatracker.ietf.org/doc/html/draft-ietf-stir-passport-divert-05

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-stir-passport-divert-05

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: "Peterson, Jon" <[email-masked]>
Date: Tue, 19 Feb 2019 22:50:36 +0000

Hello,

There's been a lot ongoing industry interest in the diversion mechanism for PASSporT - enough that it has been kind of a moving target since the last IETF. But here is a revision which has a few major changes:

First, the mechanism is now split into two PASSporT types: "div" and "div-o." The first is for inbound SIP, and is non-nested - it requires multiple Identity headers. The second, "div-o", uses the "opt" element to allow PASSporT nesting, and thus could be used in out-of-band or non-SIP use cases. Splitting this into two separate PASSporT extensions hopefully avoids the sort of compatibility problems that had been raised as we sort of vacillated between nested and non-nested in the past.

Second, there's a lot more text about authentication and verification service behavior around "div", mostly inspired by some of the ongoing discussions with ATIS about how to make "div" work with SHAKEN. I hope the behavior is much more clear in this version.

There are smaller fixes, but it is a pretty extensive overhaul, and it would benefit from some eyeballs to make sure we're ready to advance with the draft.

Thanks,

Jon Peterson
Neustar, Inc.

On 2/19/19, 1:59 PM, "stir on behalf of [email-masked]" <[email-masked] on behalf of [email-masked]> wrote:

    
    Abstract:

    

    
    _______________________________________________
    stir mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/stir