Subject: [stir] draft-housley-stir-enhance-rfc8226-00

From: Russ Housley <[email-masked]>
Date: Thu, 21 Jan 2021 16:32:29 -0500

Please review and comment.  Christ Wendt has found some use cases where the JWT Claims Constraints in RFC 8226 are not adequate.  This I-D proposes an enhancement to make the constraints more rich.

Russ

> From: [email-masked]
> Subject: New Version Notification for draft-housley-stir-enhance-rfc8226-00.txt
> Date: January 21, 2021 at 4:29:14 PM EST
> To: "Russ Housley" <[email-masked]>
> 
> 
> A new version of I-D, draft-housley-stir-enhance-rfc8226-00.txt
> has been successfully submitted by Russ Housley and posted to the
> IETF repository.
> 
> Name:		draft-housley-stir-enhance-rfc8226
> Revision:	00
> Title:		Enhanced JWT Claim Constraints for STIR Certificates
> Document date:	2021-01-21
> Group:		Individual Submission
> Pages:		8
> URL:            https://www.ietf.org/archive/id/draft-housley-stir-enhance-rfc8226-00.txt
> Status:         https://datatracker.ietf.org/doc/draft-housley-stir-enhance-rfc8226/
> Htmlized:       https://datatracker.ietf.org/doc/html/draft-housley-stir-enhance-rfc8226
> Htmlized:       https://tools.ietf.org/html/draft-housley-stir-enhance-rfc8226-00
> 
> 
> Abstract:
>   RFC 8226 provides a certificate extension to constrain the JWT claims
>   that can be included in the PASSporT as defined in RFC 8225.  If the
>   signer includes a JWT claim outside the constraint boundaries, then
>   the recipient will reject the entire PASSporT.  This document defines
>   additional ways that the JWT claims can be constrained.
> 
> 
> 
> 
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> The IETF Secretariat
> 
>

---

From: "Peterson, Jon" <[email-masked]>
Date: Mon, 25 Jan 2021 16:04:50 +0000

I think this is a helpful and pretty simple patch – can we get a call for adoption?

Jon Peterson
Neustar, Inc.

From: stir <[email-masked]> on behalf of Russ Housley <[email-masked]>
Date: Thursday, January 21, 2021 at 1:32 PM
To: IETF STIR Mail List <[email-masked]>
Subject: [stir] draft-housley-stir-enhance-rfc8226-00

Russ

From: [email-masked]<mailto:[email-masked]>
Subject: New Version Notification for draft-housley-stir-enhance-rfc8226-00.txt
Date: January 21, 2021 at 4:29:14 PM EST
To: "Russ Housley" <[email-masked]<mailto:[email-masked]>>

Name: draft-housley-stir-enhance-rfc8226
Revision: 00
Title: Enhanced JWT Claim Constraints for STIR Certificates
Document date: 2021-01-21
Group: Individual Submission
Pages: 8
URL:            https://urldefense.com/v3/__https://www.ietf.org/archive/id/draft-housley-stir-enhance-rfc8226-00.txt__;!!N14HnBHF!rT7l4j2npZze97iP564UAYWWZ3nA3V85whav8RbkGEB53gVm1H1_54KhBGI$ 
Status:         https://urldefense.com/v3/__https://datatracker.ietf.org/doc/draft-housley-stir-enhance-rfc8226/__;!!N14HnBHF!rT7l4j2npZze97iP564UAYWWZ3nA3V85whav8RbkGEB53gVm1H1_ccfXMAo$ 
Htmlized:       https://urldefense.com/v3/__https://datatracker.ietf.org/doc/html/draft-housley-stir-enhance-rfc8226__;!!N14HnBHF!rT7l4j2npZze97iP564UAYWWZ3nA3V85whav8RbkGEB53gVm1H1_7fCdqZE$ 
Htmlized:       https://urldefense.com/v3/__https://tools.ietf.org/html/draft-housley-stir-enhance-rfc8226-00__;!!N14HnBHF!rT7l4j2npZze97iP564UAYWWZ3nA3V85whav8RbkGEB53gVm1H1_vRWkKsM$ 

Abstract:

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org<https://urldefense.com/v3/__http://tools.ietf.org__;!!N14HnBHF!rT7l4j2npZze97iP564UAYWWZ3nA3V85whav8RbkGEB53gVm1H1_KHn1gbQ$ >.

The IETF Secretariat

---

From: Chris Wendt <[email-masked]>
Date: Mon, 25 Jan 2021 12:35:50 -0500

Yes agree, this looks good!  Thanks Russ.

> On Jan 25, 2021, at 11:04 AM, Peterson, Jon <jon.peterson=[email-masked]> wrote:
> 
>  
>> From: [email-masked] <mailto:[email-masked]>
>> To: "Russ Housley" <[email-masked] <mailto:[email-masked]>>
>>  
>> 
>> URL:            https://www.ietf.org/archive/id/draft-housley-stir-enhance-rfc8226-00.txt <https://urldefense.com/v3/__https://www.ietf.org/archive/id/draft-housley-stir-enhance-rfc8226-00.txt__;!!N14HnBHF!rT7l4j2npZze97iP564UAYWWZ3nA3V85whav8RbkGEB53gVm1H1_54KhBGI$>
>> Status:         https://datatracker.ietf.org/doc/draft-housley-stir-enhance-rfc8226/ <https://urldefense.com/v3/__https://datatracker.ietf.org/doc/draft-housley-stir-enhance-rfc8226/__;!!N14HnBHF!rT7l4j2npZze97iP564UAYWWZ3nA3V85whav8RbkGEB53gVm1H1_ccfXMAo$>
>> Htmlized:       https://datatracker.ietf.org/doc/html/draft-housley-stir-enhance-rfc8226 <https://urldefense.com/v3/__https://datatracker.ietf.org/doc/html/draft-housley-stir-enhance-rfc8226__;!!N14HnBHF!rT7l4j2npZze97iP564UAYWWZ3nA3V85whav8RbkGEB53gVm1H1_7fCdqZE$>
>> Htmlized:       https://tools.ietf.org/html/draft-housley-stir-enhance-rfc8226-00 <https://urldefense.com/v3/__https://tools.ietf.org/html/draft-housley-stir-enhance-rfc8226-00__;!!N14HnBHF!rT7l4j2npZze97iP564UAYWWZ3nA3V85whav8RbkGEB53gVm1H1_vRWkKsM$>
>> 
>> 
>> Abstract:
>> until the htmlized version and diff are available at tools.ietf.org <https://urldefense.com/v3/__http://tools.ietf.org__;!!N14HnBHF!rT7l4j2npZze97iP564UAYWWZ3nA3V85whav8RbkGEB53gVm1H1_KHn1gbQ$>.
>> 
>> The IETF Secretariat
>> 
>> 
> 
>  
> _______________________________________________
> stir mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/stir