Subject: [stir] I-D Action: draft-ietf-stir-enhance-rfc8226-00.txt

From: [email-masked]
Date: Mon, 15 Feb 2021 11:53:46 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Secure Telephone Identity Revisited WG of the IETF.

        Title           : Enhanced JWT Claim Constraints for STIR Certificates
        Author          : Russ Housley
	Filename        : draft-ietf-stir-enhance-rfc8226-00.txt
	Pages           : 10
	Date            : 2021-02-15

Abstract:
   RFC 8226 provides a certificate extension to constrain the JWT claims
   that can be included in the PASSporT as defined in RFC 8225.  If the
   signer includes a JWT claim outside the constraint boundaries, then
   the recipient will reject the entire PASSporT.  This document defines
   additional ways that the JWT claims can be constrained.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-stir-enhance-rfc8226/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-stir-enhance-rfc8226-00
https://datatracker.ietf.org/doc/html/draft-ietf-stir-enhance-rfc8226-00

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: "Asveren, Tolga" <[email-masked]>
Date: Mon, 22 Feb 2021 00:14:18 +0000

Would adding "*" be useful as possible claim/value value? That would allow "exclude everything else except explicitly allowed claim/value" semantics.

Thanks,
Tolga

-----Original Message-----
From: stir <[email-masked]> On Behalf Of [email-masked]
Sent: Monday, February 15, 2021 2:54 PM
To: [email-masked]
Cc: [email-masked]
Subject: [stir] I-D Action: draft-ietf-stir-enhance-rfc8226-00.txt

NOTICE: This email was received from an EXTERNAL sender.

Abstract:

The IETF datatracker status page for this draft is:
https://clicktime.symantec.com/3PYwFpZMV3FwPb3NcvPGXPN6H2?u=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-ietf-stir-enhance-rfc8226%2F

There are also htmlized versions available at:
https://clicktime.symantec.com/3SxqBweeUCx4XKQ4nGVMheq6H2?u=https%3A%2F%2Ftools.ietf.org%2Fhtml%2Fdraft-ietf-stir-enhance-rfc8226-00
https://clicktime.symantec.com/3EufEdHEi4e6411xonCH6Jm6H2?u=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-ietf-stir-enhance-rfc8226-00

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

_______________________________________________
stir mailing list
[email-masked]
https://clicktime.symantec.com/3CzNhNFFMs26vG2C9Kjx6Sq6H2?u=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fstir

Notice: This e-mail together with any attachments may contain information of Ribbon Communications Inc. and its Affiliates that is confidential and/or proprietary for the sole use of the intended recipient. Any review, disclosure, reliance or distribution by others or forwarding without express permission is strictly prohibited. If you are not the intended recipient, please notify the sender immediately and then delete all copies, including any attachments.

---

From: Russ Housley <[email-masked]>
Date: Sun, 21 Feb 2021 19:24:18 -0500

I think that can already be accomplished with the mustExclude and excludedValues.  Section 5 has an example:

 - The "priority" claim must not be present in the PASSporT.  It can include any other claims.

 - The "assurance" claim, if present in the PASSporT, must not have a value of "low".  It can have any other value.

Russ

> On Feb 21, 2021, at 7:14 PM, Asveren, Tolga <[email-masked]> wrote:
> 
> https://www.ietf.org/mailman/listinfo/stir