Subject: [stir] I-D Action: draft-ietf-stir-passport-rcd-10.txt

From: [email-masked]
Date: Mon, 22 Feb 2021 15:25:03 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Secure Telephone Identity Revisited WG of the IETF.

        Title           : PASSporT Extension for Rich Call Data
        Authors         : Chris Wendt
                          Jon Peterson
	Filename        : draft-ietf-stir-passport-rcd-10.txt
	Pages           : 26
	Date            : 2021-02-22

Abstract:
   This document extends PASSporT, a token for conveying
   cryptographically-signed call information about personal
   communications, to include rich meta-data about a call and caller
   that can be signed and integrity protected, transmitted, and
   subsequently rendered to users.  This framework is intended to extend
   caller and call specific information beyond human-readable display
   name comparable to the "Caller ID" function common on the telephone
   network.  The JSON element defined for this purpose, Rich Call Data
   (RCD), is an extensible object defined to either be used as part of
   STIR or with SIP Call-Info to include related information about calls
   that helps people decide whether to pick up the phone.  This signing
   of the RCD information is also enhanced with a integrity mechanism
   that is designed to protect the authoring and transport of this
   information between authoritative and non-authoritative parties
   generating and signing the Rich Call Data for support of different
   usage and content policies.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-stir-passport-rcd/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-stir-passport-rcd-10
https://datatracker.ietf.org/doc/html/draft-ietf-stir-passport-rcd-10

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-stir-passport-rcd-10

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Chris Wendt <[email-masked]>
Date: Tue, 23 Feb 2021 12:17:46 -0500

Hi All,

We have a fairly substantive update for this draft. This includes updates mainly to the integrity mechanism for an important set of cases where you may not want to have to reference/download certain URIs contained in an RCD/jCard, but still want to validate the integrity.  One obvious example is the case where you might reference multiple resolutions of a photo or logo, or as a client there is certain properties you can not or by local policy do not want to render.  The proposed new framework allows for digests to be created that are specific to different parts of the jCard using JSON pointer as the mechanism to associate each digest.

We also enhanced the entire integrity framework to, I think more accurately now, address the different modes of using integrity to instead of using 3 modes, is actually a 2x2 matrix with authority over the RCD information as one dimension and the inclusion of external URI content as the other dimension.  Then associated those modes with the use of either “rcdi” and JWT Claims Constraints depending on what is required.

We also incorporated some text in the body and in security considerations referencing the use of JWT Claims Constraints with exclusions as defined in housley-stir-enhance-rfc8226.

The examples were improved to match more closely they types of RCD info that are being used as well.

We plan to review the changes in the IETF110 meeting, but let me know if you have any questions/concerns.

Thanks!

-Chris

> On Feb 22, 2021, at 6:25 PM, [email-masked] wrote:
> 
> 
> _______________________________________________
> stir mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/stir