Subject: [stir] Robert Wilton's No Objection on draft-ietf-stir-enhance-rfc8226-03: (with COMMENT)

From: Robert Wilton via Datatracker <[email-masked]>
Date: Mon, 28 Jun 2021 02:30:36 -0700

Robert Wilton has entered the following ballot position for
draft-ietf-stir-enhance-rfc8226-03: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-stir-enhance-rfc8226/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

Hi,

Thanks for the document, despite not being my area of expertise I found it easy
to read and understand.

A couple of minor comments:

(1) Like Erik, when reading section 4, I was wondering whether it would be
helpful to have an example that included both mustInclude and permittedValues. 
But of course, I note that you effectively do that in section 5.

(2) In the security section, it states:

   Certificate issuers should not include an entry in mustExclude for
   the "rcdi" claim for a certificate that will be used with the
   PASSporT Extension for Rich Call Data defined in
   [I-D.ietf-stir-passport-rcd].  Excluding this claim would prevent the
   integrity protection mechanism from working properly.

I was wondering whether it would be helpful to include this as RFC 2119 SHOULD
NOT in 3, or perhaps have a forward reference from the section 3 description of
mustExclude to the "rcdi" consideration in the security section.

Regards,
Rob

---

From: Russ Housley <[email-masked]>
Date: Mon, 28 Jun 2021 14:30:21 -0400

I hope the change proposed to resolve Erik's comment is also sufficient to resolve your comment.

> mustExclude to the "rcdi" consideration in the security section.

Sure:

   Certificate issuers SHOULD NOT include an entry in mustExclude for

Russ

---

From: Robert Sparks <[email-masked]>
Date: Mon, 28 Jun 2021 14:16:23 -0500

STIR WG - There's a small bit of normative text that is going into this 
document based on IESG discussion - you've already seen it on list, but 
I've copied it here for your convenience. I want to make sure you don't 
miss it (fwiw, I'm fine with it). If anyone has problems with it, reply 
very soon.

RjS

---

From: Chris Wendt <[email-masked]>
Date: Mon, 28 Jun 2021 15:57:26 -0400

Thanks Robert, I also have no issue that language.

-Chris

> On Jun 28, 2021, at 3:16 PM, Robert Sparks <[email-masked]> wrote:
> 
> STIR WG - There's a small bit of normative text that is going into this document based on IESG discussion - you've already seen it on list, but I've copied it here for your convenience. I want to make sure you don't miss it (fwiw, I'm fine with it). If anyone has problems with it, reply very soon.
> 
> RjS
> 
> _______________________________________________
> stir mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/stir

---

From: "Rob Wilton (rwilton)" <[email-masked]>
Date: Tue, 29 Jun 2021 08:24:49 +0000

> -----Original Message-----
> From: Russ Housley <[email-masked]>
> Sent: 28 June 2021 19:30
> To: Rob Wilton (rwilton) <[email-masked]>
> Cc: IESG <[email-masked]>; IETF STIR Mail List <[email-masked]>; Ben Campbell
> <[email-masked]>; Robert Sparks <[email-masked]>
> Subject: Re: [stir] Robert Wilton's No Objection on draft-ietf-stir-enhance-
> rfc8226-03: (with COMMENT)
> 
> Rob:
> 
I'm sure it will.

>    integrity protection mechanism from working properly.

Thanks!

Rob