Subject: [stir] RCD vs "div"

From: Ben Campbell <[email-masked]>
Date: Mon, 7 Mar 2022 14:25:03 -0600

Hi,

(Apologies for bringing this up late in the process for RCD, but I just thought about it over the weekend.)

Does the RCD passport draft need to talk about interactions with “div” passports?

For example, would a retargeted call inherit any RCD claims in the innermost passport? What happens if someone adds RCD claims to a “div” passport, especially if they conflict with any claims from earlier in the chain? Is the answer the same for RCD passports vs other passport types with RCD claims?

Thanks!

Ben.

---

From: Chris Wendt <[email-masked]>
Date: Mon, 7 Mar 2022 15:32:42 -0500

Hi Ben,

I think the way i'd like to think about it is that “div” rules apply to all PASSporTs and you don’t need multiple “div”s if you have multiple PASSporT types.  So, to the extent possible i’d like to keep that line of distinction.  In other words, i’d prefer to not have to discuss all of the other PASSporT types in subsequent PASSporT type specifications to the extent possible.

A simpler answer would be that i don’t believe “rcd” has any implications specific to “div” other than someone adding new “div”s and following the general rules.

-Chris

> On Mar 7, 2022, at 3:25 PM, Ben Campbell <[email-masked]> wrote:
> 
> Hi,
>

---

From: Mary Barnes <[email-masked]>
Date: Mon, 7 Mar 2022 14:48:52 -0600

I would agree with that in general.  IMHO, we really need a call flow
document to show examples of all of this.  I worked on one a long while
back  (no RCD - it was focused on DIV) and no one was interested in
progressing.
https://www.ietf.org/archive/id/draft-barnes-stir-passport-div-hi-callflows-02.txt

It's way too much work to do on my own.  But, if anyone is interested, let
me know.

Regards,
Mary.

On Mon, Mar 7, 2022 at 2:32 PM Chris Wendt <[email-masked]>
wrote:

> Hi Ben,
>
> I think the way i'd like to think about it is that “div” rules apply to
> all PASSporTs and you don’t need multiple “div”s if you have multiple
> PASSporT types.  So, to the extent possible i’d like to keep that line of
> distinction.  In other words, i’d prefer to not have to discuss all of the
> other PASSporT types in subsequent PASSporT type specifications to the
> extent possible.
>
> A simpler answer would be that i don’t believe “rcd” has any implications
> specific to “div” other than someone adding new “div”s and following the
> general rules.
>
> -Chris
>
> > For example, would a retargeted call inherit any RCD claims in the
> innermost passport? What happens if someone adds RCD claims to a “div”
> passport, especially if they conflict with any claims from earlier in the
> chain? Is the answer the same for RCD passports vs other passport types
> with RCD claims?
> >
> > Thanks!
> >
> > Ben.
>
> _______________________________________________
> stir mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/stir
>

---

From: Ben Campbell <[email-masked]>
Date: Tue, 8 Mar 2022 09:40:27 -0600

I’m willing to believe that the RCD draft doesn’t need to talk about “div” passports. But just to check my understanding:

- A “div” passport would not copy forward RCD claims from an inner passport. This is covered in RFC 8946, where it says no other claims are copied forward.

- A single “div” passport can chain back to multiple inner passports with matching orig/dest, e.g. if you have a separate SHAKEN and RCD passport in the original INVITE request. Also covered in 8946.

- Can we also assume that no one would ever add _new_ RCD claims to a “div” passport? That seems to make sense, but is it documented somewhere?

Thanks!

Ben.

> On Mar 7, 2022, at 2:48 PM, Mary Barnes <[email-masked]> wrote:
> 
> I would agree with that in general.  IMHO, we really need a call flow document to show examples of all of this.  I worked on one a long while back  (no RCD - it was focused on DIV) and no one was interested in progressing.  
> https://www.ietf.org/archive/id/draft-barnes-stir-passport-div-hi-callflows-02.txt <https://www.ietf.org/archive/id/draft-barnes-stir-passport-div-hi-callflows-02.txt>
> 
> It's way too much work to do on my own.  But, if anyone is interested, let me know.   
> 
> Regards,
> Mary. 
> 
> On Mon, Mar 7, 2022 at 2:32 PM Chris Wendt <[email-masked] <mailto:[email-masked]>> wrote:
> Hi Ben,
> 
> > On Mar 7, 2022, at 3:25 PM, Ben Campbell <[email-masked] <mailto:[email-masked]>> wrote:
> > 
> > Hi,
> > 
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/stir <https://www.ietf.org/mailman/listinfo/stir>