Subject: [storm] SAM-4 mapping for iSCSI Network Entity

From: "Mallikarjun C." <[email-masked]>
Date: Sun, 3 May 2009 15:51:42 -0700 (PDT)

All,

In looking through Figure 12 UML class model in my copy of SAM-4 r14, I am thinking that iSCSI Network Entity (sort of) maps to "SCSI Device" class.  But per RFC 3720, one iSCSI Network Entity can host multiple SCSI Target Devices (or even SCSI Iinitiator Devices).  The multiplicity of association between SCSI Device class and the SCSI Target Device class (or the SCSI Initiator Device class) however seems to preclude this implementation possibility.  I suspect we are really looking at a required change to SAM-4 Figure 12 to support the RFC 3720 notion of a Network Entity.

Comments? --
Mallikarjun Chadalapaka

---

From: Julian Satran <[email-masked]>
Date: Tue, 5 May 2009 08:42:13 +0300

Mallikarjun,

Sorry for the delay. It surely looks a bit confusing. I think that the  
source of confusion is that in UML a device-class is (in plain  
langauge) a "device type") as it may include the attributes and  
methods. The whole Domain class structure in Fig 12 IMHO means to show  
that there can be several classes (device types) in a domain and  
associations are possible between "similar" device classes. I think  
the figures is pure outline and a Device-Class type is a notation that  
T10 may want to add (this corresponds to the current structuring of  
SCSI software in most systems). The Network Entity that 3720 talks  
about may serve a multiplicity of classes and instances - and I think  
it is best mapped by the Service Deliver Class instance(fig 13). Again  
the same observation as before holds - a system may contain several  
Service Delivery classes and the figure is not clear about it.

I think George may help us out.

Thanks,
Julo
On 04/05/2009, at 01:51, Mallikarjun C. wrote:

>
> All,
>
> In looking through Figure 12 UML class model in my copy of SAM-4  
> r14, I am thinking that iSCSI Network Entity (sort of) maps to "SCSI  
> Device" class.  But per RFC 3720, one iSCSI Network Entity can host  
> multiple SCSI Target Devices (or even SCSI Iinitiator Devices).  The  
> multiplicity of association between SCSI Device class and the SCSI  
> Target Device class (or the SCSI Initiator Device class) however  
> seems to preclude this implementation possibility.  I suspect we are  
> really looking at a required change to SAM-4 Figure 12 to support  
> the RFC 3720 notion of a Network Entity.
>
> Comments? --
> Mallikarjun Chadalapaka
>
>
>
> _______________________________________________
> storm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/storm

---

From: "Penokie, George" <[email-masked]>
Date: Wed, 6 May 2009 15:27:09 -0600

Not knowing what an iSCSI Network Entity is, I can't answer your question. 

Bye for now, 
George Penokie
 
LSI Corporation 
3033 41st St. NW 
Suite 100 
Rochester, MN 55901
 
507-328-9017 
[email-masked]

-----Original Message-----
From: Julian Satran [mailto:[email-masked]] 
Sent: Tuesday, May 05, 2009 12:42 AM
To: Mallikarjun C.
Cc: [email-masked]; Penokie, George
Subject: Re: [storm] SAM-4 mapping for iSCSI Network Entity

Mallikarjun,

Sorry for the delay. It surely looks a bit confusing. I think that the source of confusion is that in UML a device-class is (in plain
langauge) a "device type") as it may include the attributes and methods. The whole Domain class structure in Fig 12 IMHO means to show that there can be several classes (device types) in a domain and associations are possible between "similar" device classes. I think the figures is pure outline and a Device-Class type is a notation that T10 may want to add (this corresponds to the current structuring of SCSI software in most systems). The Network Entity that 3720 talks about may serve a multiplicity of classes and instances - and I think it is best mapped by the Service Deliver Class instance(fig 13). Again the same observation as before holds - a system may contain several Service Delivery classes and the figure is not clear about it.

Thanks,
Julo
On 04/05/2009, at 01:51, Mallikarjun C. wrote:

>
> All,
>
> In looking through Figure 12 UML class model in my copy of SAM-4 r14, 
> I am thinking that iSCSI Network Entity (sort of) maps to "SCSI 
> Target Device class (or the SCSI Initiator Device class) however seems 
> to preclude this implementation possibility.  I suspect we are really 
> looking at a required change to SAM-4 Figure 12 to support the RFC 
> 3720 notion of a Network Entity.
>
> Comments? --
> Mallikarjun Chadalapaka
>
>
>