Subject: Re: [storm] What if a SCSI Response PDU has GOOD status anda DataSegment?

From: [email-masked]
Date: Mon, 30 Nov 2009 18:04:12 -0500

Ralph,

The Xtend SAN initiator (for Mac OS X)  will not pass sense data to the OS 
unless CHECK CONDITION status is returned.  At first glance it looks like 
our validation routines would silently ignore the extra info.

david

For every action there is an equal and opposite malfunction...

David J Cuddihy
Principal Engineer
ATTO Technology, Inc.

www.attotech.com
Power Behind the Storage

---

From: Ralph Weber <[email-masked]>
Date: Mon, 30 Nov 2009 17:19:20 -0600

Dear MR. Cuddihy,

Thank you for this information.

The T10 (SCSI Committee) folks working on returning
Sense Data with GOOD status will be pleased to hear
that the "extra info" will be ignored.

Please be sure to let me know if additional research
reverses this observation.

The current design center for GOOD w/ Sense usage
requires that proper operation of the feature have
no dependence on the "extra info" reaching the
intended recipient (i.e., other ways of obtaining
the same information MUST be provided). It is a
given that some number of years will be required
to arrange for the "extra info" to traverse its
way up the OS driver stack.

All the best,

.Ralph

[email-masked] wrote:
>
> Ralph,
>
> The Xtend SAN initiator (for Mac OS X)  will not pass sense data to 
> the OS unless CHECK CONDITION status is returned.  At first glance it 
> looks like our validation routines would silently ignore the extra info.
>
> david
>
> /
> For every action there is an equal and opposite malfunction.../
>
> David J Cuddihy
> Principal Engineer
> ATTO Technology, Inc.
>
> _
> __www.attotech.com_ <http://www.attotech.com/>*/
> Power Behind the Storage/*
> ------------------------------------------------------------------------
>
> _______________________________________________
> storm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/storm
>