Subject: Re: [storm] Removing iSCSI Markers?

From: <[email-masked]>
Date: Fri, 21 May 2010 18:48:22 -0400

> So I believe the WG is in agreement on removing iSCSI Markers.  Once
> David is back from vacation on the 19th, I assume he will make the formal
> consensus call, unless someone reports news of existing interoperable
> implementations in the interim.

I am back, but this has taken longer than I would have liked - it's a long story that starts with an unruly volcano in Iceland ;-).

In any case, I believe that I see WG rough consensus in the list discussion for removal of iSCSI Markers from the consolidated iSCSI draft (draft-ietf-storm-iscsi-cons).

Anyone who believes that iSCSI Markers should not be removed should explain why on the list.

Thanks,
--David
----------------------------------------------------
David L. Black, Distinguished Engineer
EMC Corporation, 176 South St., Hopkinton, MA  01748
+1 (508) 293-7953             FAX: +1 (508) 293-7786
[email-masked]        Mobile: +1 (978) 394-7754
----------------------------------------------------

---

From: <[email-masked]>
Date: Fri, 21 May 2010 18:54:36 -0400

> Regarding the feature removal discussion, can I add SLP to the list ?
> 
> The RFC 3721 states
> 
> "iSCSI equipment that
>        need discovery functions beyond SendTargets should at least
>        implement SLP, and then consider iSNS when extended discovery
>        management capabilities are required such as in larger storage
>        networks.  It should be noted that since iSNS will support SLP,
>        iSNS can be used to help manage the discovery information returned
>        by SLP."
> 
> The implication is that targets and initiators should expect to find
> support for SLP before considering iSNS.
> 
> I remember our first iSCSI appliance and we spent ages trying to get
> SLP working because it the above wording effectively made it
> mandatory.  SLP turned out to be a complete bust and was effectively
> killed off when Microsoft refused to support it in their initiator
> and in their target logo tests.
> 
> The result is that today I doubt you could find a target or initiator
> out there supporting SLP.
> 
> For anybody that does still implement SLP we could change the wording
> for SLP a little to remove the implied hierarchy, or just admit that
> running code has created IETF consensus.

This is interesting.  RFC 3720 (main iSCSI spec) never mentions SLP.  RFC 3721 is not a Standards Track RFC, but that's not a reason not to update it (if people will excuse the double negative).

So, Mark, could you send an email to the list with proposed text on SLP that you'd like to see in the new consolidated iSCSI draft (no more than a few sentences, please)?  If that text (as revised) is acceptable to the WG, the result would go into the new consolidated iSCSI draft, and RFC 3721 would be added to the list of RFCs that are being updated by that draft.

Thanks,
--David