Subject: Re: [straw] WGLC for draft-ietf-straw-sip-traceroute-01.txt

From: Hadriel Kaplan <[email-masked]>
Date: Mon, 10 Mar 2014 13:09:02 -0400

Hi Peter,
sorry for the delay in responding to this!
comments inline...

On Dec 17, 2013, at 7:04 AM, Dawes, Peter, Vodafone Group <[email-masked]> wrote:

> I think the draft text in clause 3.1 Processing a Received Max-Forwards Header Field (lines 206 - 208)] "As currently defined in [RFC3261], the UAS half of a B2BUA does not technically need to inspect the Max-Forwards header field value for received requests - only Proxies do." should be clearer in terms of what the implementer actually has to do. 

It says:
   As currently defined in [RFC3261], the UAS half of a B2BUA does not
   technically need to inspect the Max-Forwards header field value for
   received requests - only Proxies do.  This behavior was updated by
   [draft-loop-detection], such that a compliant B2BUA needs to both
   inspect the value in order to prevent loops, as well as copy and
   decrement the value as if it were a Proxy.  This document also
   requires such behavior in order to succeed, therefore a B2BUA
   supporting the traceroute mechanism defined in this document MUST
   also comply with [draft-loop-detection].

How is that not clear?

> You replied that "...I think it is in fact in doubt.  I know of many B2BUAs which do in fact decrement max-forwards. (and I think they're right to)". So what does the implementer do? Be happy that they might not need to change too much? Make sure all of their B2BUAs decrement Max-Forwards whether they will loopback media or not? Be aware that if they don't want their B2BUA to decrement Max-Forwards then they can't use this mechanism? Something else?

See above.

-hadriel

---

From: "Dawes, Peter, Vodafone Group" <[email-masked]>
Date: Mon, 10 Mar 2014 19:33:10 +0000

Hi Hadriel,
Apologies for not being very clear with my comment about lack of clarity :-)

The draft describes behaviour for a UAC, B2BUA, and UAS. Is the paragraph below from clause 3.1 an instruction to a B2BUA implementer on how to process Max-Forwards or a warning that some B2BUAs will cause the mechanism to fail?

A couple of other small questions, is the first sentence "As currently defined in [RFC3261], the UAS half of a B2BUA does not technically need to inspect the Max-Forwards header field value for received requests - only Proxies do. " needed? Also, regarding complying with [draft-loop-detection] does a B2BUA need to do more than "inspect the value in order to prevent loops, as well as copy and decrement the value as if it were a Proxy"? If so it would be good to say something like ", therefore a B2BUA supporting the traceroute mechanism defined in this document MUST also comply with the Max-Forwards behaviour and all other procedures in [draft-loop-detection]"

Rgds,
Peter

-----Original Message-----
From: Hadriel Kaplan [mailto:[email-masked]] 
Sent: 10 March 2014 17:09
To: Dawes, Peter, Vodafone Group
Cc: [email-masked]
Subject: Re: [straw] WGLC for draft-ietf-straw-sip-traceroute-01.txt

Hi Peter,

It says:

How is that not clear?

See above.

-hadriel

---

From: Hadriel Kaplan <[email-masked]>
Date: Mon, 10 Mar 2014 17:25:24 -0400

> The draft describes behaviour for a UAC, B2BUA, and UAS. Is the paragraph below from clause 3.1 an instruction to a B2BUA implementer on how to process Max-Forwards or a warning that some B2BUAs wi…

It's an instruction - it has the word "MUST", and it says right at the end:
  ...This document also
  requires such behavior in order to succeed, therefore a B2BUA
  supporting the traceroute mechanism defined in this document MUST
  also comply with [draft-loop-detection].

> A couple of other small questions, is the first sentence "As currently defined in [RFC3261], the UAS half of a B2BUA does not technically need to inspect the Max-Forwards header field value for received requests - only Proxies do. " needed?

Yes, I think it sets the context for this being a change in behavior.

> Also, regarding complying with [draft-loop-detection] does a B2BUA need to do more than "inspect the value in order to prevent loops, as well as copy and decrement the value as if it were a Proxy"? If so it would be good to say something like ", therefore a B2BUA supporting the traceroute mechanism defined in this document MUST also comply with the Max-Forwards behaviour and all other procedures in [draft-loop-detection]"

Isn't that synonymous with "MUST also comply with [draft-loop-detection]"?

I must be missing something obvious to you in reading that paragraph, because it sounds like you're saying it doesn't say X when it says X to me.
:)

-hadriel

---

From: "Dawes, Peter, Vodafone Group" <[email-masked]>
Date: Tue, 11 Mar 2014 09:26:04 +0000

Hi Hadriel,
My confusion with 3.1 came from the mixture of introductory description (the UAS half of a B2BUA does not technically need to inspect the Max-Forwards header) with normative specification in the same paragraph, but I accept that the MUST makes it clear which is which. The other comments related to potentially shortening the text a little and not to errors or ambiguity.

Thanks for the answers, I have no more comments.

Peter

-----Original Message-----
From: Hadriel Kaplan [mailto:[email-masked]] 
Sent: 10 March 2014 21:25
To: Dawes, Peter, Vodafone Group
Cc: [email-masked]
Subject: Re: [straw] WGLC for draft-ietf-straw-sip-traceroute-01.txt

-hadriel

---

From: Hadriel Kaplan <[email-masked]>
Date: Tue, 11 Mar 2014 12:40:35 -0400

Great - new rev being submitted now...

On Mar 11, 2014, at 5:26 AM, Dawes, Peter, Vodafone Group <[email-masked]> wrote:

> _______________________________________________
> straw mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/straw