Subject: Re: [straw] FW: New Version Notification for draft-ram-straw-b2bua-dtls-srtp-00.txt

From: "Ram Mohan R (rmohanr)" <[email-masked]>
Date: Fri, 4 Jul 2014 06:20:20 +0000

Hi Paul,

Thanks for reviewing the draft. Please see inline

-----Original Message-----
From: Paul Kyzivat <[email-masked]>
Date: Monday, 30 June 2014 9:12 pm
To: "[email-masked]" <[email-masked]>
Subject: Re: [straw] FW: New Version Notification for
draft-ram-straw-b2bua-dtls-srtp-00.txt

>Comments on the draft:
>
>General point:
>
>This draft doesn't say anything about middleboxes that *remove* the
>encryption on the media stream. Especially given the recent issues about
>surveillance, I would think the right thing to do is say MUST NOT to
>this. OTOH, I assume that there are users of SBC who explicitly desire
>this behavior. At the least it should be discussed in the security
>considerations.

Agree. Good point. Will add some considerations in the next revision.

>
>Section 3.2:
>
>ISTM that Media Aware and Media Termination deserve separate treatment.
>
>A Media Aware relay doesn't need to encrypt - it can pass the incoming
>packets through. So it could simply observe the fingerprints as they go
>by without changing them, and then use to do decryption.

If the media aware relay B2BUA is just forwarding  after looking at the
headers (RTP/RTCP or finger) the DLTS session does not need to be
terminated on the B2BUA. It can be end to end in which case the flow will
be very similar to section 3.1
I will add some clarification for Media aware relay and perhaps have it as
separate section with a brief text and then pointing t section 3.1

Regards,
Ram

>
>Also, doesn't this depend on how much scrutiny it gives to the packets.
>IIUC, with SRTP the RTP packet headers are not encrypted, so some basic
>level of scrutiny of the RTP can be done without any decryption.
>
>	Thanks,
>	Paul
>
>On 6/21/14 1:00 PM, Ram Mohan R (rmohanr) wrote:
>> We have submitted a new draft that describes the behavior B2BUA¹s should
>> follow when acting on a media plane that uses DTLS-SRTP.
>>
>> http://tools.ietf.org/html/draft-ram-straw-b2bua-dtls-srtp-00
>>
>>
>> Comments and inputs are welcome
>>
>> Regards,
>> Authors
>>
>> -----Original Message-----
>> From: "[email-masked]" <[email-masked]>
>> Date: Saturday, 21 June 2014 11:01 am
>> To: Ram Mohan Ravindranath <[email-masked]>, "Tirumaleswar Reddy
>> (tireddy)" <[email-masked]>, Victor Pascual
>> <[email-masked]>, Victor Pascual <[email-masked]>,
>> "Gonzalo Salgueiro (gsalguei)" <[email-masked]>, "Gonzalo Salgueiro
>> (gsalguei)" <[email-masked]>, "Tirumaleswar Reddy (tireddy)"
>> <[email-masked]>, Ram Mohan Ravindranath <[email-masked]>
>> Subject: New Version Notification for
>> draft-ram-straw-b2bua-dtls-srtp-00.txt
>>
>>>
>>> A new version of I-D, draft-ram-straw-b2bua-dtls-srtp-00.txt
>>> has been successfully submitted by Gonzalo Salgueiro and posted to the
>>> IETF repository.
>>>
>>> Name:		draft-ram-straw-b2bua-dtls-srtp
>>> Revision:	00
>>> Title:		DTLS-SRTP Handling in Session Initiation Protocol (SIP)
>>> Back-to-Back User Agents (B2BUAs)
>>> Document date:	2014-06-20
>>> Group:		Individual Submission
>>> Pages:		10
>>> URL:
>>> 
>>>http://www.ietf.org/internet-drafts/draft-ram-straw-b2bua-dtls-srtp-00.t
>>>xt
>>> Status:
>>> https://datatracker.ietf.org/doc/draft-ram-straw-b2bua-dtls-srtp/
>>> Htmlized:
>>> http://tools.ietf.org/html/draft-ram-straw-b2bua-dtls-srtp-00
>>>
>>>
>>> Abstract:
>>>    Session Initiation Protocol (SIP) Back-to-Back User Agents (B2BUAs)
>>>    often function on the media plane, rather than just on the signaling
>>>    path.  This document describes the behavior B2BUAs should follow
>>>when
>>>    acting on the media plane that use Secure Real-time Transport
>>>    Protocol (SRTP) security context setup with Datagram Transport Layer
>>>    Security (DTLS) protocol.
>>>
>>>
>>>
>>>
>>>
>>> Please note that it may take a couple of minutes from the time of
>>> submission
>>> until the htmlized version and diff are available at tools.ietf.org.
>>>
>>> The IETF Secretariat
>>>
>>
>> _______________________________________________
>> straw mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/straw
>>
>
>_______________________________________________
>straw mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/straw

---

From: "Ram Mohan R (rmohanr)" <[email-masked]>
Date: Fri, 4 Jul 2014 09:35:31 +0000

-----Original Message-----
From: Paul Kyzivat <[email-masked]>
Date: Monday, 30 June 2014 9:12 pm
To: "[email-masked]" <[email-masked]>
Subject: Re: [straw] FW: New Version Notification for

>by without changing them, and then use to do decryption.

One comment on this - if the DTLS is not terminated on the B2BUA then it
can¹t decrypt the packets. So for a Media Aware relay it can¹t decrypt the
packets. It can only inspect the headers.

Ram

---

From: "Parthasarathi R" <[email-masked]>
Date: Sun, 13 Jul 2014 21:37:45 +0530

Hi all,

The draft looks good. The example of SIP & DTLS-SRTP message in the draft
will provide more clarity about the different B2BUA usages.

Thanks
Partha 

> From: straw [mailto:[email-masked]] On Behalf Of Ram Mohan R
> (rmohanr)
> Sent: Saturday, June 21, 2014 10:30 PM
> To: [email-masked]
> Subject: [straw] FW: New Version Notification for draft-ram-straw-
> b2bua-dtls-srtp-00.txt
> 
> >http://www.ietf.org/internet-drafts/draft-ram-straw-b2bua-dtls-srtp-
> 00.txt
> >Status:

---

From: "Hutton, Andrew" <[email-masked]>
Date: Mon, 14 Jul 2014 11:46:37 +0000

Just one question at this time.

Should this draft be "Informational" rather than "Standards Track"?

Regards
Andy

> Sent: 21 June 2014 18:00

---

From: "Ram Mohan R (rmohanr)" <[email-masked]>
Date: Tue, 22 Jul 2014 05:46:47 +0000

Please see inline

-----Original Message-----
From: <Hutton>, Andrew <[email-masked]>
Date: Monday, 14 July 2014 5:16 pm
To: Ram Mohan Ravindranath <[email-masked]>, "[email-masked]"
<[email-masked]>
Subject: RE: New Version Notification for
draft-ram-straw-b2bua-dtls-srtp-00.txt

>Should this draft be "Informational" rather than "Standards Track"?

Good question. IMO this should be Standards Track as we are recommending
the behavior B2BUAs must follow to make DTLS-SRTP to work end to end.

Regards,
Ram