Subject: [Suit] Architecture Drawings

From: Hannes Tschofenig <[email-masked]>
Date: Tue, 27 Feb 2018 13:32:31 +0000

Hi all,

at the virtual interim meeting yesterday we had a discussion about the architectural drawings. Currently, there is one figure available that highlights the use of end-to-end security.
The was, however, the desire expressed to have more figures that explain the different delivery methods currently offered.

I have come up with two drawings that illustrate the difference between a manifest with attached firmware image (shown in Figure 1) and a case where the manifest is delivered separately and the devices fetches the firmware image from another source (shown in Figure 2). Figure 1 illustrates a case that is useful when the device does not have access to the Internet or when the update process happens via a USB stick. Figure 2 is the remote update where the device fetches the firmware image from some file server.

              /------------\                 /------------\
             /Manifest with \               /Manifest with \
             |attached      |               |attached      |
             \firmware image/               \firmware image/
              \------------/  +-----------+  \------------/
  +--------+                  |           |                 +--------+
  |        |<.................| Untrusted |<................|        |
  | Device |                  | Storage   |                 | Author |
  |        |                  |           |                 |        |
  +--------+                  +-----------+                 +--------+

Figure 1: Manifest with attached firmware.

                              /------------\
                             /              \
                             |   Manifest   |
                             \              /
  +--------+                  \------------/                +--------+
  |        |<..............................................>|        |
  | Device |                                             -- | Author |
  |        |<-                                         ---  |        |
  +--------+  --                                     ---    +--------+
                --                                 ---
                  ---                            ---
                     --       +-----------+    --
                       --     |           |  --
        /------------\   --   | Untrusted |<-    /------------\
       /              \    -- | Storage   |     /              \
       |   Firmware   |       |           |     |   Firmware   |
       \              /       +-----------+     \              /
        \------------/                           \------------/

Figure 2: Independent retrieval of the firmware image.

What do you think? Are those the types of figures  you had in mind? What other figures would be useful to add?

Ciao
Hannes

IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you.

---

From: "Puzdrowski, Andrzej" <[email-masked]>
Date: Wed, 28 Feb 2018 09:58:09 +0000

Hi.

I Think the first image is also good for P2P solution. For instance small Bluetooth smart device can be updated using smartphone which roles are simultaneously: untrusted storage: DFU controller (mean that pushes the manifest with firmware image to the device), initiator, status tracker.

From: Suit [mailto:[email-masked]] On Behalf Of Hannes Tschofenig
Sent: Tuesday, February 27, 2018 2:33 PM
To: [email-masked]
Subject: [Suit] Architecture Drawings

Hi all,

                              /------------\
                             /              \
                             |   Manifest   |
                             \              /

Ciao
Hannes

---

From: Hannes Tschofenig <[email-masked]>
Date: Wed, 28 Feb 2018 10:54:40 +0000

Hi Andrzej,

I agree with your observation. I guess I should also add Bluetooth Smart as an example in addition to the USB stick since the Bluetooth case may actually more common in the future.

Ciao
Hannes

From: Suit [mailto:[email-masked]] On Behalf Of Puzdrowski, Andrzej
Sent: 28 February 2018 10:58
To: [email-masked]
Subject: Re: [Suit] Architecture Drawings

Hi.

From: Suit [mailto:[email-masked]] On Behalf Of Hannes Tschofenig
Sent: Tuesday, February 27, 2018 2:33 PM
To: [email-masked]<mailto:[email-masked]>
Subject: [Suit] Architecture Drawings

Hi all,

                              /------------\
                             /              \
                             |   Manifest   |
                             \              /

Ciao
Hannes