Subject: Re: [Suit] New draft-moran-suit-manifest-03

From: Brendan Moran <[email-masked]>
Date: Fri, 2 Nov 2018 17:12:36 +0000

The manifest generator that I released for the previous draft now supports a subset of draft-moran-suit-manifest-03

 https://github.com/ARMmbed/suit-manifest-generator

Best Regards,
Brendan

> On 30 Oct 2018, at 09:39, Brendan Moran <[email-masked]> wrote:
>
> My apologies for the delay in announcing this new draft, it was published Monday last week.
>
> Summary of changes:
> * All sections are now fully described
> * Most structures are now CBOR Maps
> * New COSE_Digest structure is defined
> * Processors IDs are CBOR Lists
> * Processors are defined in a tree, not a graph. Encoding of the tree is flat, in a child-first order.
> * Examples are added
>
> IANA actions required:
> * New CBOR Tag for COSE_Digest_Tagged
> * New COSE Algorithm identifiers for digest algorithms
>
> Please see here for full details:
> https://tools.ietf.org/html/draft-moran-suit-manifest-03
>
> Best Regards,
> Brendan
> IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you.
>
> _______________________________________________
> Suit mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/suit

IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you.

---

From: Carsten Bormann <[email-masked]>
Date: Sat, 3 Nov 2018 12:15:11 +0700

Jaime alerted me to the fact that there are a few problems with the CDDL in the current draft; apparently that code was never seen by a tool.

— duplicate definition: AuthenticationWrapper [innocuous, but unnecessary warning]
— conflict with prelude definition: text
- undefined: TextInfo
— a few more definitions need to be imported from COSE, if you want to repeat the CDDL from RFC 8152 here (e.g., label, values)
— where a rule is used to provide an integer key, we don’t use a colon but “=>” in CDDL
  (The colon causes the name itself to be used as a text string instead of the integer.)

(This is where I stopped looking; there are probably more things to fix.)

If you want to have a fixed version of the CDDL, I think I will be able to generate that from what is in the current document, with a few questions (e.g., what exactly is “TextInfo” supposed to be) answered.
(I’ll do that work only if you actually want to use the fixed version; I’m not sure what happened to the last set of fixes I produced.)
In general, it helps to occasionally use the cddl tool, limited as that may be at this time.

Grüße, Carsten

> On Oct 30, 2018, at 16:39, Brendan Moran <[email-masked]> wrote:
>

---

From: Brendan Moran <[email-masked]>
Date: Mon, 5 Nov 2018 09:46:34 +0000

The CDDL was seen by a tool, early on, however it appears that some of the late edits I made caused it to degrade. There is a much improved version that Henk kindly provided in the manifest generator repo:

https://github.com/ARMmbed/suit-manifest-generator/pull/7

After the SUIT meeting, I will integrate any feedback and the CDDL edits with the draft.

Best Regards,
Brendan

> On 3 Nov 2018, at 05:15, Carsten Bormann <[email-masked]> wrote:
>

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 5 Nov 2018 16:47:51 +0700

Thanks!  Looking forward to it…

Grüße, Carsten

> On Nov 5, 2018, at 16:46, Brendan Moran <[email-masked]> wrote:
>