Subject: [Suit] I-D Action: draft-ietf-suit-architecture-04.txt

From: [email-masked]
Date: Wed, 27 Mar 2019 02:02:24 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Software Updates for Internet of Things WG of the IETF.

        Title           : A Firmware Update Architecture for Internet of Things Devices
        Authors         : Brendan Moran
                          Milosch Meriac
                          Hannes Tschofenig
                          David Brown
	Filename        : draft-ietf-suit-architecture-04.txt
	Pages           : 25
	Date            : 2019-03-27

Abstract:
   Vulnerabilities with Internet of Things (IoT) devices have raised the
   need for a solid and secure firmware update mechanism that is also
   suitable for constrained devices.  Incorporating such update
   mechanism to fix vulnerabilities, to update configuration settings as
   well as adding new functionality is recommended by security experts.

   This document lists requirements and describes an architecture for a
   firmware update mechanism suitable for IoT devices.  The architecture
   is agnostic to the transport of the firmware images and associated
   meta-data.

   This version of the document assumes asymmetric cryptography and a
   public key infrastructure.  Future versions may also describe a
   symmetric key approach for very constrained devices.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-suit-architecture/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-suit-architecture-04
https://datatracker.ietf.org/doc/html/draft-ietf-suit-architecture-04

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-suit-architecture-04

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Michael Richardson <[email-masked]>
Date: Wed, 27 Mar 2019 14:04:44 +0100

[email-masked] wrote:
    >         Title : A Firmware Update Architecture for Internet of Things

I wonder if the title should be changed to be more "SUIT"...
So Firmware -> Software ?

--
]               Never tell me the odds!                 | ipv6 mesh networks [
]   Michael Richardson, Sandelman Software Works        | network architect  [
]     [email-masked]  http://www.sandelman.ca/        |   ruby on rails    [

---

From: Dave Thaler <[email-masked]>
Date: Wed, 27 Mar 2019 13:42:33 +0000

As I recall, this came up at the time the WG was first chartered... at that time, the WG
agreed that Firmware was more accurate, but didn't want to change the WG
name.

Dave

-----Original Message-----
From: Suit <[email-masked]> On Behalf Of Michael Richardson
Sent: Wednesday, March 27, 2019 2:05 PM
To: [email-masked]
Subject: Re: [Suit] I-D Action: draft-ietf-suit-architecture-04.txt

--
]               Never tell me the odds!                 | ipv6 mesh networks [
]   Michael Richardson, Sandelman Software Works        | network architect  [
]     [email-masked]  https://nam06.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.sandelman.ca%2F&amp;data=02%7C01%7Cdthaler%40microsoft.com%7C5aeb9685d28d469f9e1908d6b2b4ce1a%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C636892886963612313&amp;sdata=b7lQnzlN2cV2%2F68jSp6eL91YcP1ZISCcs53ZGRypD1k%3D&amp;reserved=0        |   ruby on rails    [

_______________________________________________
Suit mailing list
[email-masked]
https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fsuit&amp;data=02%7C01%7Cdthaler%40microsoft.com%7C5aeb9685d28d469f9e1908d6b2b4ce1a%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C636892886963612313&amp;sdata=n6vyzkYbjCGAGVSZmyx9rgsMjh2CkPC6Z04y8wy6%2FCw%3D&amp;reserved=0

---

From: Brendan Moran <[email-masked]>
Date: Wed, 27 Mar 2019 13:55:21 +0000

Could we add something like this to the draft?

> The architecture in this document is informed by the requirements of Class 1 and Class 2 devices (RFC7228), and because of that, the term Firmware is used rather than Software. There are no restrictions present that prevent distribution of larger code packages (“software”) or other machine consumable resources via this architecture.

Best Regards,
Brendan

> On 27 Mar 2019, at 14:42, Dave Thaler <dthaler=[email-masked]> wrote:
>
> https://www.ietf.org/mailman/listinfo/suit

IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you.

---

From: Dave Thaler <[email-masked]>
Date: Wed, 27 Mar 2019 15:16:24 +0000

Looks ok to me.

Dave

-----Original Message-----
From: Brendan Moran <[email-masked]> 
Sent: Wednesday, March 27, 2019 2:55 PM
To: Dave Thaler <[email-masked]>
Cc: Michael Richardson <[email-masked]>; [email-masked]
Subject: Re: [Suit] I-D Action: draft-ietf-suit-architecture-04.txt

Best Regards,
Brendan

> As I recall, this came up at the time the WG was first chartered... at 
> that time, the WG agreed that Firmware was more accurate, but didn't 
> want to change the WG name.
>
> Dave
>
> ]     [email-masked]  https://nam06.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.sandelman.ca%2F&amp;data=02%7C01%7Cdthaler%40microsoft.com%7Cf70ca755f1534d10fa9808d6b2bbdf91%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C636892917322707827&amp;sdata=1cuk7k4mJj9U1%2FvoLHQKMm8P60pFhI0TRWIHTAoEObg%3D&amp;reserved=0        |   ruby on rails    [
>
> https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.
> ietf.org%2Fmailman%2Flistinfo%2Fsuit&amp;data=02%7C01%7Cdthaler%40micr
> osoft.com%7Cf70ca755f1534d10fa9808d6b2bbdf91%7C72f988bf86f141af91ab2d7
> cd011db47%7C1%7C0%7C636892917322707827&amp;sdata=fBiKlOdFJL5nVmkvKugyB
> qAy6NiEiJRX%2BQy3gRQSTxQ%3D&amp;reserved=0
>
> https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.
> ietf.org%2Fmailman%2Flistinfo%2Fsuit&amp;data=02%7C01%7Cdthaler%40micr
> osoft.com%7Cf70ca755f1534d10fa9808d6b2bbdf91%7C72f988bf86f141af91ab2d7
> cd011db47%7C1%7C0%7C636892917322707827&amp;sdata=fBiKlOdFJL5nVmkvKugyB
> qAy6NiEiJRX%2BQy3gRQSTxQ%3D&amp;reserved=0