Subject: Re: [Suit] Proposal for changes to draft-ietf-suit-manifest

From: Brendan Moran <[email-masked]>
Date: Fri, 1 Nov 2019 08:53:27 +0000

I have published a pull-request that has this proposed structure.

https://github.com/suit-wg/manifest-spec/pull/1

Best Regards,
Brendan

> On 31 Oct 2019, at 14:16, Brendan Moran <[email-masked]> wrote:
>
> I would like to propose a set of changes to draft-ietf-suit-manifest for the 02 version.  This set of changes has no effect on the encoding and is purely organisational for the draft, though it introduces new text. This new organisation would have approximately the following layout:
>
>   1.  Introduction
>   2.  Conventions and Terminology
>   3.  Overview
>       3.1.  How to use this document
>       3.2.  Background
>             3.2.1.  Landscape
>             3.2.2.  Update Workflow Model
>             3.2.3.  SUIT Manifest goals
>             3.2.4.  SUIT manifest design summary
>   4.  Interpreter Behaviour
>       4.1.  Interpreter Setup
>       4.2.  Required Checks
>       4.3.  Interpreter fundamental properties
>       4.4.  Abstract Machine Description
>             4.4.1.  Parameters
>             4.4.2.  Commands
>             4.4.3.  Command Behaviour
>       4.5.  Serialized Processing Interpreter
>   5.  Creating Manifests
>       5.1.  Manifest Source Material
>       5.2.  Use Case Templates
>   6.  Manifest Structure
>   7.  Dependency processing
>   8.  Access Control Lists
>   9.  SUIT digest container
>   10.  Creating conditional sequences
>   11.  Full CDDL
>   12.  Examples
>
> Sections 3, 4, 5 are new. 3 contains mostly existing content with a new “how to use this document” section. Section 4 describes the behaviour of a manifest interpreter. Section 4 could give rise to a set of test vectors for manifest interpreters so that we can ensure correctness. Section 5 specifies what a manifest compiler needs to do.
>
> I would also like feedback from the working group on the possibility of removing the examples section and placing that in a separate informative draft.
>
> Best Regards,
> Brendan
> IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you.
> _______________________________________________
> Suit mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/suit

IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you.

---

From: Brendan Moran <[email-masked]>
Date: Mon, 4 Nov 2019 14:50:35 +0000

I have now added the final set of changes prior to submission of this update. The text is available in GitHub. If there is no feedback, I plan to submit this version early this evening.

Best Regards,
Brendan

> On 1 Nov 2019, at 08:53, Brendan Moran <[email-masked]> wrote:
>

---

From: Dave Thaler <[email-masked]>
Date: Mon, 4 Nov 2019 18:59:57 +0000

Thanks!  I just did a quick skim and found some typos, so submitted a pull request to fix the typos.

https://github.com/suit-wg/manifest-spec/pull/4

Dave

-----Original Message-----
From: Suit <[email-masked]> On Behalf Of Brendan Moran
Sent: Monday, November 4, 2019 6:51 AM
To: suit <[email-masked]>
Subject: Re: [Suit] Proposal for changes to draft-ietf-suit-manifest

https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fgithub.com%2Fsuit-wg%2Fmanifest-spec%2Fpull%2F1&amp;data=02%7C01%7Cdthaler%40microsoft.com%7C85076025148d4a00c8de08d761366542%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637084759510337641&amp;sdata=p9CrsypIrBkFgb6LllxYiqJIvFKuRDGfv1opG7w%2BEN4%3D&amp;reserved=0

Best Regards,
Brendan

> https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fgith
> ub.com%2Fsuit-wg%2Fmanifest-spec%2Fpull%2F1&amp;data=02%7C01%7Cdthaler
> %40microsoft.com%7C85076025148d4a00c8de08d761366542%7C72f988bf86f141af
> 91ab2d7cd011db47%7C1%7C0%7C637084759510337641&amp;sdata=p9CrsypIrBkFgb
> 6LllxYiqJIvFKuRDGfv1opG7w%2BEN4%3D&amp;reserved=0
>
> Best Regards,
> Brendan
>
>>            3.2.4.  SUIT manifest design summary  4.  Interpreter 
>> Behaviour
>>      4.1.  Interpreter Setup
>>      4.2.  Required Checks
>>      4.5.  Serialized Processing Interpreter  5.  Creating Manifests
>> https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww
>> .ietf.org%2Fmailman%2Flistinfo%2Fsuit&amp;data=02%7C01%7Cdthaler%40mi
>> crosoft.com%7C85076025148d4a00c8de08d761366542%7C72f988bf86f141af91ab
>> 2d7cd011db47%7C1%7C0%7C637084759510337641&amp;sdata=vyHJaxcJv2DH36dfQ
>> CU74l8ZgFPkdvB%2BADN%2B3ULvPE0%3D&amp;reserved=0
>
> https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.
> ietf.org%2Fmailman%2Flistinfo%2Fsuit&amp;data=02%7C01%7Cdthaler%40micr
> osoft.com%7C85076025148d4a00c8de08d761366542%7C72f988bf86f141af91ab2d7
> cd011db47%7C1%7C0%7C637084759510337641&amp;sdata=vyHJaxcJv2DH36dfQCU74
> l8ZgFPkdvB%2BADN%2B3ULvPE0%3D&amp;reserved=0

IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you.
_______________________________________________
Suit mailing list
[email-masked]
https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fsuit&amp;data=02%7C01%7Cdthaler%40microsoft.com%7C85076025148d4a00c8de08d761366542%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637084759510337641&amp;sdata=vyHJaxcJv2DH36dfQCU74l8ZgFPkdvB%2BADN%2B3ULvPE0%3D&amp;reserved=0

---

From: Michael Richardson <[email-masked]>
Date: Tue, 05 Nov 2019 16:56:04 -0500

Brendan Moran <[email-masked]> wrote:
    > I have now added the final set of changes prior to submission of this
    > update. The text is available in GitHub. If there is no feedback, I
    > plan to submit this version early this evening.

    > https://github.com/suit-wg/manifest-spec/pull/1

Last week, I wanted to review your proposed ToC changes, but realized I had
to compare it to what was there before.  And draft deadline loomed..

I see that you merged the result, and I looked at the (rfc)diff, and I think that
it is an improvement.

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-