Subject: [Suit] Is draft-ietf-suit-manifest-07 ready for WGLC?

From: "Waltermire, David A. (Fed)" <[email-masked]>
Date: Tue, 9 Jun 2020 17:32:31 +0000

I'd like to get a sense from the working group about how mature everyone thinks this draft is. Do you think there are any significant areas or work that still need to be addressed before starting a WGLC?

Dave

-----Original Message-----
From: Suit <[email-masked]> On Behalf Of Hannes Tschofenig
Sent: Tuesday, June 9, 2020 1:15 PM
To: suit <[email-masked]>
Subject: [Suit] draft-ietf-suit-manifest-07

Hi all,

I just submitted version -07 of the manifest draft.

Here are the changes:

* Corrected the boilerplate text (it was wrong also in the architecture and the information model draft)
* All CDDL text is now concentrated in one place. This should make it easier to read.
* Fixed various TBDs for parameter descriptions in the text
* Enhanced IANA consideration section
* Completed the Implementation Conformance Matrix
* Removed mailing list info

Here is the doc:
https://gcc02.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftools.ietf.org%2Fhtml%2Fdraft-ietf-suit-manifest-07&amp;data=02%7C01%7Cdavid.waltermire%40nist.gov%7C0bebc9420b4d4a8414d708d80c98afec%7C2ab5d82fd8fa4797a93e054655c61dec%7C1%7C0%7C637273197219461344&amp;sdata=FIDOF03YpTKQXnVbfFWdFZlbMyCWRCh6pS4MeGnAP4M%3D&amp;reserved=0

Here is the diff:
https://gcc02.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Frfcdiff%3Furl2%3Ddraft-ietf-suit-manifest-07&amp;data=02%7C01%7Cdavid.waltermire%40nist.gov%7C0bebc9420b4d4a8414d708d80c98afec%7C2ab5d82fd8fa4797a93e054655c61dec%7C1%7C0%7C637273197219461344&amp;sdata=6FNvlZKR51AdHRb2y2gLZHflbNxg5Xug%2BQxAQSJPlMs%3D&amp;reserved=0

Ciao
Hannes

IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you.

_______________________________________________
Suit mailing list
[email-masked]
https://gcc02.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fsuit&amp;data=02%7C01%7Cdavid.waltermire%40nist.gov%7C0bebc9420b4d4a8414d708d80c98afec%7C2ab5d82fd8fa4797a93e054655c61dec%7C1%7C0%7C637273197219461344&amp;sdata=%2Fa4VetAyNJLU776I5uy%2Bf2%2Fs3%2FCGVPVG5iytA3MQZ4s%3D&amp;reserved=0

---

From: Hannes Tschofenig <[email-masked]>
Date: Tue, 9 Jun 2020 18:23:05 +0000

Hi David,

the last few draft updates have focused on improving readability. I also believe we need more examples and that's something I will focus on next.
The upcoming hackathon might also help to provide further input.

Ciao
Hannes

-----Original Message-----
From: Waltermire, David A. (Fed) <[email-masked]>
Sent: Tuesday, June 9, 2020 7:33 PM
To: Hannes Tschofenig <[email-masked]>; suit <[email-masked]>
Subject: Is draft-ietf-suit-manifest-07 ready for WGLC?

Dave

-----Original Message-----
From: Suit <[email-masked]> On Behalf Of Hannes Tschofenig
Sent: Tuesday, June 9, 2020 1:15 PM
To: suit <[email-masked]>
Subject: [Suit] draft-ietf-suit-manifest-07

Hi all,

Here are the changes:

Here is the doc:

Here is the diff:

Ciao
Hannes

---

From: "Waltermire, David A. (Fed)" <[email-masked]>
Date: Tue, 23 Jun 2020 16:30:26 +0000

Hannes,

Do you plan to provide an update with more examples before the IETF meeting?

Dave

-----Original Message-----
From: Hannes Tschofenig <[email-masked]> 
Sent: Tuesday, June 9, 2020 2:23 PM
To: Waltermire, David A. (Fed) <[email-masked]>; suit <[email-masked]>
Subject: RE: Is draft-ietf-suit-manifest-07 ready for WGLC?

Hi David,

Ciao
Hannes

-----Original Message-----
From: Waltermire, David A. (Fed) <[email-masked]>
Sent: Tuesday, June 9, 2020 7:33 PM
To: Hannes Tschofenig <[email-masked]>; suit <[email-masked]>
Subject: Is draft-ietf-suit-manifest-07 ready for WGLC?

Dave

-----Original Message-----
From: Suit <[email-masked]> On Behalf Of Hannes Tschofenig
Sent: Tuesday, June 9, 2020 1:15 PM
To: suit <[email-masked]>
Subject: [Suit] draft-ietf-suit-manifest-07

Hi all,

Here are the changes:

Here is the doc:
https://gcc02.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftools.ietf.org%2Fhtml%2Fdraft-ietf-suit-manifest-07&amp;data=02%7C01%7Cdavid.waltermire%40nist.gov%7Caeb629d8c4974384e31d08d80ca23065%7C2ab5d82fd8fa4797a93e054655c61dec%7C1%7C0%7C637273238026315038&amp;sdata=x7vJqnQn2BZ5vB6epqMWQxKQcZDPge2vcrDXFOdUkJo%3D&amp;reserved=0

Here is the diff:
https://gcc02.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Frfcdiff%3Furl2%3Ddraft-ietf-suit-manifest-07&amp;data=02%7C01%7Cdavid.waltermire%40nist.gov%7Caeb629d8c4974384e31d08d80ca23065%7C2ab5d82fd8fa4797a93e054655c61dec%7C1%7C0%7C637273238026324995&amp;sdata=N3%2FREsY%2BWdbGNueWgx5O9wnvz7iivoa%2FJtT%2FkPx75%2BE%3D&amp;reserved=0

Ciao
Hannes

_______________________________________________
Suit mailing list
[email-masked]
https://gcc02.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fsuit&amp;data=02%7C01%7Cdavid.waltermire%40nist.gov%7Caeb629d8c4974384e31d08d80ca23065%7C2ab5d82fd8fa4797a93e054655c61dec%7C1%7C0%7C637273238026324995&amp;sdata=o8czKKEG6wt6%2BtIJiIv5OXy5R9d17AfcTqYzOVpTsSY%3D&amp;reserved=0
IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you.

---

From: Hannes Tschofenig <[email-masked]>
Date: Tue, 23 Jun 2020 17:46:07 +0000

The authors were planning to ship another draft update in time for the hackathon.
I was thinking about adding a few examples and those could be discussed and refined during the hackathon.

-----Original Message-----
From: Waltermire, David A. (Fed) <[email-masked]>
Sent: Tuesday, June 23, 2020 6:30 PM
To: Hannes Tschofenig <[email-masked]>; suit <[email-masked]>
Subject: RE: Is draft-ietf-suit-manifest-07 ready for WGLC?

Hannes,

Dave

-----Original Message-----
From: Hannes Tschofenig <[email-masked]>
Sent: Tuesday, June 9, 2020 2:23 PM
To: Waltermire, David A. (Fed) <[email-masked]>; suit <[email-masked]>
Subject: RE: Is draft-ietf-suit-manifest-07 ready for WGLC?

Hi David,

Ciao
Hannes

-----Original Message-----
From: Waltermire, David A. (Fed) <[email-masked]>
Sent: Tuesday, June 9, 2020 7:33 PM
To: Hannes Tschofenig <[email-masked]>; suit <[email-masked]>
Subject: Is draft-ietf-suit-manifest-07 ready for WGLC?

Dave

-----Original Message-----
From: Suit <[email-masked]> On Behalf Of Hannes Tschofenig
Sent: Tuesday, June 9, 2020 1:15 PM
To: suit <[email-masked]>
Subject: [Suit] draft-ietf-suit-manifest-07

Hi all,

Here are the changes:

Here is the doc:

Here is the diff:

Ciao
Hannes

---

From: "Waltermire, David A. (Fed)" <[email-masked]>
Date: Tue, 23 Jun 2020 21:30:58 +0000

That would be great. I talked with Dave and Russ today. We want to be in a good position to start a WG on the manifest after the IETF 108 WG meeting if possible. To this end, we need to work through any remaining issues.

This means that any updates to the manifest draft need to be identified and worked as part of the hackathon.

Do you think this will be possible?

Dave

-----Original Message-----
From: Waltermire, David A. (Fed) <[email-masked]>
Sent: Tuesday, June 23, 2020 6:30 PM
To: Hannes Tschofenig <[email-masked]>; suit <[email-masked]>
Subject: RE: Is draft-ietf-suit-manifest-07 ready for WGLC?

Hannes,

Dave

-----Original Message-----
From: Hannes Tschofenig <[email-masked]>
Sent: Tuesday, June 9, 2020 2:23 PM
To: Waltermire, David A. (Fed) <[email-masked]>; suit <[email-masked]>
Subject: RE: Is draft-ietf-suit-manifest-07 ready for WGLC?

Hi David,

Ciao
Hannes

-----Original Message-----
From: Waltermire, David A. (Fed) <[email-masked]>
Sent: Tuesday, June 9, 2020 7:33 PM
To: Hannes Tschofenig <[email-masked]>; suit <[email-masked]>
Subject: Is draft-ietf-suit-manifest-07 ready for WGLC?

Dave

-----Original Message-----
From: Suit <[email-masked]> On Behalf Of Hannes Tschofenig
Sent: Tuesday, June 9, 2020 1:15 PM
To: suit <[email-masked]>
Subject: [Suit] draft-ietf-suit-manifest-07

Hi all,

Here are the changes:

Here is the doc:
https://gcc02.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftools.ietf.org%2Fhtml%2Fdraft-ietf-suit-manifest-07&amp;data=02%7C01%7Cdavid.waltermire%40nist.gov%7C813f72b1e9614545aedd08d8179d55b5%7C2ab5d82fd8fa4797a93e054655c61dec%7C1%7C0%7C637285311809216524&amp;sdata=EGpO%2ByNDuxtenIRZbv8H6IY46H8uwdFrX0qprOGII6A%3D&amp;reserved=0

Here is the diff:
https://gcc02.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Frfcdiff%3Furl2%3Ddraft-ietf-suit-manifest-07&amp;data=02%7C01%7Cdavid.waltermire%40nist.gov%7C813f72b1e9614545aedd08d8179d55b5%7C2ab5d82fd8fa4797a93e054655c61dec%7C1%7C0%7C637285311809226518&amp;sdata=K5AiUbsml%2B%2Bf79FfOAj9lwUatSIK4NLmn3MnTkIMrbY%3D&amp;reserved=0

Ciao
Hannes

_______________________________________________
Suit mailing list
[email-masked]
https://gcc02.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fsuit&amp;data=02%7C01%7Cdavid.waltermire%40nist.gov%7C813f72b1e9614545aedd08d8179d55b5%7C2ab5d82fd8fa4797a93e054655c61dec%7C1%7C0%7C637285311809226518&amp;sdata=Jl7ZQNRIyx5cpfbACkbhp77j2PbfcYwnKlr72iZQZWQ%3D&amp;reserved=0
IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you.
IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you.

---

From: Emmanuel Baccelli <[email-masked]>
Date: Wed, 24 Jun 2020 11:58:50 +0200

Hi Dave, all

our team (including Koen) is working on upgrading our SUIT implementation
(open sourced, in RIOT) to comply with version -07 of the manifest draft.
It seems healthy to plan on having such implementation work under our belt
by the time WGLC starts.
If all goes as planned, we should indeed be in such a position after the
hackathon and IETF108?

Cheers,

Emmanuel

On Tue, Jun 23, 2020 at 11:31 PM Waltermire, David A. (Fed)
<david.waltermire=[email-masked]> wrote:

> That would be great. I talked with Dave and Russ today. We want to be in a
> good position to start a WG on the manifest after the IETF 108 WG meeting
> if possible. To this end, we need to work through any remaining issues.
>
> the last few draft updates have focused on improving readability. I also
> believe we need more examples and that's something I will focus on next.
> I'd like to get a sense from the working group about how mature everyone
> thinks this draft is. Do you think there are any significant areas or work
> that still need to be addressed before starting a WGLC?
>
> Dave
>
> IMPORTANT NOTICE: The contents of this email and any attachments are
> confidential and may also be privileged. If you are not the intended
> recipient, please notify the sender immediately and do not disclose the
> contents to any other person, use it for any purpose, or store or copy the
> information in any medium. Thank you.
>
> IMPORTANT NOTICE: The contents of this email and any attachments are
> confidential and may also be privileged. If you are not the intended
> recipient, please notify the sender immediately and do not disclose the
> contents to any other person, use it for any purpose, or store or copy the
> information in any medium. Thank you.
> IMPORTANT NOTICE: The contents of this email and any attachments are
> confidential and may also be privileged. If you are not the intended
> recipient, please notify the sender immediately and do not disclose the
> contents to any other person, use it for any purpose, or store or copy the
> information in any medium. Thank you.
>
> https://www.ietf.org/mailman/listinfo/suit
>

---

From: "Waltermire, David A. (Fed)" <[email-masked]>
Date: Wed, 24 Jun 2020 13:34:53 +0000

Emmanuel,

Thanks for the update. This is good news.

Have you had a chance to review the updates that Brendan is proposing? Will these changes impact your schedule?

Thanks,
Dave

From: Suit <[email-masked]> On Behalf Of Emmanuel Baccelli
Sent: Wednesday, June 24, 2020 5:59 AM
To: suit <[email-masked]>
Subject: Re: [Suit] Is draft-ietf-suit-manifest-07 ready for WGLC?

Hi Dave, all

our team (including Koen) is working on upgrading our SUIT implementation (open sourced, in RIOT) to comply with version -07 of the manifest draft.
It seems healthy to plan on having such implementation work under our belt by the time WGLC starts.
If all goes as planned, we should indeed be in such a position after the hackathon and IETF108?

Cheers,

Emmanuel

On Tue, Jun 23, 2020 at 11:31 PM Waltermire, David A. (Fed) <david.waltermire=[email-masked]<mailto:[email-masked]>> wrote:
That would be great. I talked with Dave and Russ today. We want to be in a good position to start a WG on the manifest after the IETF 108 WG meeting if possible. To this end, we need to work through any remaining issues.

Dave

-----Original Message-----
From: Waltermire, David A. (Fed) <[email-masked]<mailto:[email-masked]>>
Sent: Tuesday, June 23, 2020 6:30 PM
To: Hannes Tschofenig <[email-masked]<mailto:[email-masked]>>; suit <[email-masked]<mailto:[email-masked]>>
Subject: RE: Is draft-ietf-suit-manifest-07 ready for WGLC?

Hannes,

Dave

-----Original Message-----
From: Hannes Tschofenig <[email-masked]<mailto:[email-masked]>>
Sent: Tuesday, June 9, 2020 2:23 PM
To: Waltermire, David A. (Fed) <[email-masked]<mailto:[email-masked]>>; suit <[email-masked]<mailto:[email-masked]>>
Subject: RE: Is draft-ietf-suit-manifest-07 ready for WGLC?

Hi David,

Ciao
Hannes

-----Original Message-----
From: Waltermire, David A. (Fed) <[email-masked]<mailto:[email-masked]>>
Sent: Tuesday, June 9, 2020 7:33 PM
To: Hannes Tschofenig <[email-masked]<mailto:[email-masked]>>; suit <[email-masked]<mailto:[email-masked]>>
Subject: Is draft-ietf-suit-manifest-07 ready for WGLC?

Dave

-----Original Message-----
From: Suit <[email-masked]<mailto:[email-masked]>> On Behalf Of Hannes Tschofenig
Sent: Tuesday, June 9, 2020 1:15 PM
To: suit <[email-masked]<mailto:[email-masked]>>
Subject: [Suit] draft-ietf-suit-manifest-07

Hi all,

Here are the changes:

Here is the doc:
https://gcc02.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftools.ietf.org%2Fhtml%2Fdraft-ietf-suit-manifest-07&amp;data=02%7C01%7Cdavid.waltermire%40nist.gov%7C813f72b1e9614545aedd08d8179d55b5%7C2ab5d82fd8fa4797a93e054655c61dec%7C1%7C0%7C637285311809216524&amp;sdata=EGpO%2ByNDuxtenIRZbv8H6IY46H8uwdFrX0qprOGII6A%3D&amp;reserved=0<https://gcc02.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftools.ietf.org%2Fhtml%2Fdraft-ietf-suit-manifest-07&data=02%7C01%7Cdavid.waltermire%40nist.gov%7Cad380ebdb1f2446dc5be08d8182544ec%7C2ab5d82fd8fa4797a93e054655c61dec%7C1%7C0%7C637285895640279532&sdata=HgSw2jDJmXq%2BMehRzv%2BmHpf0Ys%2Fwoazrft5xXdhXFMs%3D&reserved=0>

Here is the diff:
https://gcc02.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Frfcdiff%3Furl2%3Ddraft-ietf-suit-manifest-07&amp;data=02%7C01%7Cdavid.waltermire%40nist.gov%7C813f72b1e9614545aedd08d8179d55b5%7C2ab5d82fd8fa4797a93e054655c61dec%7C1%7C0%7C637285311809226518&amp;sdata=K5AiUbsml%2B%2Bf79FfOAj9lwUatSIK4NLmn3MnTkIMrbY%3D&amp;reserved=0<https://gcc02.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Frfcdiff%3Furl2%3Ddraft-ietf-suit-manifest-07&data=02%7C01%7Cdavid.waltermire%40nist.gov%7Cad380ebdb1f2446dc5be08d8182544ec%7C2ab5d82fd8fa4797a93e054655c61dec%7C1%7C0%7C637285895640289490&sdata=NXxF9JpQ33k4XGuGlAfRWWjzseXTrf44GNCGqWkju4o%3D&reserved=0>

Ciao
Hannes

_______________________________________________
Suit mailing list
[email-masked]<mailto:[email-masked]>
https://gcc02.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fsuit&amp;data=02%7C01%7Cdavid.waltermire%40nist.gov%7C813f72b1e9614545aedd08d8179d55b5%7C2ab5d82fd8fa4797a93e054655c61dec%7C1%7C0%7C637285311809226518&amp;sdata=Jl7ZQNRIyx5cpfbACkbhp77j2PbfcYwnKlr72iZQZWQ%3D&amp;reserved=0<https://gcc02.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fsuit&data=02%7C01%7Cdavid.waltermire%40nist.gov%7Cad380ebdb1f2446dc5be08d8182544ec%7C2ab5d82fd8fa4797a93e054655c61dec%7C1%7C0%7C637285895640289490&sdata=NE%2FlkI9Aa4NkiyPIT9UuS%2Fs6HGBqv5MrwjOW6KmSsRE%3D&reserved=0>
IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you.
IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you.

_______________________________________________
Suit mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/suit<https://gcc02.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fsuit&data=02%7C01%7Cdavid.waltermire%40nist.gov%7Cad380ebdb1f2446dc5be08d8182544ec%7C2ab5d82fd8fa4797a93e054655c61dec%7C1%7C0%7C637285895640299448&sdata=4rFSBwmqHEsYKS23UyQwOWWD4YhdL%2FrhFbQS8HsTxwk%3D&reserved=0>