Subject: [Suit] architecture draft -v15

From: Hannes Tschofenig <[email-masked]>
Date: Mon, 18 Jan 2021 06:42:35 +0000

Hi all,

I have just submitted version 15 of the architecture draft. This version includes the review from the IESG and from various directorates.
Reviewers requested a lot of clarifications and hence the draft changed quite a bit (on the editorial side). Here is the diff:
https://www.ietf.org/rfcdiff?url2=draft-ietf-suit-architecture-15

Here is the doc:
https://www.ietf.org/archive/id/draft-ietf-suit-architecture-15.txt

Ciao
Hannes

IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you.

---

From: Michael Richardson <[email-masked]>
Date: Tue, 19 Jan 2021 13:39:14 -0500

On 2021-01-18 1:42 a.m., Hannes Tschofenig wrote:
> Hi all,
> 
> I have just submitted version 15 of the architecture draft. This version 
> includes the review from the IESG and from various directorates.
> 
> Reviewers requested a lot of clarifications and hence the draft changed 
> quite a bit (on the editorial side). Here is the diff:

Yes, it did.  The change in the table of contents alone made me re-read 
it from the beginning rather than just the diff.

I found a number of places where the wording was poor due to grammar, 
and I'm trying to send that as a pull request since it does not affect 
the (intended) meaning.   I think you forgot to commit/push your -15 to 
github though.

Figure 5 and 6 are long and have some unfortunate page breaks.
I think that you could squeeze a few filler lines out of figure 6,
and perhaps when going to PDF, it will be fine.  We aren't doing page 
breaks in text RFCs, so it likely isn't as important.

Figure 5 is rather long though, and I suggest that you might want to 
split it up into two figures, repeating the 
author/firmware-server/consumer/bootloader headings.
I suggest splitting it at "Request Firmware", repeating "Request 
Firmware"/"Send Firmware" at the bottom of one diagram and the top of 
the other.  That split also means the second time-sequence does not need 
"Author" heading at all.

I can tell that you did a lot of work based upon the reviews, it all 
seems great. Thank you.

---

From: Hannes Tschofenig <[email-masked]>
Date: Wed, 27 Jan 2021 10:10:59 +0000

Hi Michael,

I was wondering why you thought the document contained poor wording given the number of changes I had made. Now, I know why you thought so.

As stated in my other mail, I submitted the correct version of the draft.

Ciao
Hannes

-----Original Message-----
From: Suit <[email-masked]> On Behalf Of Michael Richardson
Sent: Tuesday, January 19, 2021 7:39 PM
To: [email-masked]
Subject: Re: [Suit] architecture draft -v15

On 2021-01-18 1:42 a.m., Hannes Tschofenig wrote:
> Hi all,
>
> I have just submitted version 15 of the architecture draft. This
> version includes the review from the IESG and from various directorates.
>
> Reviewers requested a lot of clarifications and hence the draft
> changed quite a bit (on the editorial side). Here is the diff:

Yes, it did.  The change in the table of contents alone made me re-read it from the beginning rather than just the diff.

I found a number of places where the wording was poor due to grammar, and I'm trying to send that as a pull request since it does not affect
the (intended) meaning.   I think you forgot to commit/push your -15 to
github though.

Figure 5 and 6 are long and have some unfortunate page breaks.
I think that you could squeeze a few filler lines out of figure 6, and perhaps when going to PDF, it will be fine.  We aren't doing page breaks in text RFCs, so it likely isn't as important.

Figure 5 is rather long though, and I suggest that you might want to split it up into two figures, repeating the author/firmware-server/consumer/bootloader headings.
I suggest splitting it at "Request Firmware", repeating "Request Firmware"/"Send Firmware" at the bottom of one diagram and the top of the other.  That split also means the second time-sequence does not need "Author" heading at all.

I can tell that you did a lot of work based upon the reviews, it all seems great. Thank you.

_______________________________________________
Suit mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/suit
IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you.