Subject: [Suit] draft-tschofenig-suit-firmware-encryption-00

From: Hannes Tschofenig <[email-masked]>
Date: Tue, 25 May 2021 11:36:43 +0000

Hi all,

At the last IETF meeting I presented the hackathon results of the firmware encryption work. I talked through some of the challenges in implementing firmware encryption with COSE and the group decided to put the guidance of firmware encryption into a separate document.

Here is a first write-up of the firmware encryption for SUIT using AES-Key Wrap and HPKE. This is a first version and still incomplete. The solution for AES Key Wrap is in better shape (thanks to Russ) than the HPKE-based version. Unlike what I presented at the last IETF meeting this document uses HPKE for the public key encryption mechanism. There is code available for HPKE even though it is a fairly recent development in the CFRG. HPKE is used with the TLS ESNI and the MLS work.

I wanted to submit this snapshot for the virtual interim meeting today.

Here is the draft:
https://datatracker.ietf.org/doc/html/draft-tschofenig-suit-firmware-encryption

Ciao
Hannes

IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you.

---

From: Carsten Bormann <[email-masked]>
Date: Tue, 25 May 2021 13:43:21 +0200

Nice!

Editorial comment:
Can I suggest you use the 8152bis style of putting in the examples as opposed to the 8152 style that you are using now?
(They differ in the use of EDN, particularly Appendix G.3 of RFC 8610.)
[There is also some inventive comment syntax that has not been adopted in RFC 8610.]

Grüße, Carsten