Subject: [Suit] CALL FOR ADOPTION: draft-tschofenig-suit-firmware-encryption-00

From: Dave Thaler <[email-masked]>
Date: Tue, 25 May 2021 16:34:26 +0000

This email begins a 3-week call for adoption of draft-tschofenig-suit-firmware-encryption
to complete on June 15th.

The document was discussed in the interim meeting today and within the meeting attendees
there was support for adoption, and we previously agreed that this would be within the scope
of the existing charter.

Please speak up before June 15th if you have any concerns with adopting.

We hope folks will use this as an opportunity to review the document either way and post
technical comments to the list.
https://datatracker.ietf.org/doc/html/draft-tschofenig-suit-firmware-encryption<https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-tschofenig-suit-firmware-encryption&data=04%7C01%7Cdthaler%40microsoft.com%7C7f9d7b308faf4c3dbfd108d91f716dd9%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637575394861209432%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C0&sdata=8gaBeyYbHpDsyPAx%2F2wIh%2BmxD%2FBXv78ZWV8dB3Svwqk%3D&reserved=0>

Dave

From: Suit <[email-masked]> On Behalf Of Hannes Tschofenig
Sent: Tuesday, May 25, 2021 4:37 AM
To: [email-masked]
Subject: [Suit] draft-tschofenig-suit-firmware-encryption-00

Hi all,

At the last IETF meeting I presented the hackathon results of the firmware encryption work. I talked through some of the challenges in implementing firmware encryption with COSE and the group decided to put the guidance of firmware encryption into a separate document.

Here is a first write-up of the firmware encryption for SUIT using AES-Key Wrap and HPKE. This is a first version and still incomplete. The solution for AES Key Wrap is in better shape (thanks to Russ) than the HPKE-based version. Unlike what I presented at the last IETF meeting this document uses HPKE for the public key encryption mechanism. There is code available for HPKE even though it is a fairly recent development in the CFRG. HPKE is used with the TLS ESNI and the MLS work.

I wanted to submit this snapshot for the virtual interim meeting today.

Here is the draft:
https://datatracker.ietf.org/doc/html/draft-tschofenig-suit-firmware-encryption<https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-tschofenig-suit-firmware-encryption&data=04%7C01%7Cdthaler%40microsoft.com%7C7f9d7b308faf4c3dbfd108d91f716dd9%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637575394861209432%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C0&sdata=8gaBeyYbHpDsyPAx%2F2wIh%2BmxD%2FBXv78ZWV8dB3Svwqk%3D&reserved=0>

Ciao
Hannes

IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you.

---

From: Henk Birkholz <[email-masked]>
Date: Thu, 27 May 2021 21:53:17 +0200

Dear SUIT WG,

I support the adoption of this work. It is a natural extension to the 
SUIT space and needed in many places.

Viele Grüße,

Henk

On 25.05.21 18:34, Dave Thaler wrote:
> This email begins a 3-week call for adoption of 
> draft-tschofenig-suit-firmware-encryption
> 
> to complete on June 15^th .
> 
> Please speak up before June 15^th if you have any concerns with adopting.
> 
> https://datatracker.ietf.org/doc/html/draft-tschofenig-suit-firmware-encryption 
> <https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-tschofenig-suit-firmware-encryption&data=04%7C01%7Cdthaler%40microsoft.com%7C7f9d7b308faf4c3dbfd108d91f716dd9%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637575394861209432%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C0&sdata=8gaBeyYbHpDsyPAx%2F2wIh%2BmxD%2FBXv78ZWV8dB3Svwqk%3D&reserved=0>
> 
> Dave
> 
> *From:* Suit <[email-masked]> *On Behalf Of * Hannes Tschofenig
> *Sent:* Tuesday, May 25, 2021 4:37 AM
> *To:* [email-masked]
> *Subject:* [Suit] draft-tschofenig-suit-firmware-encryption-00
> 
> Hi all,
> 
> At the last IETF meeting I presented the hackathon results of the 
> firmware encryption work. I talked through some of the challenges in 
> implementing firmware encryption with COSE and the group decided to put 
> the guidance of firmware encryption into a separate document.
> 
> Here is a first write-up of the firmware encryption for SUIT using 
> AES-Key Wrap and HPKE. This is a first version and still incomplete. The 
> solution for AES Key Wrap is in better shape (thanks to Russ) than the 
> HPKE-based version. Unlike what I presented at the last IETF meeting 
> this document uses HPKE for the public key encryption mechanism. There 
> is code available for HPKE even though it is a fairly recent development 
> in the CFRG. HPKE is used with the TLS ESNI and the MLS work.
> 
> https://datatracker.ietf.org/doc/html/draft-tschofenig-suit-firmware-encryption 
> <https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-tschofenig-suit-firmware-encryption&data=04%7C01%7Cdthaler%40microsoft.com%7C7f9d7b308faf4c3dbfd108d91f716dd9%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637575394861209432%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C0&sdata=8gaBeyYbHpDsyPAx%2F2wIh%2BmxD%2FBXv78ZWV8dB3Svwqk%3D&reserved=0>
> 
> Ciao
> 
> Hannes
> 
> IMPORTANT NOTICE: The contents of this email and any attachments are 
> confidential and may also be privileged. If you are not the intended 
> recipient, please notify the sender immediately and do not disclose the 
> contents to any other person, use it for any purpose, or store or copy 
> the information in any medium. Thank you.
> 
> 
> _______________________________________________
> Suit mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/suit
>