Subject: [Suit] Hash Algorithm Identifiers (was: [Cbor] Packed CBOR review)

From: Brendan Moran <[email-masked]>
Date: Thu, 17 Jun 2021 13:31:52 +0000

cose-wg has now finalised a set of algorithm identifiers for digests. SUIT’s digest container predates this work, but now that draft-ietf-cose-hash-algs is in the RFC Editor’s queue, I think it might make sense to replace the suit-digest-algorithm-id with a COSE Algorithm Identifier.

Best Regards,
Brendan

> On 17 Jun 2021, at 12:33, Carsten Bormann <[email-masked]> wrote:
>
> I thought COSE did: https://datatracker.ietf.org/doc/draft-ietf-cose-hash-algs/
> (in RFC editor queue; registrations already done) did this:
>
>   | Name        | Value | Recommended |
>   |-------------|-------|-------------|
>   | SHA-1       |   -14 | Filter Only |
>   | SHA-256/64  |   -15 | Filter Only |
>   | SHA-256     |   -16 | Yes         |
>   | SHA-384     |   -43 | Yes         |
>   | SHA-512     |   -44 | Yes         |
>   | SHA-512/256 |   -17 | Yes         |
>   | SHAKE128    |   -18 | Yes         |
>   | SHAKE256    |   -45 | Yes         |
>
> Grüße, Carsten
>

IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you.

---

From: Russ Housley <[email-masked]>
Date: Thu, 17 Jun 2021 09:43:04 -0400

This makes sense to me. Using the same IANA registry is highly desirable.

Russ

> On Jun 17, 2021, at 9:31 AM, Brendan Moran <[email-masked]> wrote:
> 
> _______________________________________________
> Suit mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/suit

---

From: Hannes Tschofenig <[email-masked]>
Date: Thu, 17 Jun 2021 14:02:49 +0000

Thanks for tracking this, Brendan. It makes sense to align the SUIT manifest draft with the COSE alg draft.

-----Original Message-----
From: Suit <[email-masked]> On Behalf Of Brendan Moran
Sent: Thursday, June 17, 2021 3:32 PM
To: suit <[email-masked]>
Cc: Carsten Bormann <[email-masked]>
Subject: [Suit] Hash Algorithm Identifiers (was: [Cbor] Packed CBOR review)

Best Regards,
Brendan