Subject: [Suit] Integrated Payload Keys

From: Brendan Moran <[email-masked]>
Date: Thu, 22 Jul 2021 11:00:57 +0000

I have been discussing the use of integrated payloads and dependencies more.  The current form of the draft requires that a URI Reference is converted into a numeric key in order to index a payload or dependency in the envelope. If we were to permit string keys in the envelope, we could eliminate this conversion.

For 1-character URI References, this would require 0-1 additional bytes per integrated payload/dependency: the keys permitted are key < 0 or key > 23. This has always borne the risk that it would intersect with future extensions. However, if we use string keys for integrated payloads and dependencies, we eliminate that risk and eliminate string->int conversions on the recipient device.

What does the WG think of allowing string keys in the SUIT_Envelope?

Best Regards,
Brendan
IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you.

---

From: Russ Housley <[email-masked]>
Date: Thu, 22 Jul 2021 10:37:50 -0400

I like the avoidance of possible conflict with a future extension.

Russ

> On Jul 22, 2021, at 7:00 AM, Brendan Moran <[email-masked]> wrote:
> 
> _______________________________________________
> Suit mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/suit