Subject: [Suit] Call for Adoption: draft-tschofenig-suit-firmware-encryption

From: Dave Thaler <[email-masked]>
Date: Thu, 1 Jul 2021 19:02:35 +0000

As discussed at the recent SUIT WG interim (minutes-interim-2021-suit-01 (ietf.org)<https://datatracker.ietf.org/meeting/interim-2021-suit-01/materials/minutes-interim-2021-suit-01-202105251100-00>),

This email starts a 3-week SUIT WG call for adoption for draft-tschofenig-suit-firmware-encryption, which ends on 2021-07-22.

We already have agreement that such adoption would not require a charter update.

Please send your reply about whether you support adopting this document as a WG document.

On behalf of the SUIT WG Chairs,
Dave Thaler

---

From: Dave Thaler <[email-masked]>
Date: Thu, 1 Jul 2021 19:05:46 +0000

Correction... the actual call for adoption ran May 27 - June 15 as noted in
https://mailarchive.ietf.org/arch/msg/suit/DiJwzKsKf9iMJFDfEjYkfPnpt1o/

Instead, this email declares that based on the discussion at the interim meeting and the email thread
linked, the call for adoption completed and the draft is adopted by the SUIT WG.
Authors, please post draft-ietf-suit-firmware-encryption-00.

Dave

From: Dave Thaler
Sent: Thursday, July 1, 2021 12:03 PM
To: [email-masked]
Subject: Call for Adoption: draft-tschofenig-suit-firmware-encryption

---

From: Michael Richardson <[email-masked]>
Date: Sun, 04 Jul 2021 13:58:27 -0400

I have read the -00 and now the diff to -01.
I support adoption.

I believe that we had a long thread about the downsides to encryption, which
I hope the document will capture into the security considerations before
WGLC.

--
Michael Richardson <[email-masked]>   . o O ( IPv6 IøT consulting )
           Sandelman Software Works Inc, Ottawa and Worldwide

---

From: Hannes Tschofenig <[email-masked]>
Date: Wed, 7 Jul 2021 15:57:03 +0000

Thanks, Dave.

I will submit a -00 version based on what is currently in the draft and then use it as a foundation to capture the comments from the recent discussions.

Ciao
Hannes

From: Suit <[email-masked]> On Behalf Of Dave Thaler
Sent: Thursday, July 1, 2021 9:06 PM
To: [email-masked]
Subject: Re: [Suit] Call for Adoption: draft-tschofenig-suit-firmware-encryption

Dave

From: Dave Thaler
Sent: Thursday, July 1, 2021 12:03 PM
To: [email-masked]<mailto:[email-masked]>
Subject: Call for Adoption: draft-tschofenig-suit-firmware-encryption

On behalf of the SUIT WG Chairs,
Dave Thaler
IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you.