Subject: [Suit] SUIT related discussion in TEEP WG this week

From: Dave Thaler <[email-masked]>
Date: Mon, 8 Nov 2021 14:01:04 +0000

FYI to SUIT WG, a couple of SUIT related issues were filed in the TEEP github repo during the hackathon.
I wanted to surface these to the SUIT WG for visibility, and to invite SUIT folks to come to TEEP.

  *   "Adding three examples of suit manifests": https://github.com/ietf-teep/teep-protocol/pull/161
  *   "Updating Deleting Manifest": https://github.com/ietf-teep/teep-protocol/pull/169
     *   This PR seems to include changing the SUIT manifest draft as one of the options

Dave Thaler
(as a TEEP protocol spec co-author)

---

From: Akira Tsukamoto <[email-masked]>
Date: Thu, 18 Nov 2021 11:26:55 +0900

Hi Bredan,

It is regarding having integrated binary inside suit manifest, which
we are using in our prototype.

The manifest draft, the section "7.5.  Integrated Payload Template" is
updated accordingly as the payload envelope key is a string.
https://datatracker.ietf.org/doc/draft-ietf-suit-manifest/

The applicable section in new external manifest draft is probably 7.1.1,
but it seems to have an old description when it was an integer.
https://datatracker.ietf.org/doc/html/draft-moran-suit-trust-domains-00#section-7.1.1

If there is repository for the draft-moran-suit-trust-domains-00 on the github,
I am fine making the PR for it.

Best,
Akira

On 11/8/2021 11:01 PM, Dave Thaler wrote:
>   * “Adding three examples of suit manifests”: https://github.com/ietf-teep/teep-protocol/pull/161 <https://jpn01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fgithub.com%2Fietf-teep%2Fteep-protocol%2Fpull%2F161&data=04%7C01%7Cakira.tsukamoto%40aist.go.jp%7C336dc7d3216b4ca9eb6308d9a2c0430f%7C18a7fec8652f409b8369272d9ce80620%7C0%7C0%7C637719768912088234%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=O2%2B0PRNjVqHGz8RQU62qcaJlXpKnAbQEUJUgUk7vXmk%3D&reserved=0>
>   * “Updating Deleting Manifest”: https://github.com/ietf-teep/teep-protocol/pull/169 <https://jpn01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fgithub.com%2Fietf-teep%2Fteep-protocol%2Fpull%2F169&data=04%7C01%7Cakira.tsukamoto%40aist.go.jp%7C336dc7d3216b4ca9eb6308d9a2c0430f%7C18a7fec8652f409b8369272d9ce80620%7C0%7C0%7C637719768912098188%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=jDn9YBrUbiuh9uaKfY78JmtrkYPg973kDQb9h91RbJQ%3D&reserved=0>
>       o This PR seems to include changing the SUIT manifest draft as one of the options
> 
> Dave Thaler
> 
> _______________________________________________
> TEEP mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/teep
>