Subject: Re: [sunset4] New Version Notification for draft-jjmb-sunset4-dns-forwarding-ipv4aas-00.txt

From: "Brzozowski, John" <[email-masked]>
Date: Tue, 3 Nov 2015 04:30:41 +0000

Cross posting with dnsop and sunsets per email exchanges/conversations
with both sets of chairs.

John

-----Original Message-----
From: John Jason Brzozowski <[email-masked]>
Date: Monday, November 2, 2015 at 17:21
To: "[email-masked]" <[email-masked]>
Cc: Fred Baker <[email-masked]>, "[email-masked]"
<[email-masked]>, "[email-masked]" <[email-masked]>, Joel
Jaeggli <[email-masked]>, Paul Ebersman
<[email-masked]>, Brian Haberman
<[email-masked]>, "[email-masked]"
<[email-masked]>, Wesley George <[email-masked]>,
Marc Blanchet <[email-masked]>
Subject: New Version Notification for
draft-jjmb-sunset4-dns-forwarding-ipv4aas-00.txt

>sunset4,
>
>Please see the following I-D that was submitted earlier today.  We would
>appreciate your feedback and comments.  I had some offline email with the
>dnsop and v6ops chairs and ADs (they are copied instead of cross posting
>for now).  The guidance I received was to post this here to sunset4.
>
>Thanks,
>
>John
>+1-484-962-0060
>
>
>
>
>-----Original Message-----
>From: "[email-masked]" <[email-masked]>
>Date: Monday, November 2, 2015 at 16:48
>To: Paul Ebersman <[email-masked]>, John Jason Brzozowski
><[email-masked]>
>Subject: New Version Notification for
>draft-jjmb-sunset4-dns-forwarding-ipv4aas-00.txt
>
>>
>>A new version of I-D, draft-jjmb-sunset4-dns-forwarding-ipv4aas-00.txt
>>has been successfully submitted by John Jason Brzozowski and posted to
>>the
>>IETF repository.
>>
>>Name:		draft-jjmb-sunset4-dns-forwarding-ipv4aas
>>Revision:	00
>>Title:		DNS Forwarding and IPv4aaS
>>Document date:	2015-11-02
>>Group:		Individual Submission
>>Pages:		7
>>URL:            
>>https://www.ietf.org/internet-drafts/draft-jjmb-sunset4-dns-forwarding-ip
>>v
>>4aas-00.txt
>>Status:         
>>https://datatracker.ietf.org/doc/draft-jjmb-sunset4-dns-forwarding-ipv4aa
>>s
>>/
>>Htmlized:       
>>https://tools.ietf.org/html/draft-jjmb-sunset4-dns-forwarding-ipv4aas-00
>>
>>
>>Abstract:
>>   The depletion of IPv4 coupled with the wide spread deployment of IPv6
>>   for broadband globally is creating an environment where service
>>   providers can seriously begin to consider alternate uses and
>>   applications for native IPv6 connectivity.  Pervasive, reliable
>>   support for IPv6 across many access technologies suggests that one
>>   critical use for native IPv6 is the carry legacy IPv4 communications.
>>   Today this is referred to as IPv4 as a Service (IPv4aaS).  IPv4aaS
>>   can leverage a variety of transports ranging from Mapping of Address
>>   and Ports (MAP) to Generic Route Encapsulation (GRE) along with other
>>   viable protocols.  Most every use case for IPv4aaS includes the use
>>   of CG-NAT, however, this is not strictly required.  The purpose of
>>   this document is to hone in on DNS specific behavior that must be
>>   taken into consideration as the deployment of IPv4aaS advances
>>   globally.
>>
>>                 
>>        
>>
>>
>>Please note that it may take a couple of minutes from the time of
>>submission
>>until the htmlized version and diff are available at tools.ietf.org.
>>
>>The IETF Secretariat
>>
>>
>

---

From: "Brzozowski, John" <[email-masked]>
Date: Tue, 3 Nov 2015 06:01:14 +0000

Mark this is in part, what we are planning on doing.  However, what we
want to make sure we had was standards reference(s) that we could point
implementers to.  Also note this case only pertains to DNS queries that
are directed at the LAN of the CPE router i.e. 10.0.0.1.  There are other
use cases that we thought would be valuable to enumerate, including cases
where hosts are configured with a publicly routable IPv4 DNS server
address or DNS servers that are in the customer’s premises that are dual
stacked.  In the later cases assigning only a DNS server IPv6 address
would have no impact.

John
+1-484-962-0060

-----Original Message-----
From: Mark Andrews <[email-masked]>
Date: Tuesday, November 3, 2015 at 14:37
Cc: John Jason Brzozowski <[email-masked]>, Brian
Haberman <[email-masked]>, "[email-masked]" <[email-masked]>,
Joel Jaeggli <[email-masked]>, Fred Baker <[email-masked]>,
"[email-masked]" <[email-masked]>, Paul Ebersman
<[email-masked]>, "[email-masked]"
<[email-masked]>
Subject: Re: [DNSOP] New Version Notification for
draft-jjmb-sunset4-dns-forwarding-ipv4aas-00.txt

>
>Also perhaps we should be looking at RFC3901bis.  Alain, Johan are you
>interested?
>
>Mark
>
>In message <[email-masked]>, Mark Andrews
>writes:
>> 
>> The simplest way to force this is for the ISP to only supply IPv6
>> recursive recursive servers to the CPE where 464XLAT / MAP* / DS-Lite
>> is in use.  Also if a DUID is presented over DHCPv4 (RFC 4361) don't
>> return nameservers.  The CPE device should be getting nameservers
>> via RA/DHCPv6 in this case.
>> 
>> The CPE at this point can only advertise it's own addresses IPv4
>> address or manually configured addresses.
>> 
>> Iterative servers should prefer IPv6.
>> 
>> Mark
>> -- 
>> Mark Andrews, ISC
>> 1 Seymour St., Dundas Valley, NSW 2117, Australia
>> PHONE: +61 2 9871 4742                 INTERNET: [email-masked]
>> 
>> _______________________________________________
>> DNSOP mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/dnsop
>-- 
>Mark Andrews, ISC
>1 Seymour St., Dundas Valley, NSW 2117, Australia
>PHONE: +61 2 9871 4742                 INTERNET: [email-masked]
>

---

From: "Brzozowski, John" <[email-masked]>
Date: Tue, 3 Nov 2015 06:03:39 +0000

Forgot to add, I am interested in RFC3901bis.

John
+1-484-962-0060

-----Original Message-----
From: John Jason Brzozowski <[email-masked]>
Date: Tuesday, November 3, 2015 at 15:01
To: Mark Andrews <[email-masked]>
Cc: Brian Haberman <[email-masked]>, "[email-masked]"
<[email-masked]>, Joel Jaeggli <[email-masked]>, Fred Baker
<[email-masked]>, "[email-masked]" <[email-masked]>, Paul Ebersman
<[email-masked]>, "[email-masked]"
<[email-masked]>
Subject: Re: [DNSOP] New Version Notification for
draft-jjmb-sunset4-dns-forwarding-ipv4aas-00.txt