Subject: [Supa] New SUPA charter text

From: Benoit Claise <[email-masked]>
Date: Mon, 7 Sep 2015 16:51:57 +0200

Dear all,

Based on my review of the mailing list, 
https://github.com/IETF-SUPA/SUPA/wiki/Charter-Diff (thanks for this 
btw), my discussion with the BoF chairs and some other people, I tried 
to integrate all the changes in this new charter version.
I moved this charter into the internal review state 
(https://datatracker.ietf.org/doc/help/state/charter/)

Please review https://datatracker.ietf.org/doc/charter-ietf-supa/ 
version00-09ASAP, for any mistake.
At this point, we passed the wordsmithing phase.

Looking now at the timing before Yokohama.
A charter takes at the minimum one week internal review + two IESG 
formal telechats.
I'm shooting for the Sept 17th and Oct 1th IESG formal telechats.
However, the request for WG agenda time must be completed by Sept 18th.
If the IESG approves the charter for external review on the Sept 17th 
telechat, I'll reserve the WG slot in the agenda, anticipating a 
positive answer on the WG creation.

Regards, Benoit (OPS AD)

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Tue, 8 Sep 2015 14:40:23 +0200

> At this point, we passed the wordsmithing phase.

It is unclear whether you want to have feedback or not. I will send it
anyway, feel free to ignore since we 'passed the wordsmithing phase'.

I have two comments:

- It is unclear what SUPA is going to do regarding declarative
  policies. The charter text says

    (iii) the working group will investigate the practically of building policy
    rules that declaratively specify what goals to achieve (this is often called
    "intent-based" policy) but not how to achieve those goals and may create a model
    accordingly

  but it also says:

    Out of scope of this working group are:
    [...]
    - Declarative a.k.a intent-based policy rules. Another extension for defining
    policy rules according to a declarative, or intent-based, paradigm, may be
    produced in later phases of SUPA work.

  For me this is confusing but perhaps I just do not read the text in
  the right way.

- The other comment concerns this text:

    SUPA however will not deal with
    the definition of the specific network configuration changes but with how the
    configuration changes are applied (e.g. who is allowed to set policies, when and
    how the policies are activated, changed or de-activated)

  Is SUPA going to work out how actions are specified and executed?
  For example: Assuming the ACL YANG data model worked on in NETMOD,
  will I be able to use SUPA policy data models without further data
  models to populate my ACL lists? Or is the idea that SUPA only
  provide a core framework that requires data model extensions to do
  anything meaningful? Pretty much like the interfaces data model that
  requires interface type specific extensions to be really useful.

Now I shut up. ;-)

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1 | 28759 Bremen | Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Tue, 8 Sep 2015 18:55:01 +0000

Hi, 

See in-text. 

Regards,

Dan

> -----Original Message-----
> From: Supa [mailto:[email-masked]] On Behalf Of Juergen
> Schoenwaelder
> Sent: Tuesday, September 08, 2015 3:40 PM
> To: Benoit Claise
> Cc: [email-masked]
> Subject: Re: [Supa] New SUPA charter text
> 
> > Please review
> > https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.
> > org_doc_charter-2Dietf-
> 2Dsupa_&d=BQICAg&c=BFpWQw8bsuKpl1SgiZH64Q&r=I4d
> >
> zGxR31OcNXCJfQzvlsiLQfucBXRucPvdrphpBsFA&m=FjFbmJya6x58nXbHAJ389
> Wd24wZ
> >
> U2zmjtIlRJFIAHB0&s=yGfhqxgu2nlg2EOrZwD3qlRzY9ykPQwO8IXMAc8KrFw&
> e=
> It is unclear whether you want to have feedback or not. I will send it anyway,
> feel free to ignore since we 'passed the wordsmithing phase'.
> 
> I have two comments:
> 

IMO - the text says that we can (continue to) investigate 'practicality' as well as how to avoid conflict with work chartered in other WGs, but we should not write a data model in the first phase of the WG. We may do this 'in later phases'. 

>   requires interface type specific extensions to be really useful.

IMO - rather the later. Yet, I would observe - as you brought up the example - that some people do useful things and get useful information from the interfaces table MIB objects. 

> Now I shut up. ;-)

Why? :-)

> Fax:   +49 421 200 3103
> <https://urldefense.proofpoint.com/v2/url?u=http-3A__www.jacobs-
> 2Duniversity.de_&d=BQICAg&c=BFpWQw8bsuKpl1SgiZH64Q&r=I4dzGxR31O
> cNXCJfQzvlsiLQfucBXRucPvdrphpBsFA&m=FjFbmJya6x58nXbHAJ389Wd24wZ
> U2zmjtIlRJFIAHB0&s=qrI__AXlgml5bUqjuH_K_dNchVZDYRzehsCmOTpRXRg
> &e= >
> 
> _______________________________________________
> Supa mailing list
> [email-masked]
> https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__www.ietf.org_mailman_listinfo_supa&d=BQICAg&c=BFpWQw8bsuKpl1
> SgiZH64Q&r=I4dzGxR31OcNXCJfQzvlsiLQfucBXRucPvdrphpBsFA&m=FjFbmJy
> a6x58nXbHAJ389Wd24wZU2zmjtIlRJFIAHB0&s=Kp4a2MG8oVlIY-
> HewXWBrbaebyraGmPqwd2xlfRSAfU&e=

---

From: John Strassner <[email-masked]>
Date: Tue, 8 Sep 2015 19:19:02 +0000

>>     "intent-based" policy) but not how to achieve those goals and may create a
>>     model accordingly
>> 
>>   but it also says:
>> 

> IMO - the text says that we can (continue to) investigate 'practicality' as well
> as how to avoid conflict with work chartered in other WGs, but we should not
> write a data model in the first phase of the WG. We may do this 'in later phases'. 

<jcs>
I agree with Juergen. The two pieces of text conflict with each other. The simplest
fix is to remove all of the first text cited.
</jcs>

>>     the definition of the specific network configuration changes but with how
>>     the configuration changes are applied (e.g. who is allowed to set policies,
>>     when and how the policies are activated, changed or de-activated)

<jcs>
I'm confused by the above text. Defining who (or what) is allowed to set 
policies seems out of scope for the IETF. This is typically done using patterns
(e.g., the role-object pattern), and I don't see how to map that easily to YANG.
</jcs>

> IMO - rather the later. Yet, I would observe - as you brought up the 
> example - that some people do useful things and get useful information from 
> the interfaces table MIB objects.

<jcs>
I would hope that it is the former.
</jcs>

regards,
John

John Strassner, Ph.D.
CTO, Software Laboratory, CRD

Futurewei Technologies
US R&D Center
2330 Central Expressway
Building A, office A2-2143
Santa Clara, California   95050
  Office:  +1.408.330.4923
  Email:   [email-masked]

-----Original Message-----
From: Supa [mailto:[email-masked]] On Behalf Of Romascanu, Dan (Dan)
Sent: Tuesday, September 08, 2015 11:55 AM
To: Juergen Schoenwaelder; Benoit Claise
Cc: [email-masked]
Subject: Re: [Supa] New SUPA charter text

Hi, 

See in-text. 

Regards,

Dan

Why? :-)

_______________________________________________
Supa mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/supa

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Wed, 9 Sep 2015 17:54:37 +0200

On Tue, Sep 08, 2015 at 06:55:01PM +0000, Romascanu, Dan (Dan) wrote:
> > model

Expecting a WG to "practically investigate" something that is clearly
declared to be out of scope for the WG still sounds like a
contradiction to me (and I also wonder what "practically investigate"
means).
 
> > the

There is little to gain from this exercise if the SUPA policies do
nothing without data model extensions. It seems I have to lower my
expectations.

/js

---

From: Andy Bierman <[email-masked]>
Date: Wed, 9 Sep 2015 09:15:26 -0700

On Wed, Sep 9, 2015 at 8:54 AM, Juergen Schoenwaelder <
[email-masked]> wrote:

> anyway,
> > IMO - the text says that we can (continue to) investigate 'practicality'
> as well as how to avoid conflict with work chartered in other WGs, but we
> should not write a data model in the first phase of the WG. We may do this
> 'in later phases'.
> >
>
+1

WGs try to work on individual submission drafts, instead of declaring any
official WG drafts, as a way of ignoring the charter.  That's what
"practically investigate" sounds like to me.

> > >     configuration changes are applied (e.g. who is allowed to set
> policies, when
> > > and

It seems to me that speculating or worrying about the SUPA solution is not
very useful.  It is possible there is a good solution path within the
restrictions
of this charter text.  I haven't seen one yet, but it might happen.
I agree it would be bad if SUPA requires YANG modules to be altered in any
way
so they can be used in SUPA.  But conceptual meta-data annotations done in
SUPA configuration modules would be OK.

> /js
Andy

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Wed, 9 Sep 2015 16:48:57 +0000

Hi,

See in-line. 

Regards,

Dan

> From: Juergen Schoenwaelder [mailto:j.schoenwaelder@jacobs-
> university.de]
> Sent: Wednesday, September 09, 2015 6:55 PM
> To: Romascanu, Dan (Dan)
> Cc: Benoit Claise; [email-masked]

> > > It is unclear whether you want to have feedback or not. I will send
> > > it anyway, feel free to ignore since we 'passed the wordsmithing phase'.
> > >
> > > I have two comments:
> > >
> > IMO - the text says that we can (continue to) investigate 'practicality' as
> well as how to avoid conflict with work chartered in other WGs, but we
> Expecting a WG to "practically investigate" something that is clearly declared
> to be out of scope for the WG still sounds like a contradiction to me (and I
> also wonder what "practically investigate"
> means).
> 

It's not declared to be out of scope for the WG. Quite the opposite - it seems to me that there is an agreement that declarative / intent-based policy rules are within the scope of the IETF work. What we did not agree is that we do them in the first phase, and also how we differentiate from similar or similarly labelled work in other IETF WGs or WGs-to-be. In order not to get stuck while attending the resolution of this issue, the charter proposes to start work in SUPA but delay the definition of the declarative/intent-based policy rules for a later phase. 

> > > policies, when and
> There is little to gain from this exercise if the SUPA policies do nothing
> without data model extensions. It seems I have to lower my expectations.
> 

Let us create the expectations as we do the work. This is just charter text - and we want it approved - the results will be seen when the models are approved.

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Wed, 9 Sep 2015 19:02:52 +0200

> It's not declared to be out of scope for the WG. Quite the opposite - it seems to me that there is an agreement that declarative / intent-based policy rules are within the scope of the IETF work. W…

I still find the text confusing and I wished it would not require
interpretation to be understood the right way.

> Let us create the expectations as we do the work. This is just charter text - and we want it approved - the results will be seen when the models are approved. 

OK. I will shut up and then look at the results when the models are
approved.

/js

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Wed, 9 Sep 2015 17:05:22 +0000

> Sent: Wednesday, September 09, 2015 8:03 PM
> To: Romascanu, Dan (Dan)
> > > > > It is unclear whether you want to have feedback or not. I will
> > > > > send it anyway, feel free to ignore since we 'passed the wordsmithing
> phase'.
> > > > >
> > > > > I have two comments:
> > > > >
> > > > >     - Declarative a.k.a intent-based policy rules. Another
> > > > > extension for
> > > defining
> > > > >     policy rules according to a declarative, or intent-based,
> > > > > paradigm, may
> > > be
> > > well as how to avoid conflict with work chartered in other WGs, but
> > > we should not write a data model in the first phase of the WG. We
> > > may do this 'in later phases'.
> > > >
> > >
> > > Expecting a WG to "practically investigate" something that is
> > > clearly declared to be out of scope for the WG still sounds like a
> > It's not declared to be out of scope for the WG. Quite the opposite - it
> seems to me that there is an agreement that declarative / intent-based
> policy rules are within the scope of the IETF work. What we did not agree is
> that we do them in the first phase, and also how we differentiate from
> similar or similarly labelled work in other IETF WGs or WGs-to-be. In order not
> to get stuck while attending the resolution of this issue, the charter proposes
> to start work in SUPA but delay the definition of the declarative/intent-based
> policy rules for a later phase.
> >
> 
> I still find the text confusing and I wished it would not require interpretation
> to be understood the right way.
> 

Ignoring Benoit's advice (' At this point, we passed the wordsmithing phase') - can you suggest the edits that would make the text clear with no need of interpretation? 

Thanks and Regards,

Dan

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Thu, 10 Sep 2015 10:01:55 +0200

> Ignoring Benoit's advice (' At this point, we passed the wordsmithing phase') - can you suggest the edits that would make the text clear with no need of interpretation? 

If the intent is that SUPA is not working on declarative policies
until the IETF has settled where to entertain such work, then simply
state it that way. That is, remove (iii) from the 6th paragraph and
the last item from the list of things that are out of scope and add a
new paragraph that say something along these lines:

  Declarative policies that specify the goals to achieve but not how
  to achieve those goals (also called "intent-based" policies) are out
  of scope for the initial phase of SUPA but may be considered in
  future phases of SUPA.

I think this is clearer and avoids the tension between the different
paragraphs we have in the current charter text.

/js

---

From: Benoit Claise <[email-masked]>
Date: Fri, 11 Sep 2015 15:15:07 +0200

Dear all,

Based on https://github.com/IETF-SUPA/SUPA/wiki/Charter-Diff, and 
specifically "Aug 2016 Discuss with the IESG possible re-chartering, 
including a YANG data model for defining policy rules according to a 
declarative, or intent-based, paradigm",  I adapted the charter (version 
00-09)

I understand the concern discussed in this email thread, specifically 
the two sentences

   ...

The confusion comes from "and may create a model accordingly" in the 
first sentence.

I've followed Jürgen and John's advice to remove the two pieces of text.
And I have incorporated Jürgen's new proposal. Thanks Jürgen, it makes 
the charter clearer.

The charter <https://datatracker.ietf.org/doc/charter-ietf-supa/>is on 
the IESG telechat next Thursday for external review approval.

Regards, Benoit

---

From: Benoit Claise <[email-masked]>
Date: Fri, 11 Sep 2015 15:19:52 +0200

Hi John,
> (e.g., the role-object pattern), and I don't see how to map that easily to YANG.
Now, I'm confused. The text says:

    SUPA however will not deal with the definition of the specific
    network configuration changes but WILL DEAL with how the
    configuration changes are applied (e.g. who is allowed to set
    policies, when and how the policies are activated, changed or
    de-activated).

Note my addition in capital letters.
So the who (and when, how) is clearly in scope.

Regards, Benoit

---

From: Benoit Claise <[email-masked]>
Date: Fri, 11 Sep 2015 17:55:16 +0200

Hi,
> IMO - rather the later.
The later, the way I understood.
This is the reason for this charter sentence:

    This working group will be a success when the SUPA policy constructs
    are re-used in future IETF specifications (and ideally
    specifications from other SDOs), in a manner that will save
    development time and avoid inconsistencies between data models
    developed by different working groups.

Regards, Benoit
> Yet, I would observe - as you brought up the example - that some people do useful things and get useful information from the interfaces table MIB objects.
>
>> Now I shut up. ;-)
>>
> Why? :-)
>
>> /js
>>
>> --
> .