Subject: [Supa] ECA Component class inheritance

From: "Leroux, Francois" <[email-masked]>
Date: Tue, 22 Sep 2015 21:51:13 +0000

John and Yang modeling team,

While cross reading information and data model drafts I could not figure the inheritance scheme for ECA Component. Please see potentially conflicting bullets below. IM refers to [I-D. draft-strassner-supa-generic-policy-info-model-02] and DM refers to [I-D. draft-chen-supa-eca-data-model-03]. SUPA (or supa) prefix is omitted for readability.

1.       IM p.57 (fig. 10) - ECA Component inherits from Policy Atomic

2.       IM p.60 (fig. 11) - ECA Component inherits from Policy

3.       DM p.7 (fig. 4) - ECA Component inherits from ECA Policy Rule

I first suspected that #3 (DM) was the original intent but then noticed IM text at the top of p.58 ("(EPRIM)... also specializes the SUPAPolicy class to create a SUPAECAComponent...") suggesting #2 is correct (and #1 is a typo).

Please let me know which one is correct.

Regards,
François
--

---

From: John Strassner <[email-masked]>
Date: Tue, 22 Sep 2015 15:57:28 -0700

Hi Francois,

thank you for noticing this. Figure 10 in the IM is incorrect - a
PolicyAtomic is the superclass for different types of policies (e.g.,
imperative (ECA) and declarative (LogicStatement).

Figure 11 in the IM is correct - an ECAComponent is a type of Policy object.

I need to think more about Figure 4 in draft-chen. I know that this is a
"SUPA ECA Policy Data Model", and I know that SUPA (if it turns into a WG)
is not currently mandated to work on declarative (e.g., intent) policies.
However, if it ever does, then Figure 4 strikes me as wrong, since it is
useless to declarative policies.

I will try and comment on draft-chen soon.

regards,
John

On Tue, Sep 22, 2015 at 2:51 PM, Leroux, Francois <
[email-masked]> wrote:

> While cross reading information and data model drafts I could not figure
> the inheritance scheme for ECA Component. Please see potentially
> conflicting bullets below. IM refers to [I-D.
> draft-strassner-supa-generic-policy-info-model-02] and DM refers to [I-D.
> draft-chen-supa-eca-data-model-03]. SUPA (or supa) prefix is omitted for
> readability.
>
>
>
> I first suspected that #3 (DM) was the original intent but then noticed IM
> text at the top of p.58 (“(EPRIM)… also specializes the SUPAPolicy class to
> create a SUPAECAComponent…”) suggesting #2 is correct (and #1 is a typo).
>
>
>
> _______________________________________________
> Supa mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/supa
>
>

-- 
regards,
John

---

From: "Leroux, Francois" <[email-masked]>
Date: Wed, 23 Sep 2015 19:15:39 +0000

Hi John,

Thanks for the quick clarification. Figure 11 is what I thought too, for the reason you mentioned and more generally as inheritance from higher level classes favors overall reusability. The relationships between Policy Atomic, Policy Statement and ECA Component (or/and their sub-classes) are not always obvious, and each time I ended up getting stuck on ECA Component...

Regards,
François
--

From: John Strassner [mailto:[email-masked]]
Sent: Tuesday, September 22, 2015 5:57 PM
To: Leroux, Francois; John Strassner
Cc: [email-masked]
Subject: Re: [Supa] ECA Component class inheritance

Hi Francois,

thank you for noticing this. Figure 10 in the IM is incorrect - a PolicyAtomic is the superclass for different types of policies (e.g., imperative (ECA) and declarative (LogicStatement).

I need to think more about Figure 4 in draft-chen. I know that this is a "SUPA ECA Policy Data Model", and I know that SUPA (if it turns into a WG) is not currently mandated to work on declarative (e.g., intent) policies. However, if it ever does, then Figure 4 strikes me as wrong, since it is useless to declarative policies.

regards,
John

On Tue, Sep 22, 2015 at 2:51 PM, Leroux, Francois <[email-masked]<mailto:[email-masked]>> wrote:
John and Yang modeling team,

I first suspected that #3 (DM) was the original intent but then noticed IM text at the top of p.58 (“(EPRIM)… also specializes the SUPAPolicy class to create a SUPAECAComponent…”) suggesting #2 is correct (and #1 is a typo).

Regards,
François
--

_______________________________________________
Supa mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/supa

--
regards,
John