Subject: [Supa] Updated Agenda for IETF 94

From: "King, Daniel" <[email-masked]>
Date: Mon, 26 Oct 2015 21:22:20 +0000

Hi Supa,

Please find the updated agenda for our inaugural meeting in Yokohama:

https://www.ietf.org/proceedings/94/agenda/agenda-94-supa

As discussed, a significant portion of the meeting will be to focus on I-Ds that are directly relevant to achieving those goals. Currently, we identified these core I-Ds as:

The Framework of Simplified Use of Policy Abstractions
https://datatracker.ietf.org/doc/draft-zhou-supa-framework/

Problem Statement for Simplified Use of Policy Abstractions
https://datatracker.ietf.org/doc/draft-karagiannis-supa-problem-statement/

ECA Policy YANG Data Model
https://datatracker.ietf.org/doc/draft-chen-supa-eca-data-model/

Applicability of SUPA
https://datatracker.ietf.org/doc/draft-vadrevu-supa-applicability/

If you are an author of a document that you believe has been overlooked as a milestone deliverable, then please initiate discussion on the list or contact the Chairs.

Other topics for our meeting include:

- Impact on SUPA from other Specification and Standards development organisations?
- Discussion on SUPA contributions to Open Source Controller projects?
- Should we organise a Hackathon project for SUPA at IETF 95?

Representatives or contributors from other SDOs, and/or Open Source projects, that would like agenda time to highlight relevant (SUPA-related) discussion and findings from their own activities are very welcome.

BR, Dan & Nevil.

---

From: Tina TSOU <[email-masked]>
Date: Mon, 26 Oct 2015 23:39:25 +0000

Dear Dan and Nevil,

As far as I know,

have been converged into and replaced by

SUPA Value Proposition
https://datatracker.ietf.org/doc/draft-klyus-supa-proposition/

There may be one omitted.
Generic Policy Information Model for Simplified Use of Policy Abstractions (SUPA)
https://datatracker.ietf.org/doc/draft-strassner-supa-generic-policy-info-model/

Thank you,
Tina

在 2015年10月27日，上午5:22，King, Daniel <[email-masked]<mailto:[email-masked]>> 写道：

Hi Supa,

Applicability of SUPA

BR, Dan & Nevil.

---

From: John Strassner <[email-masked]>
Date: Mon, 26 Oct 2015 16:52:14 -0700

Hi Dan and Nevil,

I'm confused. In the agenda, you wrote:

> 3.2 If the working group considers it necessary, a generic
> information model composed of policy concepts and
> vocabulary.
>
> - Problem Statement for Simplified Use of Policy
> Abstractions (SUPA) (20 minutes - 60/150)

This draft says that an information model is required, but
does not describe what that information model is. Earlier,
I had requested a slot for presenting the revisions to
draft-strassner-supa-generic-policy-info-model-02,
which is missing from your list.

Could you kindly clarify if you would like me to present
the info model or not?

regards,
John

On Mon, Oct 26, 2015 at 2:22 PM, King, Daniel <[email-masked]>
wrote:

> As discussed, a significant portion of the meeting will be to focus on
> I-Ds that are directly relevant to achieving those goals. Currently, we
> identified these core I-Ds as:
>
>
>
> If you are an author of a document that you believe has been overlooked as
> a milestone deliverable, then please initiate discussion on the list or
> contact the Chairs.
>
>
>
> Representatives or contributors from other SDOs, and/or Open Source
> projects, that would like agenda time to highlight relevant (SUPA-related)
> discussion and findings from their own activities are very welcome.
>
>
>
> BR, Dan & Nevil.
>
> _______________________________________________
> Supa mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/supa
>
>

-- 
regards,
John

---

From: "King, Daniel" <[email-masked]>
Date: Mon, 26 Oct 2015 23:54:20 +0000

Hi John,

It was a copy/paste error. The agenda was updated a few minutes ago (https://www.ietf.org/proceedings/94/agenda/agenda-94-supa). If you refresh it should show your I-D listed under:

3.2 If the working group considers it necessary, a generic information model composed of policy concepts and vocabulary.

- Generic Policy Information Model for Simplified Use of Policy Abstractions (SUPA)
https://datatracker.ietf.org/doc/draft-strassner-supa-generic-policy-info-model/
<<

Just to confirm. Yes. Please present the info model I-D.

BR, Dan.

From: John Strassner [mailto:[email-masked]]
Sent: 26 October 2015 23:52
To: King, Daniel <[email-masked]>
Cc: [email-masked]; Nevil Brownlee <[email-masked]>
Subject: Re: [Supa] Updated Agenda for IETF 94

Hi Dan and Nevil,

regards,
John

On Mon, Oct 26, 2015 at 2:22 PM, King, Daniel <[email-masked]<mailto:[email-masked]>> wrote:
Hi Supa,

Applicability of SUPA

BR, Dan & Nevil.

_______________________________________________
Supa mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/supa

--
regards,
John

---

From: John Strassner <[email-masked]>
Date: Mon, 26 Oct 2015 17:06:39 -0700

Hi Dan,

wow, that was fast! Thanks for the clarification. I'll have slides to you
by Sunday, and hopefully a good chunk of the revised draft.

regards,
John

On Mon, Oct 26, 2015 at 4:54 PM, King, Daniel <[email-masked]>
wrote:

> Hi John,
>
>
>
> It was a copy/paste error. The agenda was updated a few minutes ago (
> https://www.ietf.org/proceedings/94/agenda/agenda-94-supa). If you
> refresh it should show your I-D listed under:
>
>
>
> >>
>
> 3.2 If the working group considers it necessary, a generic information
> model composed of policy concepts and vocabulary.
>
>
>
> *From:* John Strassner [mailto:[email-masked]]
> *Sent:* 26 October 2015 23:52
> *To:* King, Daniel <[email-masked]>
> *Cc:* [email-masked]; Nevil Brownlee <[email-masked]>
> *Subject:* Re: [Supa] Updated Agenda for IETF 94
>
>
>
> Hi Dan and Nevil,
>
>
>
> > https://datatracker.ietf.org/doc/draft-karagiannis-supa-
>
> > problem-statement/
>
>
>

-- 
regards,
John

---

From: "King, Daniel" <[email-masked]>
Date: Tue, 27 Oct 2015 00:07:25 +0000

Supa! ;-) Thanks John.

Sent: 27 October 2015 00:07

Hi Dan,

wow, that was fast! Thanks for the clarification. I'll have slides to you by Sunday, and hopefully a good chunk of the revised draft.

regards,
John

On Mon, Oct 26, 2015 at 4:54 PM, King, Daniel <[email-masked]<mailto:[email-masked]>> wrote:
Hi John,

It was a copy/paste error. The agenda was updated a few minutes ago (https://www.ietf.org/proceedings/94/agenda/agenda-94-supa). If you refresh it should show your I-D listed under:

BR, Dan.

From: John Strassner [mailto:[email-masked]<mailto:[email-masked]>]
Sent: 26 October 2015 23:52
To: King, Daniel <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>; Nevil Brownlee <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Supa] Updated Agenda for IETF 94

Hi Dan and Nevil,

regards,
John

Applicability of SUPA

BR, Dan & Nevil.

--
regards,
John

--
regards,
John

---

From: "Susan Hares" <[email-masked]>
Date: Thu, 29 Oct 2015 22:55:36 -0400

Daniel and Nevil: 

After reading your agenda, I found a section of the SUPA agenda that states:

- Impact on SUPA from other Specification and Standards development
organisations?

Would it  be appropriate to provide an example of where the
draft-chen-eca-data-model-05 has an application?   The I2RS Filter-Based RIB
utilizes ECA policy or ACL policy.  I have draft on the ECA-policy for the
I2RS Filter-Based RIB (draft-hares-i2rs-bnp-eca-data-model).  

I can provide a comparison in a few slides.   

Sue Hares 

From: Supa [mailto:[email-masked]] On Behalf Of King, Daniel
Sent: Monday, October 26, 2015 5:22 PM
To: [email-masked]
Cc: King, Daniel; Nevil Brownlee
Subject: [Supa] Updated Agenda for IETF 94

Hi Supa, 

As discussed, a significant portion of the meeting will be to focus on I-Ds
that are directly relevant to achieving those goals. Currently, we
identified these core I-Ds as:

Applicability of SUPA

If you are an author of a document that you believe has been overlooked as a
milestone deliverable, then please initiate discussion on the list or
contact the Chairs. 

- Impact on SUPA from other Specification and Standards development
organisations?

BR, Dan & Nevil.

---

From: Maxim Klyus <[email-masked]>
Date: Fri, 30 Oct 2015 09:40:11 +0000

Dear Daniel and Nevil,

As Tina noticed the drafts you mentioned was partially converged to new draft

SUPA Value Proposition

I’m not sure if I should present SUPA proposition again because nothing actually changed from the last time and charter already formed.
If you have any concerns suggestions on it, I can do this presentation one more time.

Best Regards,
Max Klyus

From: Supa [mailto:[email-masked]] On Behalf Of Tina TSOU
Sent: Tuesday, October 27, 2015 8:39 AM
To: King, Daniel
Cc: Nevil Brownlee; [email-masked]
Subject: Re: [Supa] Updated Agenda for IETF 94

Dear Dan and Nevil,

As far as I know,

SUPA Value Proposition

Thank you,
Tina

Applicability of SUPA

BR, Dan & Nevil.

________________________________
The information transmitted herein is intended only for the person or entity to which it is addressed and may contain confidential, proprietary and/or privileged material. Any review, retransmission, dissemination or other use of, or taking of any action in reliance upon, this information by persons or entities other than the intended recipient is prohibited. If you received this in error, please contact the sender and delete the material from any computer.

---

From: "King, Daniel" <[email-masked]>
Date: Fri, 30 Oct 2015 11:53:50 +0000

Hi Max,

It would be good to present the I-D at the session. Unless the authors believe that the I-D should not be progressed further. Otherwise, it needs to be presented in the context of the new working group and our scope/milestones. Then the working group will need to decide if it’s a document that we would like to work on.

Please consider the following points where preparing your summary/slides:

- Motivation for the I-D (beyond chartering the working group)
- How it relates to the working group milestones?
- Status of the I-D: what content should stay, what will be removed, what needs developing? (For instance security and manageability discussion  are absent from the I-D, is this intended?
- What, if any, open issues exists with the I-D?
- How can the working group help the authors, i.e., what contributions are required?

BR, Dan.

From: Maxim Klyus [mailto:[email-masked]]
Sent: 30 October 2015 09:40
To: Tina TSOU <[email-masked]>; King, Daniel <[email-masked]>
Cc: Nevil Brownlee <[email-masked]>; [email-masked]
Subject: RE: [Supa] Updated Agenda for IETF 94

Dear Daniel and Nevil,

SUPA Value Proposition

Best Regards,
Max Klyus

From: Supa [mailto:[email-masked]] On Behalf Of Tina TSOU
Sent: Tuesday, October 27, 2015 8:39 AM
To: King, Daniel
Cc: Nevil Brownlee; [email-masked]<mailto:[email-masked]>
Subject: Re: [Supa] Updated Agenda for IETF 94

Dear Dan and Nevil,

As far as I know,

SUPA Value Proposition

Thank you,
Tina

Applicability of SUPA

BR, Dan & Nevil.

---

From: "King, Daniel" <[email-masked]>
Date: Fri, 30 Oct 2015 14:46:00 +0000

Hi Sue,

That sounds like a good idea. It will help continue the discussion on use cases.

Our preference is to the find the initial 1-2 "killer apps" for the SUPA policy model(s), rather than demonstrating an exhaustive set of potential use cases. Operators and Service Providers must continue to be vocal on how they intend to use the SUPA models.

BR, Dan.

From: Supa [mailto:[email-masked]] On Behalf Of Susan Hares
Sent: 30 October 2015 02:56
To: King, Daniel <[email-masked]>; [email-masked]
Cc: 'Nevil Brownlee' <[email-masked]>
Subject: Re: [Supa] Updated Agenda for IETF 94

Daniel and Nevil:

Would it  be appropriate to provide an example of where the draft-chen-eca-data-model-05 has an application?   The I2RS Filter-Based RIB utilizes ECA policy or ACL policy.  I have draft on the ECA-policy for the I2RS Filter-Based RIB (draft-hares-i2rs-bnp-eca-data-model).

Sue Hares

To: [email-masked]<mailto:[email-masked]>

Hi Supa,

Applicability of SUPA

BR, Dan & Nevil.