Subject: [Supa] Fwd: New Version Notification for draft-chen-supa-eca-data-model-05.txt

From: Tina TSOU <[email-masked]>
Date: Mon, 26 Oct 2015 23:32:30 +0000

Dear all,

For your reading pleasure.

Thank you,
Tina

以下是转发的邮件：

发件人: <[email-masked]<mailto:[email-masked]>>
日期: 2015年10月27日 GMT+8 上午5:31:01
收件人: Maoke Chen <[email-masked]<mailto:[email-masked]>>, Tina Tsou <[email-masked]<mailto:[email-masked]>>, "Luis M. Contreras" <[email-masked]<mailto:[email-masked]>>, "Michiaki Hayashi" <[email-masked]<mailto:[email-masked]>>
主题: New Version Notification for draft-chen-supa-eca-data-model-05.txt

A new version of I-D, draft-chen-supa-eca-data-model-05.txt
has been successfully submitted by Cindy Morgan and posted to the
IETF repository.

Name:        draft-chen-supa-eca-data-model
Revision:    05
Title:        ECA Policy YANG Data Model
Document date:    2015-10-26
Group:        Individual Submission
Pages:        28
URL:            https://www.ietf.org/internet-drafts/draft-chen-supa-eca-data-model-05.txt
Status:         https://datatracker.ietf.org/doc/draft-chen-supa-eca-data-model/
Htmlized:       https://tools.ietf.org/html/draft-chen-supa-eca-data-model-05
Diff:           https://www.ietf.org/rfcdiff?url2=draft-chen-supa-eca-data-model-05

Abstract:
  This document describes a YANG data model for SUPA (Simplified Use
  of Policy Abstractions) ECA (Event-Condition-Action) policies
  using policy abstractions defined in [I-D. strassner-supa-generic-
  policy-info-model]. The EPDM (ECA policy data model) is refined
  from SGPIM (SUPA Generic Policy Information Model)and EPRIM (ECA
  Policy Rule Information Model) to be applied to deliver various
  management policies for controlling managed entities throughout
  the service development and deployment lifecycle. The generic ECA
  policy data model could be augmented by additional YANG data
  modules modeling and configuring policy-related protocols and
  functions. Reusability as the major advantage of this approach can
  be realized. The policy data model described in this document
  provides common building blocks for such extensions.

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org<http://tools.ietf.org>.

The IETF Secretariat

---

From: Andy Bierman <[email-masked]>
Date: Mon, 26 Oct 2015 16:37:46 -0700

Hi,

I forgot to point this out last IETF:
Please do not use numbers to name enumerations.
This is not user-friendly and YANG Doctors will not approve it.

  leaf policy-rule-deploy-status {
             type enumeration {
               enum 0{
                 description "undefined";
               }
               enum 1{
                 description "deployed and enabled";
               }
               enum 2{
                 description "deployed and in test";
               }
               enum 3{
                 description "deployed but not enabled";
               }
               enum 4{
                 description "ready to be deployed";
               }
               enum 5{
                 description "not deployed";
               }
             }
             description
             "The deploy status of the policy.";
           }

Andy

On Mon, Oct 26, 2015 at 4:32 PM, Tina TSOU <[email-masked]>
wrote:

> *发件人:* <[email-masked]>
> *日期:* 2015年10月27日 GMT+8 上午5:31:01
> *收件人:* Maoke Chen <[email-masked]>, Tina Tsou <
> [email-masked]>, "Luis M. Contreras" <
> [email-masked]>, "Michiaki Hayashi" <
> [email-masked]>
> *主题:* *New Version Notification for draft-chen-supa-eca-data-model-05.txt*
>
>
> URL:
> https://www.ietf.org/internet-drafts/draft-chen-supa-eca-data-model-05.txt
> Status:
> https://datatracker.ietf.org/doc/draft-chen-supa-eca-data-model/
> Htmlized:
> https://tools.ietf.org/html/draft-chen-supa-eca-data-model-05
> Diff:
> https://www.ietf.org/rfcdiff?url2=draft-chen-supa-eca-data-model-05
>
> Abstract:
> until the htmlized version and diff are available at tools.ietf.org.
>
> The IETF Secretariat
>
>
> _______________________________________________
> Supa mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/supa
>
>

---

From: Tina TSOU <[email-masked]>
Date: Tue, 27 Oct 2015 02:36:16 +0000

Dear Andy,

Good catch, it will be fixed.

Thank you,
Tina

在 2015年10月27日，上午7:37，Andy Bierman <[email-masked]<mailto:[email-masked]>> 写道：

Hi,

Andy

On Mon, Oct 26, 2015 at 4:32 PM, Tina TSOU <[email-masked]<mailto:[email-masked]>> wrote:
Dear all,

Thank you,
Tina

以下是转发的邮件：

Abstract:

The IETF Secretariat

_______________________________________________
Supa mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/supa