Subject: Re: IPP> SLP 'printer:' template comments

From: Ira McDonald <[email-masked]>
Date: Tue, 12 Jan 99 19:22:12 EST

Hi Hugo,

Thanks for the quick and thorough response.

Let me comment on 'natural-language-configured'.  Like ALL of
the IPP-derived attributes in the SLP 'printer:' template, it
is meant to accurately reflect the actual configuration of
the IPP Printer object.  However, since SLP (and LDAP) don't
have any standard base datatype 'textWithLanguage', the
'natural-language-configured' attribute does double duty
to specify the language of SLP (and IPP Printer object)
attributes with 'textWithLanguage' or 'nameWithLanguage'
(such as site-administered media names, which are very
important in enterprise printing environments).

This is conformant with RFC 2277 (IETF Policy on Charsets
and Languages) which MANDATES that all application protocols
which transfer text shall explicitly convey the language
of that text.  It is NOT optional for an IETF standards-track
document to put language-tags on text attributes.  It is 
a requirement to stay on the Internet 'standards track'.

We COULD have a separate attribute for the language
of the SLP 'printer:' template text and site-name
attributes, but it seems an entirely reasonable simplification
to presume that a system administrator would: 1) install
a network printer (connectivity setup); 2) set the
'natural-language-configured' of that printer; and 3) set
various site-specific info attributes of that printer.
So the current SLP 'printer:' template makes sense.

What do you think?

Cheers,
- Ira McDonald (outside consultant at Xerox)
  High North Inc
  716-461-5667 (w/ voice mail)

---

From: erik guttman <[email-masked]>
Date: Tue, 12 Jan 1999 16:43:58 -0800

Ira and others,

SLP service de/registrations and requests are all language tagged.
This means that the attributes and other strings which are transported
by SLP are always explicitely language specific.  This is in full
conformance with RFC 2277.  There is no need to include an attribute
identifying the language of the other attributes since there is an
explicit language tagging used in every SLP message.  This language
tag is exactly that specified by RFC 1766. 

Erik

-- 
--------------------------------------------------------------------------
Erik Guttman                                     Germany: +49 7263 911 701
Sun Microsystems - Advanced Network Development  USA:      +1 650 786 5992