Subject: LDAP Schema to SLP Template Question.

From: "Todd Rupper" <[email-masked]>
Date: Thu, 07 Jan 1999 12:04:40 -0700

Pete,

In section 5.11 of the "Conversion of LDAP Schemas to and from SLP Templates" document, you show an example of "type = printer".

How do we differentiate LDAP schema templates from normal templates defined through the working group?

For example, say the LDAP schema definition for "printer" is different than the definition defined in the "Definition of printer:  URLs for use with Service Location" document.

Perhaps, the best solution might be to add the ".ldap" name authority to all schema templates. The example in section 5.11 would become "printer.ldap", rather than just "printer", which would prevent a clash between definitions.

Todd.

---

From: erik guttman <[email-masked]>
Date: Thu, 07 Jan 1999 13:36:55 -0800

> Perhaps, the best solution might be to add the ".ldap" name authority to all schema templates. The example in section 5.11 would become "printer.ldap", rather than just "printer", which would preve…

This is an excellent suggestion.  I would add that templates registered with
IANA
will still have the default naming authority.  When service schema registered
using
the IETF schema registration process (which are compatible with SLP) are used
as 
templates (converted according to the rules given in the ldap conversion
document)
the service type would use the 'ldap' naming authority.  

I am assuming this is what you meant above, but I just want to be sure to point
out that the 'ldap' naming authority templates would not be registered as such,
but rather implied by using registered directory schemas.

Erik