Subject: SLP V2 questions.

From: "Todd Rupper" <[email-masked]>
Date: Thu, 22 Jul 1999 15:04:22 -0600

Erik,

I have several items about the DA Advert.

Concern 1.  Under section 8.5, Directory Agent Advertisement, it states "the error code is set to 0 unless the DAAdvert is being returned due to a SrvRqst without the multicast flag set.  In this case it returns the same errors a SrvRply would."

I have always unicasted a DA to determine if it's active.  We have found that DHCP & Static discovery may provide addresses that don't have active DA's yet.  I have also found situations where hosts don't have a gateway setup.  In this case, the multicast packets traverse through the gateway, but unicast packets get a "route unknown" error.  

This unicast, or ping, mechanism has been very important in validating an active DA and verification that communication is working properly.

Question 2:  What is the initial DA stateless boot time stamp for a DA that wants the SA's to register or reregister all services?

Todd.

---

From: James Kempf <[email-masked]>
Date: Thu, 22 Jul 1999 15:10:52 -0700 (PDT)

Hi Todd,

>Concern 1.  Under section 8.5, Directory Agent Advertisement, it states "the 
error code is set to 0 unless the DAAdvert is being returned due to a SrvRqst 
without the multicast flag set.  In this case it returns the same errors a 
SrvRply would."
>
>I have always unicasted a DA to determine if it's active.  We have found that 
DHCP & Static discovery may provide addresses that don't have active DA's yet.  
I have also found situations where hosts don't have a gateway setup.  In this 
case, the multicast packets traverse through the gateway, but unicast packets 
get a "route unknown" error.  
>
>This unicast, or ping, mechanism has been very important in validating an 
active DA and verification that communication is working properly.

Solairs SLP also contacts all configured DAs via unicast initially, to get
the DA attributes and SPIs among other reasons. We don't contact DAs that
are discovered via multicast active or passive discovery, however.

>Question 2:  What is the initial DA stateless boot time stamp for a DA that 
wants the SA's to register or reregister all services?

Setting the stateless boot time stamp to the current
time should cause all SAs to reregister, because they will see that
the boot time is more recent than the time at which they
last registered.

		jak

---

From: Erik Guttman <[email-masked]>
Date: Fri, 23 Jul 1999 12:47:34 +0200 (MET DST)

> Concern 1.  Under section 8.5, Directory Agent Advertisement, it states
> "the error code is set to 0 unless the DAAdvert is being returned due to
> a SrvRqst without the multicast flag set.  In this case it returns the
> same errors a SrvRply would."
> 
> I have always unicasted a DA to determine if it's active.  We have
> found that DHCP & Static discovery may provide addresses that don't have
> active DA's yet.  I have also found situations where hosts don't have a
> gateway setup.  In this case, the multicast packets traverse through the
> gateway, but unicast packets get a "route unknown" error.  
> 
> This unicast, or ping, mechanism has been very important in validating
> an active DA and verification that communication is working properly.
> 

The rule in section 8.5 means that when the DAAdvert is multicast it
has an error set to 0 and that when it is sent in reply to a SrvRqst
the error may be nonzero (ie. if the SrvRqst processing causes a parse 
error).   The reason this text is worded the way it is, is that a DA
doesn't reply to a multicast SrvRqst if there is an error - errors 
arising from multicast requests cause the request to be silently 
discarded.

Your periodic contacting of DAs is perfectly legitimate.  In fact,
the rule you cite in section 8.5 could provide important information
in the error code in the DAAdvert such as 'DA Busy', etc.

Erik