Subject: Re: service templates

From: Ira Mcdonald <[email-masked]>
Date: Mon, 18 Oct 1999 11:31:11 -0400

Hi Erik,

I *think* there is probably a minor tweak to be 
done to 'printer:' to align it with IPP/1.1 after
the dust cleared.  I planned to look at this
in November.  I'm guessing we would want a 
'backwards compatibility' rule for any that
are registered with IANA?  So that a newer
(updated) registration wouldn't remove any
former attribute or attribute value (like
an enumeration)?

Cheers,
- Ira McDonald
  High North Inc

---

From: Erik Guttman <[email-masked]>
Date: Mon, 18 Oct 1999 17:41:50 +0200 (MET DST)

> former attribute or attribute value (like

Yes, there is backward compatibility.  There are
revision numbers (major and minor).  Minor numbers
just add, major numbers remove or change.  Everything
which enters the repository will be '1.0' for the first
time.  

Erik