Subject: Re: Help - Naming problems in SLP 'service:printer'

From: Erik Guttman <[email-masked]>
Date: Tue, 29 Feb 2000 11:25:39 +0100 (MET)

> 
> Many of the SLP 'service:printer' attributes (largely taken from the
> IPP Model) lack a proper scope prefix 'printer-'.  This forces us to add
> those prefixes when translating to an LDAP schema.
> 
> Tom Hastings (editor of IPP Model) just asked me to write to you and ask
> if we can (once more) update the SLP 'service:printer' template and add
> the proper 'printer-' prefixes, to make the translation cleaner and any
> blind mapping (by an SLP-DA to an LDAP directory server) safe.  Some of
> the numerous currently 'unsafe' attribute names include:
> 
> uri-authentication-supported
> uri-security-supported
> media-supported
> color-supported
> sides-supported
> 
> Has IANA already registered <draft-ietf-svrloc-printer-scheme-05.txt>?

ftp://ftp.isi.edu/in-notes/iana/assignments/svrloc-templates
still lacks the registrations.  I sent them to IANA in December!
 
> If I turn out a revised I-D within the next 10 days, can we send that to
> IANA instead?

Go ahead.

Even if the template version 1.0 goes into the repository, we can submit 
the new draft as template version 1.1.  No problem.  

I intend to talk to some members of the IESG soon about how to escalate 
interaction with IANA so the template registry will get started.
 
> Tom Hastings and I are very concerned about polluting the LDAP flat
> attribute namespace with names like 'uri-security-supported' and
> 'media-supported' without proper 'printer-' prefixes.
> 

Understood.
 
Erik

---

From: "McDonald, Ira" <[email-masked]>
Date: Tue, 29 Feb 2000 13:38:36 -0800

Hi Erik,

Thanks very much for clear direction.  I'll make a serious effort
to get the revised SLP 'service:printer' schema out before the
I-D cutoff on 10 March (for the Adelaide IETF plenary).

I labelled the last one 'v1.0' in the template source.  Should
I label the revision 'v1.1' in the template source?  Or should we
try to just publish the fixup as 'v1.0'?

Best Regards,
- Ira McDonald (consulting architect at Sharp Labs America)
  (co-editor of SLP 'service:printer' template)
  High North Inc

-----Original Message-----
From: Erik Guttman [mailto:[email-masked]]
Sent: Tuesday, February 29, 2000 2:26 AM
To: McDonald, Ira
Cc: [email-masked]'; [email-masked]'; [email-masked]'
Subject: Re: Help - Naming problems in SLP 'service:printer'

 

Go ahead.

 

Understood.
 
Erik