Subject: question about printer:raw-tcp and service:printer templates

From: Matthieu Desmons <[email-masked]>
Date: Wed, 01 Mar 2000 09:20:59 +0100

Hello,

Being working on SLP and especially its applications in the printer
field of activity, I wonder what is exactly the status of the
"Definition of printer:raw-tcp" template (aka
draft-ietf-svrloc-rawtcp-printer-scheme-01.txt).

It is an Internet draft for the moment, I wonder if is anybody currently
working on it ? I heard it was used in Axis SLP implementation (Axis
Print System), so it is currently deployed "on the field", so can we
consider it is reasonable to base developments on it ? if not, and if
major changes are planned for that template, where could I get more info
about what's going on with it ?

Moreover, and I beg your pardon if that question was already answered,
since I'm a newcomer to the mailing list, is there any
technical/political/historical reason for which the raw-tcp template has
not been integrated in the more general "service:printer" template ? 

Indeed, "concrete" services as LPR or IPP are in the service:printer
template, so why not raw-tcp, which is used in many printers ?

Best regards,

Matthieu Desmons,
Software Engineer, Oce Industries, France

---

From: Mikael Pahmp <[email-masked]>
Date: Wed, 1 Mar 2000 11:46:21 +0100

Hi Matthieu,

I believe the draft has been sent to IANA for registration (Erik, correct me if I'm wrong) as an SLP service template. There is, however, no templates available yet in the repository - ftp://ftp.isi.edu/in-notes/iana/assignments/svrloc-templates .

I'm about to go through the raw-tcp draft and update it against the recent draft-ietf-svrloc-printer-scheme-05.txt if necessary.

There were some objections to accept the raw-tcp service in the "service:printer" template that mainly had to do with missing definitions of what raw-tcp is. I updated the definitions in the 01 version of the raw-tcp draft to meet these objections but I haven't tried to get the template moved in to the printer template again.

Please give me any comments you have on the definitions in the raw-tcp template that would make it even better.

/MiP

> -----Original Message-----
> From: Matthieu Desmons [mailto:[email-masked]]
> Sent: den 1 mars 2000 9:21 AM
> To: [email-masked]
> Cc: Ray Herwarts (OS116); [email-masked]
> Subject: question about printer:raw-tcp and service:printer templates
> 
> 
> Hello,
>

---

From: "McDonald, Ira" <[email-masked]>
Date: Wed, 1 Mar 2000 09:14:43 -0800

Hi Mikael and Matthieu,

Please note that (because of problems translating to
the LDAP attribute flat namespace), as noted on the
SLP and IPP lists yesterday, I'm about to revise the
base 'service:printer:' template *very* quickly (for
the I-D deadline 10 March) to *change* most of the
attribute names by prefixing them with 'printer-'
(as James Kempf and Ryan Moats have recommended in
their I-D on converting LDAP to/from SLP schemas).

This is unfortunate (it will mean a new template
version of course), because the names won't be
backwards compatible, but the error was in IPP itself
which did not properly scope its attribute names.

We've only been actively working on an LDAP schema
translation of SLP 'service:printer:' since January,
so we just found this namespace problem - LDAP names
are NOT enclosed in their respective objects but are
global across all objects, so that they must be
explicitly scoped by prefixes.

Separately, each concrete protocol in a service
must have a well-known IANA registered URL scheme.
The 'raw-tcp' (port 9100 or whichever) is certainly
a common print protocol, but IANA would not accept
'raw-tcp' as a URL scheme (the URL scheme namespace
is also flat).  If Mikael or someone could suggest
(following RFC 2396 and more recent RFCs on naming)
a good name for 'raw-tcp' (e.g., 'printraw') and
send it to IANA for registration that would be
great.

On the current one week deadline, I don't have the
time to integrate the 'raw-tcp' stuff into the base
'service:printer:' template, but I'll be glad to
work with Mikael to do so in a future update.

I also plan to work with Novell folks to integrate
NDPS printing into the base 'service:printer:' in
a future update (the work has largely been done some
time ago by Novell engineers).

Erik Guttman sent all of the stable SLP templates to
IANA for registration in December - they haven't been
registered yet.

Cheers,
- Ira McDonald (consulting architect at Sharp Labs America)
  (co-editor of SLP 'service:printer:' template)
  High North Inc

-----Original Message-----
From: Mikael Pahmp [mailto:[email-masked]]
Sent: Wednesday, March 01, 2000 2:46 AM
To: 'Matthieu Desmons'; [email-masked]
Cc: Ray Herwarts (OS116); [email-masked]; Erik Guttman (E-mail); McDonald,
Ira
Subject: RE: question about printer:raw-tcp and service:printer
templates

Hi Matthieu,

I believe the draft has been sent to IANA for registration (Erik, correct me
if I'm wrong) as an SLP service template. There is, however, no templates
available yet in the repository -
ftp://ftp.isi.edu/in-notes/iana/assignments/svrloc-templates .

I'm about to go through the raw-tcp draft and update it against the recent
draft-ietf-svrloc-printer-scheme-05.txt if necessary.

There were some objections to accept the raw-tcp service in the
"service:printer" template that mainly had to do with missing definitions of
what raw-tcp is. I updated the definitions in the 01 version of the raw-tcp
draft to meet these objections but I haven't tried to get the template moved
in to the printer template again.

Please give me any comments you have on the definitions in the raw-tcp
template that would make it even better.

/MiP