Subject: Re: SLP implementations?

From: James Kempf <[email-masked]>
Date: Wed, 7 Jun 2000 08:59:46 -0700 (PDT)

Jyri,

With the exception of mini-slp and Weibin's DA, there are a few
student project level implementations of SLP. They are not complete
implementations because of time constraints.

There are two complete commercial implementations, Novell's Netware
5 implemenation of SLPv1 and Sun's Solaris implementation of SLPv2
with SLPv1 compatibility. Both of these contain UA, SA, and DA
code. Solaris is now under SCSL, so you can
get the source code if you need it, for research purposes. Apple
also has an implementation of the SLPv1 client side starting with MacOS 8
but I don't know how complete it is.

		jak

>X-Authentication-Warning: wicked.neato.org: majordom set sender to 
[email-masked] using -f
>X-Sender: [email-masked]
>Date: Wed, 07 Jun 2000 11:49:37 +0300
>To: [email-masked]
>From: Jyri Palmu <[email-masked]>
>Subject: SLP implementations?
>Mime-Version: 1.0
>
>Hello,
>
>I'm trainee research scientist in VTT (Technical Research Centre of 
>Finland) Electronics.
>
>I would like to know is in Internet any implementation of SLP,
>which could be used for research purpose, in Java or C/C++
>(other than Mini SLP)? Where I can find one?
>
>Thank you,
>
>Jyri Palmu
>
>
>

---

From: Kevin Arnold <[email-masked]>
Date: Wed, 07 Jun 2000 12:24:08 -0700

Apple has a limited implementation of SLPv1 (UA & SA) on MacOS 8.5 and 8.6.
On Mac OS 9 and later, we have a SLPv2 version of the UA & SA, though also
not fully compliant (no support for attributes).

Our MacOS X version is more compliant as it was started from the mslp
implementation by Sun.  We are also implementing a SLPv2 DA on Mac OS X
Server.

Kevin

--Kevin Arnold
--Senior Software Engineer
--Network Services Location (NSL) Technical Lead,
--Service Location Protocol (SLP) products,
--NetFinder, and Personal NetFinder products
--Service Discovery Group,
--Apple Computer

> From: James Kempf <[email-masked]>
> Reply-To: James Kempf <[email-masked]>
> Date: Wed, 7 Jun 2000 08:59:46 -0700 (PDT)
> To: [email-masked], [email-masked]
> Subject: Re: SLP implementations?
> 
> Jyri,
>