Subject: FW: LDAP Printer schema last call comments

From: "McDonald, Ira" <[email-masked]>
Date: Thu, 13 Jul 2000 17:21:26 -0700

Hi folks,

FYI - some IBM folks found some bugs in their review of the
LDAP printer schema I-D.

Cheers,
- Ira McDonald, consulting architect at Xerox and Sharp
  High North Inc

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Wednesday, July 12, 2000 7:32 PM
To: [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: LDAP schema last call comments

The following comments resulted from more widespread review of the latest
draft "draft-ietf-ipp-ldap-printer-schema-02.txt". The following changes
are recommended.

1. Section 3.4, second paragraph should specify printerServiceAuxClass
instead of printerService. (I think this is just a typo).

2. Attributes definitions that define possible values that are keywords
should not have a substring matching rule since the keywords don't contain
patterns of characters suitable for substring searches.  Specifically
SUBSTR caseIgnoreSubstringMatch should be removed from the attribute
definitions in the following sections of this document: 4.4, 4.11, 4.12,
4.13, 4.14, 4.16, 4.19, 4.21, 4.22, 4.25, 4.31, 4.32, 4.33.

Harry Lewis
IBM Printing Systems

---

From: Terry Lambert <[email-masked]>
Date: Thu, 13 Jul 2000 18:04:59 -0700

> FYI - some IBM folks found some bugs in their review of the

[ ... ]

> 2. Attributes definitions that define possible values that
>    are keywords should not have a substring matching rule
>    since the keywords don't contain patterns of characters
>    suitable for substring searches.  Specifically SUBSTR
>    caseIgnoreSubstringMatch should be removed from the
>    attribute definitions in the following sections of this
>    document: 4.4, 4.11, 4.12, 4.13, 4.14, 4.16, 4.19, 4.21,
>    4.22, 4.25, 4.31, 4.32, 4.33.

I disagree, in the following cases:

4.4	I want to search for "fr-ca" or "fr-fr"; the language
	distinction following the hyphen has no bearing on
	printing (unless the printer does spell/grammer
	chacking 8-)), so "fr-*" is reasonable.

4.13	Same as 4.4.

4.19	"staple*" or "staple-*-left" (just staple the thing,
	already!)

It's not clear where "postscript-level-*" would fit, if
anywhere.

-- Terry Lambert
-- Whistle Communications, Inc., an I.B.M. Company
-- [email-masked]
-------------------------------------------------------------------
This is formal notice under California Assembly Bill 1629, enacted
9/26/98 that any UCE sent to my email address will be billed $50
per incident to the legally allowed maximum of $25,000.