Subject: RE: Reactions to draft-guttman-svrloc-slpv2bis-00.txt ???

From: Mikael Pahmp <[email-masked]>
Date: Tue, 4 Jul 2000 13:59:37 +0200

> From: Kevin Arnold [mailto:[email-masked]]
> 
> 
> I think that dropping the PR lists would actually make our 
> situation here at
> Apple even worse (at least until we deploy DAs).  What would 
> extend the
> functionality of PR lists is to change them from a string 
> representation of
> IP Addrs to using just 4 byte values for those addresses.  
> This would give
> you a potential 4x bump in the number of machines on that list...
> 
> Now of course you probably should just slap the back of my 
> hand and tell me
> that I should be deploying DAs to take care of so many 
> machines...  (Its
> actually pretty amazing how well SLP holds up in a UA/SA 
> environment of
> thousands of machines.  The user experience is pretty good 
> considering!) But
> I'm coding Apple's DA implementation as fast as I can! ;-)

I like this. The effort needed to install and configure DAs is not trivial. Having SLP work well even in large environments without DAs is a big plus.

But I believe what we've discussed so far has allowed current SLPv2 behaviour to work well with the changes suggested. But changing the PR list format will make them incompatible. Am I correct about this?

/MiP

---

From: Kevin Arnold <[email-masked]>
Date: Wed, 05 Jul 2000 09:28:40 -0700

Yep, changing the PR list format would make them incompatible...

Kevin

> From: Mikael Pahmp <[email-masked]>
> Date: Tue, 04 Jul 2000 13:59:37 +0200
> To: 'Kevin Arnold' <[email-masked]>, [email-masked], Erik Guttman
> <[email-masked]>, Michael Day <[email-masked]>,
> [email-masked]
> Cc: Terry Lambert <[email-masked]>, Evan Hughes <[email-masked]>
> Subject: RE: Reactions to draft-guttman-svrloc-slpv2bis-00.txt ???
> 
> I like this. The effort needed to install and configure DAs is not trivial.
> Having SLP work well even in large environments without DAs is a big plus.
> 
> But I believe what we've discussed so far has allowed current SLPv2 behaviour
> to work well with the changes suggested. But changing the PR list format will
> make them incompatible. Am I correct about this?
> 
> /MiP