Subject: Service Access implementations (via SLP) requested

From: Michael Fischer <[email-masked]>
Date: Thu, 30 Nov 2000 19:48:50 +0100 (MET)

Hi out there,

I'd like to know which simple (selfmade) implementations you made for
service access after discovery with SLP.
This should includes the service description and attributes needed for
the access parameters, as well as the access technology behind. Latter may
be public ones, like Salutation, UPnP, Jini or proprietary selfmade ones.

Thats because I've got to implement such a service access myself, and like
to draw back on already available knowledge.

Thanks
Michael

----------------------------------------------------------------------------
       (L)       Michael Fischer    
       / \       Institute of Communication Networks
      /TUM\      Technical University of Munich
    (K)---(N)    Munich, Germany                   
----------------------------------------------------------------------------

---

From: James Kempf <[email-masked]>
Date: Thu, 30 Nov 2000 11:20:16 -0800 (PST)

Michael,

I'm not sure I understand your question.

After discovering a service, you use the reachability information 
in the service URL and (potentially) attributes to contact the
service through opening a TCP or UDP socket and exchanging
messages. You could also use attributes to configure the service,
if there is no service-specific attribute discovery procedure.

All this is completely independent of SLP or any other service
discovery protocol.

		jak

>X-Authentication-Warning: wicked.neato.org: majordom set sender to 
[email-masked] using -f
>Date: Thu, 30 Nov 2000 19:48:50 +0100 (MET)
>From: Michael Fischer <[email-masked]>
>To: [email-masked]
>Subject: Service Access implementations (via SLP) requested
>MIME-Version: 1.0
>
>Hi out there,
>