Subject: Re: Applications with SLP ?

From: Laura Jauregui <[email-masked]>
Date: Wed, 21 Mar 2001 08:42:16 -0600

On Tue, 20 Mar 2001, ebenezer schubert wrote:
 >     Applications will have to be re-written to be able
 >     to use SLP. SLP provides a set of APIs to do
 >     this.

   Not true. Existing client applications only need some form of SLP-aware
proxy that will do service location for them, and then invoke them once
the service has been found. 

   Existing server apps are a little more complex. 

e

- L. Jauregui
[email-masked]
SeeDragon Software, Inc.
USA: 1.512.453.0891

This electronic mail message together with any attachments is confidential.  If you are not the intended recipient please email back immediately and destroy the message.  You may not copy, disclose or use the contents in any way.  Thank you.

---

From: James Kempf <[email-masked]>
Date: Wed, 21 Mar 2001 08:45:57 -0700

.
>And speaking from experience don't ever run SLP without a DA in a production
>network. I have heard many of our customers dreading SLP multicast traffic
>like they used to fear SAP broadcasts in IPX. DAs with properly configured
>scopes are necessary for scalability.
>
>Ganesan
>

Absolutely. DAs are a fundamental part of the SLP design and are necessary
for scalability, even though many implementors think they can do without.

		jak