Subject: Re: Applications with SLP ?

From: James Kempf <[email-masked]>
Date: Tue, 20 Mar 2001 14:25:42 -0700

It is also possible to write an advertisement proxy that simply advertises
the services, separate from the actual service. This works when you don't
have any source code for the service.

		jak
>
>> Hello,
>> I'm new to SLP environment and Balaji raises a very interesting question
>> 
>> How about actual use of SLP in real life applications ?
>> 
>> Should we re-write any application with the API of SLP ? Such
>> applications already exist ?
>
>	To make  existing  application  SLP-enabled  the code  has to be
>	modified  both on the server and  client  side  (atleast  on the
>	client side).
>
>	The client has to  incorporate  changes in its part of code that
>	performs  the work of an User Agent which may include  Discovery
>	of Services available, finding the attributes of the service and
>	its URL etc.
>
>
>	Similary  the server has to  incorporate  changes in its part of
>	code that performs the task of Service Agent which will normally
>	include registration of its service URL when the server comes up
>	and deregistration of its service URL when it goes down.
>
>	Currently SLP  implementations  come with apis that are provided
>	to  help  client  and  server   perform   this  task.  For  more
>	information about the apis you can look at RFC2614.
>
>
>Praveen
>
>> 
>> /jean-mick
>> 
>> Matt Peterson wrote:
>> 
>> > Balaji Meruva wrote:
>> > >
>> > > Hello
>> > >       We are graduate students at University of
>> > > Kansas, Lawrence. We are working on Service Location
>> > > Protocol(SLP) for our course work. We will be very
>> > > grateful if you can suggest any further Extensions to
>> > > the existing features of SLP.
>> > >
>> > > Thanking you in anticipation
>> > > Balaji Meruva
>> > >
>> >
>> > How about actual use of SLP in real life applications instead of
>> > continuous extension...   Do you want specific suggestions of
>> > applications that could benefit greatly by being SLP enabled?
>> >
>> > --
>> > Matthew Peterson
>> > Sr. Software Engineer
>> > Caldera Systems, Inc
>> > [email-masked]
>> 
>> 
>
>
>-- 
>==============================================================================
>Praveen Kumar Amritaluru                 Phone (Off) : (91)(80)2251554 x 1306
>HP India Software Operations             Telnet      : 847-1306
>Bangalore 560 052
>India.
>==============================================================================

---

From: Praveen Kumar Amritaluru <[email-masked]>
Date: Wed, 21 Mar 2001 02:18:07 +0530 (IST)

In case of server  which  cannot be  modified  as you may not having the
source  code  of the  server,  it is also  possible  to put the  service
information (the service URL, attributes etc) in a file and register the
services.  This is called static  registration and more  information can
be found in RFC2608.

Praveen