Subject: RE: recap SLPv2bis discussion

From: "Mayer, Jim" <[email-masked]>
Date: Tue, 1 May 2001 14:07:44 -0400

Hi all,

What's the current state on this?  Is there a draft document somewhere?  I
haven't seen anything in a while.

Thanks.

-- Jim Mayer
Xerox Corporation

> -----Original Message-----
> From: James Kempf [mailto:[email-masked]]
> Sent: Tuesday, January 02, 2001 12:44 PM
> To: [email-masked]; [email-masked]
> Subject: Re: recap SLPv2bis discussion
> 
> 
> Hi Erik,
> 
> Re. Matt's email on SLPv2APIbis, I believe there was some 
> discussion to
> deprecate the fresh bit on SrvReg as well, to completely remove
> incremental registration and deregistration.
> 
> 		jak
> 
> >X-Authentication-Warning: wicked.neato.org: majordom set sender to 
> [email-masked] using -f
> >Date: Tue, 2 Jan 2001 14:20:49 +0100 (MET)
> >From: Erik Guttman <[email-masked]>
> >Subject: recap SLPv2bis discussion
> >To: [email-masked]
> >MIME-Version: 1.0
> >
> > I want to find out where we were on the SLPv2bis discussion 
> last Autumn.
> >Let's try to finish up the to-do list and then start an 
> actual SLPv2bis
> >spec.  
> >
> >If I understand - this much we've agreed to:
> >
> > - Eliminate AttrRqst by type.
> > - Eliminate wildcards in AttrRqst search filters.
> > - Recommend support for mesh SLP enhancement in SAs and DAs.
> > - Change scope configuration rules as per 
> >   draft-guttman-svrloc-slpv2bis-01.txt
> > - Eliminate SrvDereg tag list support (no incremental 
> deregistration)
> > - Eliminate requirement to elide white space in string matching
> > - DAs SHOULD remain backward compatible to RFC 2608 features
> >
> >This much we have only rough consensus on:
> >
> > - Simplify Service Request filters.  Eliminate support for 
> '!' filter.
> >   (At first we talked about deprecating '|' and arbitrary nesting,
> >   but that position has no more defenders.)
> > - Create new SLP error code - SEARCH FILTER FEATURE NOT SUPPORTED
> > - PR list support RECOMMENDED (no longer required)
> >
> >Under discussion:
> >
> > - change interpretation of service URLs to allow the use of 
> service:id 
> >   so as to simplify rediscovery of the same service (after 
> renumbering,
> >   say) and discovery of services which have multiple locations.
> >
> >Does this look like a complete list to everyone?
> >
> >Erik
> >
> >._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._.
> >E r i k   G u t t m a n         SHORT msgs: [email-masked]
> >Sr Staff Engineer, Sun Microsystems       Email: [email-masked]
> >Eichhoelzelstr. 7, 74915 Waibstadt Germany    Phone: +49 172 865 5497
> >
> >
>

---

From: Erik Guttman <[email-masked]>
Date: Wed, 2 May 2001 02:45:38 -0700 (PDT)

Jim,

> What's the current state on this?  

To move SLPv2 to draft standard we have to revise RFC 2608 (and
possibly 2609, 2610 and 2614).  This revision must clarify those
points which prevented interoperability, deprecate or eliminate
features for which there has been no interest or we have discovered
that the features don't work.  We cannot add new features or modify
the wire format advancing to draft standard.  

> Is there a draft document somewhere?  

The draft has expired from the directories.  I put a copy of it at

  http://www.srvloc.org/draft-guttman-svrloc-slpv2bis-01.txt

> I haven't seen anything in a while.

Want to see more?  Its up to you!  :-)
Here is what we need, specifically:   

 - review the list below and the draft I gave a URL to
 - discuss this on the list until we have concrete list of deltas
 - write SLPv2bis (the specification) - Jim & I are willing to
   take this on.  Anyone want to be a coeditor/coauthor?
 - work on an interoperability test suite for every feature of
   SLPv2.  Ideally this would use scripts driving the RFC 2614 API
   so we could share some portable test code.
 - organize/host the interop test or tests (if we can't finish
   the interop matrix in one meeting)
 - eventually:  write up the interoperability report for the IESG

> > incremental registration and deregistration.

This certainly has been proposed and strongly motivated.

> > >Does this look like a complete list to everyone?

The point is - to move forward with this effort we need discussion
on the list and to come to an agreement.  

Erik

---

From: Matt Peterson <[email-masked]>
Date: Wed, 02 May 2001 08:43:19 -0600

Erik, 

I am still interested in moving SLPv2 to draft standard.  However, I am
currently very busy trying to meet other deadlines.  I have suggestions
for several changes to 2608, and 2614, that are based on experience
gained from the OpenSLP project.  However, it will take me a few hours
to summarize them.  The problem is that, I won't have a few hours  to
concentrate on it until for a couple weeks.  

Let me know if it is imperative that I post the summary sooner and I
will see what I can do.  Otherwise, I'll stick with plans I have made to
post the change summaries in a couple weeks.

> > > > - DAs SHOULD remain backward compatible to RFC 2608 features

All of the above are items on our change list too.  

Thanks,

-- 
Matthew Peterson
Sr. Software Engineer
Caldera Systems, Inc
[email-masked]

---

From: Erik Guttman <[email-masked]>
Date: Wed, 2 May 2001 07:49:49 -0700 (PDT)

> All of the above are items on our change list too.  

Matt,

Thanks for the enthusiastic answer.  There is no need to push on this
in the next couple weeks.  It has been waiting for a push for several
months already :-)  I just wanted to take the opportunity, spurred on
by Jim Mayer, to try and get discussion going again.  I'm ready when
you guys are - I just can't drive it myself.

Erik