Subject: SA daemon

From: Sean Kelley <[email-masked]>
Date: Tue, 8 May 2001 11:28:49 -0400 (EDT)

Both the OpenSLP and the Sun SLP have a
SA daemon process which runs on each machine. The
local processes which desire to advertise services
connect to the SA daemon and register services. 

	I don't believe that the mechanism allowing
the local processes to register with the SA daemon
is specified in a RFC, but it appears to be implemented 
in both the OpenSLP and Sun SLP through the SA daemon 
supporting SvrReg, SvrDeReg, SvrAck on connections 
from the local host. This is a logical approach since
only one process can bind to the SRVLOC port.

	My question is interoperability. I have
tried using the 'slptool' which is in the OpenSLP 
distribution to register services with the Sun
SA daemon. The 'slptool' is compiled against the
OpenSLP libraries. While the two connect, I
receive an error -13 (SLP_INVALID_UPDATE). Should
I hold out hope for the two implementations to
interoperate? Are there plans to make the protocol 
between local processes and SA daemons a standard?

	Sincerely,

	Sean

Sean M. Kelley                  Solers, Inc. 
[email-masked]          1611 N. Kent St. Ste. 600
[email-masked]               Arlington, VA 22209
(703)526-0001                   #include <std_disclaimer.h>

---

From: Sean Kelley <[email-masked]>
Date: Tue, 8 May 2001 11:56:49 -0400 (EDT)

Hi,
	Just for additional information,
what I was trying to do (as a test):

	slptool register service:test://x/y "(z=1)"

It doesn't mean anything. This works with the openslp
daemon. You can then:

	slptool findsrvs service:test

and 
	slptool findattrs service:test://x/y

and the correct values will be output. With the
Sun SA daemon, the error -13 is returned on 
registration.

	Sincerely,

	Sean