Subject: [Svt] I'd like to see SVT move forward

From: Russ Housley <[email-masked]>
Date: Thu, 4 Feb 2021 14:47:17 -0500

In October 2020, Stefan approached me about working with him on the SVT documents.  I said that the information that was perviously presented had not convinced me that this was needed.  That lead to a dialog about the digitally signed documents in archives.  The examples that Stefan used were the Swedish Agency for Digital Government (DIGG) and eduSign.  Further discussion of these use chases convinced me that there was value to this approach.  These were included in the SECDISPATCH slides at IETF 109:

	https://datatracker.ietf.org/meeting/109/materials/slides-109-secdispatch-draft-santesson-svt-00

I am not saying that the specifications are finished.  Rather, I am saying let's talk about them.  Has anyone on this list found things in the documents to praise or criticize?

Russ

---

From: Stefan Santesson <[email-masked]>
Date: Mon, 08 Feb 2021 10:02:16 +0100

Russ,

Thank you for this reminder.

I would like to update on the implementation progress of the current version (1.0) of these specifications.

Attached you find a signed XML and PDF document, with and without an SVT.

These documents were signed using the eduSign signing service at: https://edusign.sunet.se/open/login

The SVT was issued by the eduSign validation service: https://validator.edusign.sunet.se

Anyone can upload, validate and get successfully validated documents extended with an SVT.

Documents extended with an SVT can be archived and validated at any time in the future based on the SVT as long as the validator trust the SVT signing key and the algorithms used to sign the SVT.

At this point we see no problems with the specifications and the profiles for PDF and XML.

We have now got a green light to implement this as a national service for the public sector government agencies in Sweden.

Any feedback on these specifications would therefore be very valuable.

I would like to also repeat that there are more resources available at our GitHub page: https://github.com/swedenconnect/IETF-SVT

Including a youtube presentation video: https://youtu.be/IEJBmHJklHY

Stefan Santesson 

From: Svt <[email-masked]> on behalf of Russ Housley <[email-masked]>
Date: Thursday, 4 February 2021 at 20:47
To: "[email-masked]" <[email-masked]>
Subject: [Svt] I'd like to see SVT move forward

Russ

-- Svt mailing list [email-masked] https://www.ietf.org/mailman/listinfo/svt