Subject: [T2TRG] Number of expected IoT devices per household

From: "Kovatsch Matthias" <[email-masked]>
Date: Tue, 21 Apr 2015 06:01:41 +0000

Dear group

During the meeting in Dallas, I heard a number of 250 or 300 expected IoT devices per household. Are there any studies or reports on that? I only found an OECD report for 50 devices by 2022. Would be good to have something to make reasonable assumptions when discussing approaches and research results!

Best regards
Matthias

---

From: Carsten Bormann <[email-masked]>
Date: Tue, 21 Apr 2015 09:13:15 +0200

On 21 Apr 2015 at 08:02:00, Kovatsch Matthias ([email-masked]) wrote:
During the meeting in Dallas, I heard a number of 250 or 300 expected IoT devices per household. Are there any studies or reports on that? I only found an OECD report for 50 devices by 2022. Would be good to have something to make reasonable assumptions when discussing approaches and research results!

Good lead-in to a discussion of reference scenarios!

I doubt a single number will be sufficient here, but we still might be able to capture some easy to remember cornerstones.

First of all, a household is composed of things that mainly stay at home (some of which are actually installed there and really can’t move) and things that move with their owners (“personal area network” in the real sense, not the 802.15 sense).  The boundary is of course not well-defined (some things may rarely travel), but will influence the usage patterns.

I have heard the number 250 (which is conveniently below 255 or 256) being cited as a reasonable upper bound for things installed at home, for a while.  If that estimate is right, we should plan to be able to accommodate that many nodes, but not for that number to be an average number.  Again, the number may fluctuate with household members and their guests bringing their personal area networks, some of which will integrate with the home area network to some extent, so we have to be clear whether that “reasonable maximum” includes those or not.

Of course we are in the position of someone in 1994 trying to estimate how many Internet devices a household will have in 2014… But we still can make an educated guess.

Grüße, Carsten

---

From: "Carles Gomez Montenegro" <[email-masked]>
Date: Tue, 21 Apr 2015 11:11:02 +0200

Hi Matthias, all,

> During the meeting in Dallas, I heard a number of 250 or 300 expected IoT
> devices per household. Are there any studies or reports on that?

Here are a few possible (not so recent) references on the topic:

- RFC 5826 (2010) states:
    "Looking at the number of wall switches, power outlets, sensors of
    various natures, video equipment, and so on in a modern house, it
    seems quite realistic that hundreds of devices may form a home-
    automation network in a fully populated "smart" home, and a large
    proportion of those may be low-power devices."

- The ZigBee Home Automation Public Application Profile v1.0 (2007) states:
    "Home Automation (HA) networks scale from 2 to 500 nodes"

- ITU-T G.9959 (i.e. Z-Wave PHY/MAC specification) specifies a maximum of
232 nodes per network.

- A 2010 paper
(http://www.ann.ece.ufl.edu/courses/eel6935_11fal/papers/Survey%20of%20home%20automation%20networks.pdf)
states:
    "... the number of nodes may be on the order of hundreds"

I hope this helps!

All the best,

Carles

---

From: Michael Richardson <[email-masked]>
Date: Tue, 21 Apr 2015 12:02:33 -0400

Carsten Bormann <[email-masked]> wrote:
    > I have heard the number 250 (which is conveniently below 255 or 256)
    > being cited as a reasonable upper bound for things installed at home,
    > for a while. If that estimate is right, we should plan to be able to
    > accommodate that many nodes, but not for that number to be an average
    > number. Again, the number may fluctuate with household members and
    > their guests bringing their personal area networks, some of which will
    > integrate with the home area network to some extent, so we have to be
    > clear whether that “reasonable maximum” includes those or not.

I agree that 250 is a good number to plan to accomodate, and that this number
will only very infrequently be reached: likely when you have a party.

There are 17 "areas" in my somewhat modest 2-bedroom 1200 sqft, 1.5 storey,
1947-era house . Each area could have a lighting system ("system", because
they might have more than one bulb, but they might not be independant) that I
would want to control independantly.

If you add an actuator for each area (which might be a switch, or an
occupancy sensor, or both), then we are at 34 *nodes* for my house, for
lighting alone.   Number of possible routers is likely ~20 if I count devices
which I expect are mains powererable.

So that was lighting: add to that stove, range, dishwasher, fridge, clothes
washer, and dryer, BBQ, and pool (motor, also would like temperature and
chlorine levels...).  Maybe also: water heater, furnace, electric
meter, water meter, gas meter.

Would be nice to have a temperature sensor in each area, and ideally some
servo controlled baffles in the ducts so that I can send the heat where it
belongs better...
And I haven't counted computers or TV and TV-like items (computer monitors,
which might always display the output of the computer), etc.

If you were counting, you got to 50 devices pretty easily, but one had to
really be imaginative to get beyond 75.  Bigger houses will have more areas.

-- 
]               Never tell me the odds!                 | ipv6 mesh networks [ 
]   Michael Richardson, Sandelman Software Works        | network architect  [ 
]     [email-masked]  http://www.sandelman.ca/        |   ruby on rails    [

---

From: "Kovatsch Matthias" <[email-masked]>
Date: Wed, 22 Apr 2015 08:37:55 +0000

Thanks everyone for the input!

I would conclude that the T2TRG should assume and support up to about 250 devices when designing solutions for home environments, while 50 devices appear to be "normal" in the near future (also see http://oecdinsights.org/2013/01/21/smart-networks-coming-soon-to-a-home-near-you/).

Ciao
Matthias

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 22 Apr 2015 11:23:17 +0200

> I would conclude that the T2TRG should assume and support up to about 250 devices when designing solutions for home environments, while 50 devices appear to be "normal" in the near future (also see…

That indeed seems a good target for 2020.
With a 10-15 year horizon, I'm probably more comfortable with "hundreds"
than with "~250" as an upper bound...
(~250 is probably fine as a per-technology upper bound, as used in
G.9959, for quite a while.)

Grüße, Carsten

---

From: <[email-masked]>
Date: Wed, 22 Apr 2015 12:24:01 +0000

Hello Matthias,

While 250 devices sound a reasonable number to play with when evaluating the performance of potential solutions in the next 5 to 10 years, I'd hate to *design* protocols or systems that would be limited to that number. Using two bytes for that number would seem much more future-proof.
Also, in the subject of your mail, as others have alluded to, I would distinguish "household" (which to me includes residents and guests) and "home" (limited to the building itself).
Best regards

Dominique

-----Message d'origine-----
De : T2TRG [mailto:[email-masked]] De la part de Kovatsch Matthias
Envoyé : mercredi 22 avril 2015 10:38
À : [email-masked]
Objet : Re: [T2TRG] Number of expected IoT devices per household

Ciao
Matthias

_______________________________________________
T2TRG mailing list
[email-masked]
https://www.irtf.org/mailman/listinfo/t2trg

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: "Simpson, Robby (GE Energy Management)" <[email-masked]>
Date: Wed, 22 Apr 2015 12:33:56 +0000

I too am generally uncomfortable with upper bounds. I think a more interesting exercise would be enumerating what we believe would create limits/constraints (e.g., addresses, specific buffers, connection overheads) from a research group perspective and then determining what bounds may result. All bounds of which I am aware are either based on non-IP systems or "marketing."

- Robby

Sent from my iPhone - thus the tpyos and brvty

---

From: Joerg Ott <[email-masked]>
Date: Wed, 22 Apr 2015 15:43:05 +0300

I would also be interested in understanding not just how many devices
we expect there to be (order of magnitude) but also some initial ideas
of what those are going to do (in terms to traffic generation).
Whether you have a 100 or 10,000 devices doesn't make so much of a
difference if they are silent all the time.

+1 on avoiding strict upper bounds (640 KB should be enough for
everybody and 32 bit IP addresses suffice)

Jörg

---

From: "Dave Oran (oran)" <[email-masked]>
Date: Wed, 22 Apr 2015 13:46:11 +0000

> On Apr 22, 2015, at 5:43 AM, Joerg Ott <[email-masked]> wrote:
> 
I agree with Jörg that for the part of the problem T2TRG is addressing duty cycle, bandwidth load, and resopnsiveness are the important metrics.

That said, if there processing that scale poorly with device count we have a problem. For example, if routing has to keep track of all the devices, even when they are asleep, or execute some expensive operation every time they wake up even if they have nothing to do, we have a problem.

---

From: "Kovatsch Matthias" <[email-masked]>
Date: Thu, 23 Apr 2015 07:38:46 +0000

My intention behind this question was not to set a bound! I was interested in a plausible number that should be used when evaluating solutions in this space, e.g., to dimension experiments or simulations.

The traffic patterns mentioned by Jörg is also part of this guesswork when trying to make reasonable assumptions...

Ciao
Matthias

---

From: "Carles Gomez Montenegro" <[email-masked]>
Date: Thu, 23 Apr 2015 12:42:08 +0200

Hi Matthias,

> The traffic patterns mentioned by Jörg is also part of this guesswork
> when trying to make reasonable assumptions...

Recently, we also had to go through a scenario guesswork for a home
automation evaluation. (We didn't use an actual home setting. Instead, we
emulated a home by assigning specific roles to nodes in a testbed.)

Part of the guesswork included the traffic patterns. Hoping that this can
be useful, the node roles and traffic patterns we assumed can be found in
sections 4.1 and 4.2 here: http://www.mdpi.com/1424-8220/14/8/14932.

RFC 5826 also provides some details on expected traffic patterns in the
same space: https://tools.ietf.org/html/rfc5826#section-4

Best regards,

Carles