Subject: [T2TRG] Information aggregation in internet of things

From: "[email-masked]" <[email-masked]>
Date: Wed, 27 Apr 2016 15:03:43 +0800

Hi,folks

Considering the large-scale but small-sized information exchange in the IOT, in order to make the data generated by IOT devices transmission more efficient, we may need a data aggregation scheme in IOT. 
Consider this scenario: in a home network may consist of many sensors, such as light sensor, meter, and fire detector, etc, each frame has very small payload(15 – 100 byte) and limit number of frames per day(10). IOT users need remote access these sensors for the easy management and safety of house. If initiate an internet transmission for every frame of each sensor, the payload must account very low percent of the whole frame(because of the IP header, MAC header, PHY header). 
So,IMO, data generated by some IOT devices should be aggregated at the transmitter and de-aggregated by the receiver for more efficient.

Regards
Xiaowei Qin

---

From: "[email-masked]" <[email-masked]>
Date: Wed, 27 Apr 2016 15:28:22 +0800

Hi，folks
One use case is that several frames generated by one IOT device are aggregated into one IP packet. 
This use case suits none-real-time requirements scenario. Data generated by each IOT device can be stored temporarily at local cache, and then send with aggregation chain. 
The second use case is that several frames generated by some different IOT devices are aggregated into one IP packet. 
This use case suits real-time requirements scenario. Data generated by different IOT devices will be transmitted immediately with frame aggregation chain. 

Regards
Xiaowei Qin

发件人： [email-masked]
发送时间： 2016-04-27 15:03
收件人： t2trg
主题： Information aggregation in internet of things
Hi,folks

Regards
Xiaowei Qin

---

From: Ari Keränen <[email-masked]>
Date: Wed, 27 Apr 2016 07:41:45 +0000

Hi,

Indeed data aggregation is one key mechanism for reducing the overhead in IoT scenarios. That's why for example in SenML (https://tools.ietf.org/html/draft-ietf-core-senml-00) we have put quite a lot of effort into making batches of data efficient and simple to exchange.

Cheers,
Ari

> On 27 Apr 2016, at 10:03, [email-masked] wrote:
> 
> Hi,folks
> 
> _______________________________________________
> T2TRG mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/t2trg

---

From: "[email-masked]" <[email-masked]>
Date: Wed, 27 Apr 2016 17:35:02 +0800

Hi，

IMO, SenML (Sensor Markup Language) may be one kind open, the self - description way definition construction of data. So, every IOT device can use the common SenML data model to send information and each transmission can send large data. But, does it place a burden on the transportation system of IOT? After all, it need packaged into similar to XML document? 
Information aggregation scheme in internet of things(IASIOT) is based on IP packet. The data generated by IOT devices would be aggregated into one frame chain at senders, which becomes the payload(MAC data) of the IP packet. 
Any more?

Best wishes
Xiaowei Qin

From: Ari Keränen
Date: 2016-04-27 15:41
To: [email-masked]
CC: [email-masked]
Subject: Re: [T2TRG] Information aggregation in internet of things
Hi,

Cheers,
Ari

---

From: Soumya Kanti Datta <[email-masked]>
Date: Wed, 27 Apr 2016 15:12:32 +0530

Hi Xiaowei,

My replies inline.

Regards,
Soumya

Research Engineer, EURECOM, France | +33658194342 | @skdatta2010 |
https://sites.google.com/site/skdunfolded | Skype id: soumyakantidatta

On 27-04-2016 15:05, [email-masked] wrote:
> Hi，
>
> IMO, SenML (Sensor Markup Language) may be one kind open, the self - 
> description way definition construction of data. So, every IOT device 
> can use the common SenML data model to send information and each 
> transmission can send large data. But, does it place a burden on the 
> transportation system of IOT? After all, it need packaged into similar 
> to XML document?
[Soumya] SenML metadata can be encoded in JSON, CBOR or EXI. JSON 
encoding takes very minimal resources in IoT devices and not place so 
much burden on the transportation system (from my prototyping experience).
> Information aggregation scheme in internet of things(IASIOT) is based 
> on IP packet. The data generated by IOT devices would be aggregated 
> into one frame chain at senders, which becomes the payload(MAC data) 
> of the IP packet.
[Soumya] Depending on the scenario, you may need to process each data or 
the aggregated data. Having a local processing on the device could ease 
the process.
> Any more?
>
> Best wishes
> Xiaowei Qin
>
> ------------------------------------------------------------------------
>
>     *From:* Ari Keränen <mailto:[email-masked]>
>     *Date:* 2016-04-27 15:41
>     *To:* [email-masked] <mailto:[email-masked]>
>     *CC:* [email-masked] <mailto:[email-masked]>
>     *Subject:* Re: [T2TRG] Information aggregation in internet of things
>     Hi,
>     Indeed data aggregation is one key mechanism for reducing the
>     overhead in IoT scenarios. That's why for example in SenML
>     (https://tools.ietf.org/html/draft-ietf-core-senml-00) we have put
>     quite a lot of effort into making batches of data efficient and
>     simple to exchange.
>     Cheers,
>     Ari
>     > Considering the large-scale but small-sized information exchange
>     in the IOT, in order to make the data generated by IOT devices
>     transmission more efficient, we may need a data aggregation scheme
>     in IOT.
>     > Consider this scenario: in a home network may consist of many
>     sensors, such as light sensor, meter, and fire detector, etc, each
>     frame has very small payload(15 – 100 byte) and limit number of
>     frames per day(10). IOT users need remote access these sensors for
>     the easy management and safety of house. If initiate an internet
>     transmission for every frame of each sensor, the payload must
>     account very low percent of the whole frame(because of the IP
>     header, MAC header, PHY header).
>     > So,IMO, data generated by some IOT devices should be aggregated
>     at the transmitter and de-aggregated by the receiver for more
>     efficient.
>     >
>     > Regards
>     > Xiaowei Qin

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 27 Apr 2016 11:45:16 +0200

[email-masked] wrote:
> But, does it place a burden on the transportation system of IOT? After
> all, it need packaged into similar to XML document? 

SenML, as its name suggests, started out as an XML format.
This encoding alternative continues to be available, but -- reflecting
industry trends from XML to JSON-based data models -- has recently been
de-emphasized.

The best way to use SenML in a constrained environment is to encode it
in CBOR.
Once you transition to a more powerful environment, you way want to
transform data into equivalent JSON if you value ease-of-use over
performance.

Grüße, Carsten

---

From: "[email-masked]" <[email-masked]>
Date: Thu, 28 Apr 2016 11:45:33 +0800

Hi Soumya,
>[Soumya] SenML metadata can be encoded in JSON, CBOR or EXI. JSON encoding takes very minimal resources in IoT devices and not place so much burden on the transportation system (from my >prototyping experience).
OK,  I have got it. SenML focus on “data encapsulation", and attempts to give a general “data module"  for semantic interoperability of IOT. 

>[Soumya] Depending on the scenario, you may need to process each data or the aggregated data. Having a local processing on the device could ease the process.

Yes, that's exactly what i means, the data generated by IOT devices should be stored to local cache(if use aggregation scheme). 
Based on CROSSBOW sensors, I did an intelligent agricultural system for farms in Beijing. In each greenhouses there are many sensors(such as temperature, humidity, etc.) , and these sensor-generate-data are send to Cluster Header(gateway) by Sensor Node of CROSSBOW. The Cluster Header will store these data temporarily and encapsulate them into an aggregation chain. At last, the aggregation chain will be transmitted using WCDMA. 
By doing this, it simplify implementation as well as to lower the cost(because some greenhouse can not connect to internet through wired line, if initiated every transmission for each data of sensor, that would be a waste of bandwidth ).

Regards
Xiaowei Qin 

From: Soumya Kanti Datta
Date: 2016-04-27 18:12
To: t2trg

My replies inline.

Regards,
Soumya

IMO, SenML (Sensor Markup Language) may be one kind open, the self - description way definition construction of data. So, every IOT device can use the common SenML data model to send information and each transmission can send large data. But, does it place a burden on the transportation system of IOT? After all, it need packaged into similar to XML document? 
[Soumya] SenML metadata can be encoded in JSON, CBOR or EXI. JSON encoding takes very minimal resources in IoT devices and not place so much burden on the transportation system (from my prototyping experience).
Information aggregation scheme in internet of things(IASIOT) is based on IP packet. The data generated by IOT devices would be aggregated into one frame chain at senders, which becomes the payload(MAC data) of the IP packet. 
[Soumya] Depending on the scenario, you may need to process each data or the aggregated data. Having a local processing on the device could ease the process.
Any more?

Best wishes
Xiaowei Qin

From: Ari Keränen
Date: 2016-04-27 15:41
To: [email-masked]
CC: [email-masked]

Cheers,
Ari

---

From: "[email-masked]" <[email-masked]>
Date: Thu, 28 Apr 2016 11:55:06 +0800

Hi，
>The best way to use SenML in a constrained environment is to encode it in CBOR.

In this scenario, who is the "executor"? I mean who encode it into CBRO, sensors or gateway, or any other IOT devices? IMO, a lot of IOT sensors have very low capacity, very small payload(15 – 100 byte) and limit number of frames per day(10 or less).

Xiaowei

From: Carsten Bormann
Date: 2016-04-27 17:45
To: [email-masked]
CC: Ari Keränen; t2trg

 
Grüße, Carsten

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 28 Apr 2016 07:56:58 +0200

[email-masked] wrote:
> In this scenario, who is the "executor"? I mean who encode it into CBRO,
> sensors or gateway, or any other IOT devices? 

As the name implies, SenML was originally designed for collecting data
from sensors.  Gateways and other aggregation/processing may use SenML
on both sides.  SenML could also be used to send information to
actuators, even if we haven't discussed this very much.

> IMO, a lot of IOT sensors
> have very low capacity, very small payload(15 – 100 byte) 

That is exactly where CBOR was designed for.

> and limit
> number of frames per day(10 or less).

Now this would a "millibit" scenario (not all of IoT happens in
"LP-WANs"), but CBOR still applies.

Grüße, Carsten