Subject: [T2TRG] Schema conversion opportunity: OMA LWM2M objects to YANG?

From: Carsten Bormann <[email-masked]>
Date: Thu, 21 Apr 2016 21:35:32 +0200

Around the IOTSI workshop, we had a discussion about modeling/schema
languages and the opportunities for conversion in order to create
semantic interoperability.

In CoRE, we are having this discussion about device management right
now, and one interesting question is whether the little XML DSL that OMA
LWM2M has here is a candidate for automatic conversion to another
management modeling language, e.g., YANG.

Anybody up to hacking together a prototype?  See
https://www.iab.org/wp-content/IAB-uploads/2016/03/Noise-in-specifications-hurts.pdf
for an example of such a conversion prototype.

Grüße, Carsten

-------- Original Message --------
Subject: Re: [core] ? WG adoption of
draft-veillette-core-yang-cbor-mapping-00
Date: Thu, 21 Apr 2016 19:48:06 +0200
From: Juergen Schoenwaelder <[email-masked]>
Reply-To: Juergen Schoenwaelder <[email-masked]>
To: Michel Veillette <[email-masked]>
CC: [email-masked] WG <[email-masked]>

On Thu, Apr 21, 2016 at 05:34:50PM +0000, Michel Veillette wrote:
> 
> First, LWM2M have its own modeling language encoded in xml.
> A file like "OMA-SUP-XML_LWM2M_Security-V1_0-20131210-C" is not fundamentally different than something than can be named security.yang.
> A simple xml transform can probably do the conversion between the two without any lost.
> LWM2M just have a simpler (subset) modeling language.
>

These are pretty bold statements. Claiming something is simple and
knowing something is simple are sometimes different things. Have you
worked throught the details? Is there a decent public definition of
the 'simpler (subset) modeling language'? And with public I mean
public, not hidden behind all sorts of registration walls.

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1 | 28759 Bremen | Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

_______________________________________________
core mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/core

---

From: "Kovatsch, Matthias" <[email-masked]>
Date: Thu, 21 Apr 2016 19:40:52 +0000

Could you please provide a pointer to the DSL to which you are referring?

Thanks :)
Matthias

-----Original Message-----
From: Carsten Bormann [[email-masked]]
Received: Thursday, 21 Apr 2016, 21:36
To: [email-masked] [[email-masked]]
Subject: [T2TRG] Schema conversion opportunity: OMA LWM2M objects to YANG?

Grüße, Carsten

-------- Original Message --------

/js

_______________________________________________
T2TRG mailing list
[email-masked]
https://www.irtf.org/mailman/listinfo/t2trg

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 21 Apr 2016 22:39:50 +0200

> Could you please provide a pointer to the DSL to which you are referring?

Hey, you are making the exercise too easy :-)

If you look at:

https://github.com/OpenMobileAlliance/OMA_LwM2M_for_Developers/wiki/OMA-LwM2M-Technical-Specifications

there are links to "Supporting Documents", eight of them in total.
These are all XML files that essentially define the LWM2M objects in an
ad-hoc DSL -- we briefly discussed this in San Jose.  (Unfortunately,
part of the info is in English-language comments; these will require
manual translation; the rest should be translatable right away however.)

Grüße, Carsten