Subject: [T2TRG] Composition of media types

From: Carsten Bormann <[email-masked]>
Date: Sun, 18 Mar 2018 15:30:51 +0000

Two new drafts that may be of interest to the RG:

	The Series Transfer Pattern (STP)

	https://tools.ietf.org/html/draft-bormann-t2trg-stp-00

describes ways in which “event streams” or “time series” can be mapped to REST, using a small set of media types to operate on collections of data.

	The application/maybe media type

	https://tools.ietf.org/html/draft-bormann-core-maybe-00

describes a media type that works like the Haskell “Maybe” construction [1]:
An object of another media type is either there or (not yet, no longer) there.
(This was motivated by the “Pending” discussion, and the idea of course came from Klaus, while all breakage is mine.)

The underlying theme is that we can build media types that support specific interaction patterns out of others, with very little overhead of doing so.

Grüße, Carsten

[1]: https://wiki.haskell.org/Maybe

---

From: Abhijan Bhattacharyya <[email-masked]>
Date: Sun, 18 Mar 2018 23:21:50 +0530

Hi Carsten,

>describes ways in which &#8220;event streams&#8221; or &#8220;time series&#8221; can be
>mapped to REST, using a small set of media types to operate on
>collections of data.

I think this draft addresses an important aspect. A standardized approach would be indeed valuable. 
A small observation on the two bullets in the "Objectives" section:
While "completeness" and "latency minimization" are two competing objectives, probably they converge in the "error concealment" aspect. As you have mentioned in the both the bullets, just when the application designer makes reliability an 'illusion', the latency minimization is taken care of. So, probably, in future, an observation can be documented on the role of end-application intelligence in terms of creating the seamless feel of truthfulness to the end-user in the context of STP.    

Another point. Just wondering whether studies like the following would be worth considering in respect to this kind of work (probably I mentioned about this to you when we met in Bangalore last year):
http://ieeexplore.ieee.org/abstract/document/8016232/  
  |
 V

"Semantic data exchange between collaborative robots in fog environment: Can CoAP be a choice?", Sounak Dey, Abhijan Bhattacharyya, Arijit Mukherjee, Global Internet of Things Summit (GIoTS), June, 2017, pp.1-6

Abstract:"The transition of Internet from human-centric exchanges to the Internet  of Things has posed several interesting challenges regarding the  communication model and data exchange pattern. The emergence of edge/fog  computing as a compute model has further highlighted the need of a  uniform model to cater to the inherent heterogeneity of participating  devices. In several domains, the devices may range from standard compute  and communication devices to gateways/switches, as well as  robots/drones and other types of autonomous entities. In scenarios like  disaster management, warehouse automation, surveillance etc. use of  robots/drones/AGVs/UAVs is steadily increasing in order to minimise  potentially hazardous human intervention. Optimality of data exchange  and further processing is a desired feature in such scenarios,  especially in outdoor disaster situations where availability of the  back-end cloud infrastructure can not be guaranteed. In this paper, we  demonstrate a real life robotic data exchange model based on Resource  Description Framework (RDF). We further perform a comparative analysis  of network performance between TCP in Robot Operating System (ROS) and  block-wise extension to Constrained Application Layer Protocol (CoAP)  for bidirectional exchange of such RDF data in a disaster situation  where robotic entities accomplish search and rescue missions in  collaboration with fog devices. The causal analysis presented in this  paper puts a stepping stone for potential future enhancement of CoAP."

Thank you,

With Best Regards
 Abhijan Bhattacharyya
 Associate Consultant
 Scientist, TCS Research
 Tata Consultancy Services
 Building 1B,Ecospace
 Plot -  IIF/12 ,New Town, Rajarhat,
 Kolkata - 700160,West Bengal
 India
 Ph:- 033 66884691
 Cell:- +919830468972
 Mailto: [email-masked]
 Website: http://www.tcs.com
 ____________________________________________
 Experience certainty.	IT Services
 			Business Solutions
 			Consulting
 ____________________________________________

-----"T2TRG" <[email-masked]> wrote: -----

>To: [email-masked]
>From: Carsten Bormann 
>Sent by: "T2TRG" 
>Date: 03/18/2018 09:01PM
>Subject: [T2TRG] Composition of media types
>
>describes ways in which &#8220;event streams&#8221; or &#8220;time series&#8221; can be
>mapped to REST, using a small set of media types to operate on
>collections of data.
>
>describes a media type that works like the Haskell &#8220;Maybe&#8221;
>construction [1]:
>(This was motivated by the &#8220;Pending&#8221; discussion, and the idea of
>course came from Klaus, while all breakage is mine.)
>
>The underlying theme is that we can build media types that support
>specific interaction patterns out of others, with very little
>overhead of doing so.
>
>Grüße, Carsten
>
>_______________________________________________
>T2TRG mailing list
>[email-masked]
>https://www.irtf.org/mailman/listinfo/t2trg
>
=====-----=====-----=====
Notice: The information contained in this e-mail
message and/or attachments to it may contain 
confidential or privileged information. If you are 
not the intended recipient, any dissemination, use, 
review, distribution, printing or copying of the 
information contained in this e-mail message 
and/or attachments to it are strictly prohibited. If 
you have received this communication in error, 
please notify us by reply e-mail or telephone and 
immediately and permanently delete the message 
and any attachments. Thank you