Subject: [T2TRG] Last WISHI call (today) before IETF 101, WISHI hackathon, and OCF registration

From: Ari Keränen <[email-masked]>
Date: Mon, 12 Mar 2018 08:29:32 +0000

Remember that today we have the last WISHI call before the IETF meeting and the WISHI hackathon:
https://github.com/t2trg/wishi/wiki/Agenda-items
Time: 8:00-9:30 AM PDT (16:00-17:30 CET -- note the summer time difference)

Also remember to answer to the hackathon questionnaire: https://github.com/t2trg/wishi/wiki/Hackathon--Participant-Questionnaire

And today is the last day to register for the joint meeting with OCF and W3C WoT:
https://github.com/t2trg/2018-03-ocf-wot

Cheers,
Ari

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 12 Mar 2018 15:40:41 +0100

> Also remember to answer to the hackathon questionnaire: https://github.com/t2trg/wishi/wiki/Hackathon--Participant-Questionnaire

Looking at what we have now:

# Application scenarios:

— exposing resources and functions to third party applications
— discovery and application configuration
— maintaining abstraction over low-level API changes
— providing application data through a proxy, abstracting physical objects

# When:

— provisioning time
— perform registration and discovery as well as configuration of resources ahead to operational data exchange
— control lifetime of registrations to allow decommissioning

# What components are supplied?

— Things
— Thing Directory
— Client for ad-hoc discovery and integration of simple applications
— application-layer proxy

# What components could be integrated?

— Other Things, Applications, Thing Directories

# Protocols

— HTTP, HTTPS
— SenML based data format
— MQTT and Webhooks for dynamic notifications
— WebSockets
— CoAP

# Thing types

— lights
— motion sensors
— illuminance sensors

# Thing directory

— Resources exposing capabilities in W3C TD format
— Semantic queries
— Feature of Interest annotation
— lifetime indication on a registration

# Proxies

— currently not available for others to use for exposing things

# Security

— TLS/DTLS, plus HTTP basic auth
— none (for this round)

I hope this is a useful summary and we can discuss along these items.
Talk to you all in 20 minutes.

Grüße, Carsten

---

From: Ari Keränen <[email-masked]>
Date: Mon, 12 Mar 2018 15:11:16 +0000

Due to technical problems we moved the call to Google hangouts:
https://hangouts.google.com/call/FMWW20LkX0CAOPf1EhV2AAEI

Cheers,
Ari