Subject: Re: [T2TRG] WISHI Hackathon at IETF102 (Montreal)

From: William_J_G Overington <[email-masked]>
Date: Sat, 14 Jul 2018 13:14:39 +0100 (BST)

Hi

In relation to this I was looking on the web to try to find out more the other day and I found something about trying to link a motion sensor to a door lock such that when the motion sensor detects motion that the door becomes locked.

I have been trying to find that again but cannot now find it.

Can anyone post a link please?

I am wondering what exactly would be the message sent to the thing that contains the motion sensor to the thing that contains the door lock.

Would it be a standardized command used throughout the Internet of Things so as to request that a door be locked?

Could it be in an email?

I am wondering whether it could be a message expressed as a sequence of Unicode characters, the sequence consisting of an integral sign followed by six circled digit characters, such that the coded message could be 'understood' by a thing yet could also be easily decoded into any natural language that can be displayed using Unicode characters.

http://www.users.globalnet.co.uk/~ngo/An_encoding_space_designed_for_application_in_encoding_localizable_sentences.pdf

I am starting to draft a collection of localizable sentences for this experiment yet also for possible application more widely in the Internet of Things.

I am wondering whether this email system and the archive will handle such sequences satisfactorily so here is a test using one of the localizable sentences from the document referenced above.

The sentence is the one that asks

Would you like a drink of water?

which is encoded in my research project as an integral sign followed by a circled digit seven, a circled digit eight, and a circled digit one.

Here is that sequence

∫⑦⑧①

as a test of what happens with emails and with the archive.

William Overington

Saturday 14 July 2018

----Original message----
>From : [email-masked]
Date : 2018/07/11 - 22:00 (GMTDT)
To : [email-masked]
Subject : [T2TRG] WISHI Hackathon at IETF102 (Montreal)

If you want to attend the Hackathon for WISHI on Saturday/Sunday, don’t forget to register at

	https://www.ietf.org/registration/ietf102/hackathonregistration.py

and enter WISHI as (one of) the technologies.

You may also want to look at

	https://github.com/t2trg/wishi/wiki/Hackathon--Participant-Questionnaire

(Filling this in is not required, but useful.)
Some more information is at the WISHI wiki, e.g. at:

	https://github.com/t2trg/wishi/wiki/Hackathon-Planning

See also the slides from previous preparation calls at:

	https://github.com/t2trg/wishi/tree/master/slides

See you all in Montreal!

Grüße, Carsten

_______________________________________________
T2TRG mailing list
[email-masked]
https://www.irtf.org/mailman/listinfo/t2trg

---

From: William_J_G Overington <[email-masked]>
Date: Sat, 14 Jul 2018 17:43:44 +0100 (BST)

Hi

I have now devised some localizable sentences for research in thing to thing communication. These could also be decoded, using a previously prepared sentence.dat file, into any language (language as in English, French, Japanese etc) that Unicode can support.

The localizable sentences encoded specifically for research in thing to thing communication are codes consisting of an integral sign and six circled digit characters.

The list here also has some localizable sentences that are of more general use and they are encoded as an integral sign and three circled digit characters.

Information about the encoding space is available in the following document.

Here are the codes for the localizable sentences thus far defined for research in thing to thing communication together with codes for some localizable sentences for more general application as well as for research in thing to thing communication.

At the time of writing I do not know how useful these codes for localizable sentences may be for use at the WISHI Hackathon, maybe not at all, but I have sent them in the hope that they may be considered please.

Requests for codes for localizable sentences that readers need to pursue the research are welcome. If any requests are received I will try to post codes.

Here is the list so far.

∫①②⑦ The following question has been asked.

∫⑨⑧③ My answer is as follows.

∫③②③⑨⑧② The following request has been made.

∫③②③⑨⑧⑤ I have now carried out that request.

∫③②③⑨⑦② I do not have the capability to carry out that request.

∫③②③⑨⑦⑤ I can carry out the following requests.

∫①②⑧  Here is a list.

∫⑨⑧② The list is now completed.

∫③②③⑨⑧④ I can only carry out that request when I receive a password.

∫③②③⑨⑥① What is the temperature at your location please?

∫③②③⑨⑥② The temperature at my location in degrees Celsius is as follows.

Example of use:

∫③②③⑨⑥② 21.3

Example of use:

∫①②⑦ ∫③②③⑨⑥① ∫⑨⑧③ ∫③②③⑨⑥② 21.3

Readers are welcome to also use the codes in the

document if they so choose.

William Overington

Saturday 14 July 2018

----Original message----
>From : wjgo_10009=[email-masked]
Date : 2018/07/14 - 13:14 (GMTDT)
To : [email-masked], [email-masked]
Subject : Re: [T2TRG] WISHI Hackathon at IETF102 (Montreal)

Hi

Could it be in an email?

Here is that sequence

∫⑦⑧①

William Overington

Saturday 14 July 2018

----Original message----

See you all in Montreal!

Grüße, Carsten