Subject: [T2TRG] [T2TRG/Din] Discussion New draft for draft-hong-iot-edge-computing-00.txt

From: Jungha Hong <[email-masked]>
Date: Tue, 10 Jul 2018 02:43:13 +0000

Dear all,

We submitted a draft tiled "Problem Statement of IoT integrated with Edge Computing".

https://www.ietf.org/internet-drafts/draft-hong-iot-edge-computing-00.txt

This is the first edition and its purpose is to discuss the followings:

  *   New challenges of IoT by the environment changes
  *   Edge computing as an emerging technology in IoT
  *   Use cases of Edge computing in IoT
  *   IETF/IRTF directions for Edge computing in IoT

We would like to start a discussion first on the mailing list before the Montreal meeting.

Please take a look and give us any comments.

We hope to get an enough comments for a side meeting in Montreal.

I am copying it to DINRG as well in case they might be interested in this topic.

Thanks,

Jungha Hong

________________________________
보낸 사람 : "[email-masked]" <[email-masked]>
보낸 날짜 : 2018-07-02 21:22:08 ( +09:00 )
받는 사람 : 홍정하 <[email-masked]>, 홍용근 <[email-masked]>, 홍정하 <[email-masked]>, Joo-Sang Youn <[email-masked]>, 홍용근 <[email-masked]>
참조 :
제목 : New Version Notification for draft-hong-iot-edge-computing-00.txt

A new version of I-D, draft-hong-iot-edge-computing-00.txt
has been successfully submitted by Jungha Hong and posted to the
IETF repository.

Name: draft-hong-iot-edge-computing
Revision: 00
Title: Problem Statement of IoT integrated with Edge Computing
Document date: 2018-07-02
Group: Individual Submission
Pages: 12
URL: https://www.ietf.org/internet-drafts/draft-hong-iot-edge-computing-00.txt
Status: https://datatracker.ietf.org/doc/draft-hong-iot-edge-computing/
Htmlized: https://tools.ietf.org/html/draft-hong-iot-edge-computing-00
Htmlized: https://datatracker.ietf.org/doc/html/draft-hong-iot-edge-computing

Abstract:
This document describes new challenges for IoT services issued by the
changes of the IoT environment. In order to address those new
challenges, the integration of Edge computing and IoT has been
emerged as a promising solution. This document provides the concept
of IoT integrated with Edge computing as well as its use cases to
discuss the benefits and challenges of Edge computing mainly focused
on IoT data. The direction of Edge computing for IoT should be
discussed in IETF/IRTF.

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: Thorsten Dahm <[email-masked]>
Date: Wed, 11 Jul 2018 14:46:50 +0100

Hi,

I read the document. What I miss are the solutions. If I pick one example:
Section 4.1. - Strict Latency. I doubt that many people will disagree with
you here, if you use a light switch for example you don't want to wait for
3 seconds RTT before the light comes on. But that is such a short
paragraph, it simply says that some IoT operations are latency sensitive.
Would you consider expanding on that giving recommendations on how to
actually solve the latency problem, or do you just plan to list problems
that you are currently aware of that folks who implement IoT could come
across?

Regards,
Thorsten

Am Di., 10. Juli 2018 um 03:43 Uhr schrieb Jungha Hong <[email-masked]>:

>    - New challenges of IoT by the environment changes
>    - Edge computing as an emerging technology in IoT
>    - Use cases of Edge computing in IoT
>    - IETF/IRTF directions for Edge computing in IoT
>
>
>
> ------------------------------
> *보낸 사람 : *"[email-masked]" <[email-masked]>
> *보낸 날짜 : *2018-07-02 21:22:08 ( +09:00 )
> *받는 사람 : *홍정하 <[email-masked]>, 홍용근 <[email-masked]>, 홍정하 <
> [email-masked]>, Joo-Sang Youn <[email-masked]>, 홍용근 <
> [email-masked]>
> *참조 : *
> *제목 : *New Version Notification for draft-hong-iot-edge-computing-00.txt
>
>
> URL:
> Htmlized:
> https://datatracker.ietf.org/doc/html/draft-hong-iot-edge-computing
>
>
> Abstract:
> _______________________________________________
> T2TRG mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/t2trg
>

-- 
Thorsten Dahm

Network Engineer
Google Ireland Ltd.
The Gasworks, Barrow Street
Dublin 4,  Ireland

Registered in Dublin, Ireland
Registration Number: 368047

---

From: Jungha Hong <[email-masked]>
Date: Thu, 12 Jul 2018 02:23:38 +0000

Dear Thorsten,

The pupose of this draft is to list up new challenges/problems of IoT first and then form a group consensus on IoT integrated with Edge computing. Here, we are not addressing any specific solutions yet.

However, once we get a consensus on it, we will discuss solutions.

By the way, we are developing a solution for smart constructions stated in section 6.1.

When it comes time to propose solutions, we are willing to discuss it.

If anybody or any project is working on IoT Edge computing, please join in this discussion and give us any comments/suggestions.

We welcome any comments and suggestions.

Even more any contributions.

Thanks,

Jungha Hong

________________________________
보낸 사람 : "Thorsten Dahm" <[email-masked]>
보낸 날짜 : 2018-07-11 22:47:35 ( +09:00 )
받는 사람 : 홍정하 <[email-masked]>
참조 : [email-masked] <[email-masked]>, [email-masked] <[email-masked]>, 홍용근 <[email-masked]>, [email-masked] <[email-masked]>
제목 : Re: [T2TRG] [T2TRG/Din] Discussion New draft for draft-hong-iot-edge-computing-00.txt

Hi,

I read the document. What I miss are the solutions. If I pick one example: Section 4.1. - Strict Latency. I doubt that many people will disagree with you here, if you use a light switch for example you don't want to wait for 3 seconds RTT before the light comes on. But that is such a short paragraph, it simply says that some IoT operations are latency sensitive. Would you consider expanding on that giving recommendations on how to actually solve the latency problem, or do you just plan to list problems that you are currently aware of that folks who implement IoT could come across?

Regards,
Thorsten

Am Di., 10. Juli 2018 um 03:43 Uhr schrieb Jungha Hong <[email-masked]<mailto:[email-masked]>>:

Dear all,

Thanks,

Jungha Hong

________________________________
보낸 사람 : "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>

받는 사람 : 홍정하 <[email-masked]<mailto:[email-masked]>>, 홍용근 <[email-masked]<mailto:[email-masked]>>, 홍정하 <[email-masked]<mailto:[email-masked]>>, Joo-Sang Youn <[email-masked]<mailto:[email-masked]>>, 홍용근 <[email-masked]<mailto:[email-masked]>>

참조 :

IETF repository.

Revision: 00

Pages: 12

Abstract:

discussed in IETF/IRTF.

until the htmlized version and diff are available at tools.ietf.org<http://tools.ietf.org/>.

The IETF Secretariat

T2TRG mailing list

[email-masked]<mailto:[email-masked]>

clear="all">

--

Thorsten Dahm

Network Engineer

Google Ireland Ltd.

Dublin 4,  Ireland

---

From: L M Feeney <[email-masked]>
Date: Mon, 16 Jul 2018 22:23:08 +0200

Dear Jungha and team and all,

I think the document addresses important and interesting issues.

I agree with Thorsten Dahm that it lists problems (generally in the form
of requirements) and misses solutions.

But for me, it also misses an architectural context for the challenges
that are highlighted by the document.

For example, the discussion of latency is really about a requirement. It
would be helpful to understand more about the challenge: Where does the
important delay and jitter come from?  Is it in the wireless access or
is due to potentially high traffic loads in the network infrastructure
at the edge?  Or is the bottleneck in coordinating resources needed for
edge processing?   Perhaps working through these sorts of questions
would highlight where the most useful directions are?

Of course, the answers might be different for different architecture
models of the network and the edge functionality: A RPL-based network
operating in unlicensed spectrum and connecting via home WiFi to edge
services being provided to users spread over a large geographic area
might be quite different from a network that uses a mobile operator's
radio access network to connect to edge services for a factory
environment.  Perhaps the use cases in section 5 would be helpful in
focusing on a small number of representative architectures?

Thanks and best regards,
Laura

----
Laura Marie Feeney
Uppsala University, Sweden

On 2018-07-10 04:43, Jungha Hong wrote:
> ------------------------------------------------------------------------
> *받는 사람 : *홍정하 <[email-masked]>, 홍용근 <[email-masked]>, 홍
> 정하 <[email-masked]>, Joo-Sang Youn <[email-masked]>, 홍용근
> <[email-masked]>
> *참조 : *

När du har kontakt med oss på Uppsala universitet med e-post så innebär det att vi behandlar dina personuppgifter. För att läsa mer om hur vi gör det kan du läsa här: http://www.uu.se/om-uu/dataskydd-personuppgifter/

E-mailing Uppsala University means that we will process your personal data. For more information on how this is performed, please read here: http://www.uu.se/om-uu/dataskydd-personuppgifter/

---

From: 홍용근 <[email-masked]>
Date: Tue, 17 Jul 2018 09:57:13 +0000

Dear Laura Marie Feeney.

Thanks for your valuable comments.

For regarding of architectural issue, the current draft does not include an architectural context and I agree your point.
If we consider a requirement such as latency, this requirement is very related to a network architecture and its capabilities. 
I agree that it would be more better to consider a network architecture when we talk about requirements.

For implementing IoT Edge computing, we can utilize many open sources and existing commercial products. Even though we can describe 
an architecture of IoT Edge computing based on some typical open sources and existing commercial products, we hope to find common architecture of 
IoT Edge computing and describe common parts of them.

I appreciate your comments and we would try to describe architecture contexts in a next revision.

Best regards.

Yong-Geun.

-----Original Message-----
From: L M Feeney [mailto:[email-masked]] 
Sent: Tuesday, July 17, 2018 5:23 AM
To: 홍정하; [email-masked]; [email-masked]
Cc: 홍용근; [email-masked]
Subject: Re: [T2TRG] [T2TRG/Din] Discussion New draft for draft-hong-iot-edge-computing-00.txt

Thanks and best regards,
Laura

----
Laura Marie Feeney