Subject: Re: [T2TRG] Call for Comment: <draft-iab-iotsi-workshop-02> Report from the Internet of Things (IoT) Semantic Interoperability (IOTSI) Workshop 2016

From: William_J_G Overington <[email-masked]>
Date: Tue, 17 Jul 2018 10:46:49 +0100 (BST)

Hi

I am fairly new to research on The Internet of Things.

I have been looking at the document.

I have noted the matter of interoperability.

Recently I have been posting some ideas to the Thing-to-Thing Research Group (T2TRG) mailing list.

https://mailarchive.ietf.org/arch/browse/t2trg/

I refer in particular to three posts from me, namely my third post of Saturday 14 July 2018,

https://mailarchive.ietf.org/arch/msg/t2trg/puH70mLzz2T9IPUgooaozVcbKKI

and my post of Tuesday 10 July 2018

https://mailarchive.ietf.org/arch/msg/t2trg/zQ1aoP1QidCU2cnDR8NnTWhsVVo

and my second post of Thursday 12 July 2018

https://mailarchive.ietf.org/arch/msg/t2trg/CLBC7cqUM0kku3LxMI0hTBLe-qo

Please note that some of the posts have links out to my webspace. Please know that the webspace is now hosted by Plusnet PLC, an internet service provider in the United Kingdom, which took over the company that had taken over the company that originally hosted the webspace as a free with internet dial-up access webspace back in the late 1990s: I have now used broadband (from British Telecommunications PLC) for many years but I have been able to keep the webspace although the dial-up facility itself has been closed down. I am located in the United Kingdom. I pay a fee of just over £20 each year to have the facility of the webspace and I add items to it by ftp access from my home computer, a Lenovo ideapad 510 running Windows 10. I mention these matters so as to try to provide provenance that the webspace is safe to access. The PDF documents referenced have been produced using the Serif PagePlus desktop publishing program.

Could this method solve the interoperability problem, in that it is independent of any manufacturer and is open source and free to use?

The method has the advantages that it is language-independent, so a device does not need to analyse English or any other language; and also the codes can be localized, by using a sentence.dat text file as a look up table from code to sentence in a language, into any human language that can be encoded using Unicode characters so that a human can easily monitor what is happening.

Can we discuss these ideas please?

William Overington

Tuesday 17 July 2018

----Original message----
>From : [email-masked]
Date : 2018/07/16 - 15:27 (GMTDT)
To : [email-masked]
Subject : Call for Comment: &lt;draft-iab-iotsi-workshop-02&gt; Report from the Internet of Things (IoT) Semantic Interoperability (IOTSI) Workshop 2016

This is an announcement of an IETF-wide Call for Comment on 
draft-iab-iotsi-workshop-02.

The document is being considered for publication as an Informational RFC 
within the IAB stream, and is available for inspection at:
https://datatracker.ietf.org/doc/draft-iab-iotsi-workshop/

The Call for Comment will last until 2018-08-13. Please send comments to
[email-masked] and [email-masked].

Abstract

   This document provides a summary of the 'Workshop on Internet of
   Things (IoT) Semantic Interoperability (IOTSI)', which took place in
   Santa Clara, California, on March 17-18, 2016.  The main goal of the
   workshop was to foster a discussion on the different approaches used
   by companies and Standards Developing Organizations (SDOs) to
   accomplish interoperability at the application layer.  This report
   summarizes the discussions, and lists recommendations to the
   standards community.  The views and positions in this report are
   those of the workshop participants and do not necessarily reflect
   those of the authors and the Internet Architecture Board (IAB), which
   organized the workshop.

---

From: William_J_G Overington <[email-masked]>
Date: Tue, 17 Jul 2018 10:58:29 +0100 (BST)

Hi

William Overington

Tuesday 17 July 2018

----Original message----

Abstract

---

From: William_J_G Overington <[email-masked]>
Date: Tue, 17 Jul 2018 13:00:49 +0100 (BST)

Hi

Earlier today I posted to [email-masked] and [email-masked], also [email-masked] as well.

After posting I could not find the post in the archive for architecture-discussion and I thought that that was because I had not registered for architecture-discussion. So I registered and then posted again.

However, now, both copies are in both archives.

My apologies. Could someone possibly delete the second versions from the archives please?

William Overington

Tuesday 17 July 2018

---

From: William_J_G Overington <[email-masked]>
Date: Thu, 19 Jul 2018 17:05:13 +0100 (BST)

Hi

In section 3 there is a paragraph immediately below a heading that is labelled Translation.

> The working assumption is that devices need to have a common data model with a priori knowledge of data types and actions.  However that would imply that each consortium/organization will try to define their own, causing a major interoperability problem, if not a completely intractable one given the amount of variations, extensions, compositions or versioning changes that will happen on a per data model basis.

I am new to Internet of Things research, but to me the first sentence does not imply the second sentence.

Am I missing something?

My thinking is that yes, it is possible that "each consortium/organization will try to define their own" but why would that necessarily cause "a major interoperability problem, if not a completely intractable one given the amount of variations, extensions, compositions or versioning changes that will happen on a per data model basis."?

I remember back in the late 1980s learning some of the Ada programming language so as to be able to help students learning Ada: some needed help, some did not.

I seem to remember there was a concept of modules that could have public externally-accessible data variables and methods; and private internal data variables and methods. In practice a module usually had very few public externally-accessible data variables and methods; and more private internal data variables and methods.

Could such a situation of a similar sort of structure be used for things on the Internet of things, in that how a thing works internally is up to the manufacturer but the format of how the thing sends messages and the format of messages that it is required to receive are standardized at a manufacturer-independent level?

If that could be done, it could obviate a lot of interoperability issues.

An everyday analogy is that I am typing this email on a Lenovo ideapad 510 laptop computer that is running Windows 10. Yet the fact that the content of the email is typeset using the Unicode ISO/IEC 10646 Universal Character Set means that it can be read on a different type of computer running a different type of operating system. That is, the internal workings of each computer are how they are, yet the message sent and received is in an interoperable standardized format.

William Overington

Thursday 19 July 2018

---

From: William_J_G Overington <[email-masked]>
Date: Tue, 31 Jul 2018 15:33:39 +0100 (BST)

Hi

Further to my posts of 17 July 2018 and 19 July 2018 I have been thinking of how to express my ideas in a diagram.

Here are links to the earlier posts.

https://www.ietf.org/mail-archive/web/architecture-discuss/current/msg01372.html

https://www.ietf.org/mail-archive/web/architecture-discuss/current/msg01374.html

I noted the Red Star used in the original document upon which we are commenting.

I wondered how my ideas could be expressed using a logo.

I have now decided that in order to express my ideas, a collection of logos is needed, with each individual logo based upon a basic design.

The basic design is to have a square with a black border and that the square is divided within its boundary vertically into two equal halves by an invisible line. The area to one side of the invisible line (it can be either side as desired so as to make diagrams clearer) is always green. (r=0, g=255, b=0) This is to represent the part of the device that communicates with other devices at application level using localizable sentences encoded using a sequence of Unicode characters starting with an integral sign and followed by a number of circled digit characters. The area to the other side of the invisible line is in a colour other than green, so as to represent the part of the device that has manufacturer-chosen software and data structures.

I am wondering whether this mailing list and its archives support attachments.

So I have produced an experimental diagram both to test that and also to show an example diagram representing two devices, each made by a different manufacturer, communicating with each other using localizable sentences.

The picture has two devices with a red line connecting them.

William Overington

Tuesday 31 July 2018

---

From: William_J_G Overington <[email-masked]>
Date: Tue, 31 Jul 2018 16:34:54 +0100 (BST)

Hi

Following my post earlier today and finding that I can include a diagram as an attachment and that the diagram is stored in the archive, I have now produced another diagram that represents five devices, each from a different manufacturer, able to communicate each with the others at application level.

William Overington

Tuesday 31 July 2018

----Original message----
>From : [email-masked]
Date : 2018/07/31 - 15:33 (GMTDT)
To : [email-masked], [email-masked], [email-masked]
Subject : Call for Comment: &lt;draft-iab-iotsi-workshop-02&gt; Report from the Internet of Things (IoT) Semantic Interoperability (IOTSI) Workshop 2016

Hi

William Overington

Tuesday 31 July 2018