Subject: Re: [T2TRG] [T2TRG/Din] Discussion New draft for draft-hong-iot-edge-computing-00.txt

From: William_J_G Overington <[email-masked]>
Date: Thu, 12 Jul 2018 13:31:00 +0100 (BST)

Hi

> I wonder how your two suggestions are related to our draft.

> Could you please clarify your suggestions more related to the draft?

In section 5.3 is the following.

> In spite of such benifits of Edge computing in IoT services, it has challenges such as programmability, naming, data abstraction, service management, privacy and security and optimization metrics.

My first suggestion relates to naming, data abstraction and service management.

My second suggestion relates to programmability.

Consider please a thought experiment.

Suppose that there is a type of thing that can measure air temperature, air pressure, location in latitude and longitude. Let us call it a type 8001 device.

Suppose that the type 8001 device has built into it a mobile telephone that can receive and send emails.

When asked, by email, a type 8001 device can make a measurement and send a reply, listing any one or more of air temperature, air pressure, location in latitude and longitude. Each particular type 8001 device has its own unique telephone number.

As a first stage of this thought experiment, let us suppose that one of the type 8001 devices is located in Italy, one is located in Greece and one is located in Latvia.

Suppose that there is a type of thing than can ask a type 8001 device for measurement data of one or more of air temperature, air pressure, location in latitude and longitude. Each has a display screen that may sometimes be being viewed by a human being who knows the local language and may, but need not, know any other language. Let us call it a type 8002 device.

Let us suppose that one of the type 8002 devices is located in Portugal and one is located in Japan. 

My first suggestion allows questions from a preset list of questions to be asked by a type 8002 device independently of any human language and a reply to be sent from a type 8001 device independently of any human language, yet also displayable in any human language that can be displayed using the Universal Character Set simply by having a sentence.dat file for the particular human language loaded into the type 8002 device.

In this context, the Universal Character Set may be thought of as the same as the Unicode character set.

As regards my second suggestion, suppose please that after some time it is decided that the format of the email sent in response to an enquiry should always begin by specifying the location at which the measurements of air temperature and air pressure have been made, even if not explicitly requested.

If the type 8001 devices all have to be altered by a service technician this could take a while and be expensive. Also, if a type 8001 device can be made by several manufacturers and some use one microprocessor and some use another and so on with either direct machine code programs, or an app running on one of a number of different operating system platforms the task could be enormous.

Yet suppose that each type 8001 device runs a program that is written in a portable interpretable object code, the same code on each type 8001 device. Certainly the interpreter software for a particular type 8001 device may well be different from the interpreter software for a type 8001 device made by another manufacturer; that is not a problem provided that each interpreter software program complies to the specification for how to interpret the portable interpretable object code by running it in a software construct known as a virtual machine.

Given that scenario, the desired software update can be achieved by sending each type 8001 device an email, with appropriate security of provenance, to update the application program on the type 8001 device.

Comments are welcome. Discussion of this thought experiment is welcome

William Overington

Thursday 12 July 2018

----Original message----

>From : [email-masked]
Date : 2018/07/12 - 02:17 (GMTDT)
To : [email-masked], [email-masked], [email-masked]
Cc : [email-masked], [email-masked]
Subject : RE: [T2TRG] [T2TRG/Din] Discussion New draft for draft-hong-iot-edge-computing-00.txt

Dear William Overington,

Thanks for your email.

I wonder how your two suggestions are related to our draft.

Could you please clarify your suggestions more related to the draft?

 Thanks,

Jungha Hong

---

From: Jungha Hong <[email-masked]>
Date: Fri, 13 Jul 2018 01:15:56 +0000

Dear William Overington.

Thanks for clarifying your two suggestions.
Although those are not exactly addressed in our draft, it seems to be meaningful concerns.
We hope to find a  good approach on how to consider your two suggestions.

Due to lack of time for discussion on our draft before Montreal meeting, we would like to ask you to contribute on those concerns
in the next revision of this draft if you are not planning to make your own draft.

Thanks,
Jungha Hong

________________________________
보낸 사람 : "William_J_G Overington" <[email-masked]>
보낸 날짜 : 2018-07-12 21:31:19 ( +09:00 )
받는 사람 : 홍정하 <[email-masked]>, [email-masked] <[email-masked]>, [email-masked] <[email-masked]>
참조 : 홍용근 <[email-masked]>, [email-masked] <[email-masked]>
제목 : Re: RE: [T2TRG] [T2TRG/Din] Discussion New draft for draft-hong-iot-edge-computing-00.txt

Hi

William Overington

Thursday 12 July 2018

----Original message----

From : [email-masked]

Dear William Overington,

Thanks for your email.

Thanks,

Jungha Hong

---

From: William_J_G Overington <[email-masked]>
Date: Sat, 14 Jul 2018 15:54:36 +0100 (BST)

Hi
in the next revision of this draft if you are not planning to make your own draft.
Thank you for your request.
I am trying to think of how to phrase the concepts underlying my ideas as problems that might need to be solved, because it may be that solutions to such problems already exist, already authored by other people.
Best regards,
William Overington
Saturday 14 July 2018
----Original message----
>From : [email-masked]
Date : 2018/07/13 - 02:15 (GMTDT)
To : [email-masked], [email-masked], [email-masked]
Cc : [email-masked], [email-masked]
Subject : Re: [T2TRG] [T2TRG/Din] Discussion New draft for draft-hong-iot-edge-computing-00.txt
Dear William Overington.

 
 
Hi

Suppose that there is a type of thing than can ask a type 8001 device for measurement data of one or more of air temperature, air pressure, location in latitude and longitude. Each has a display screen that may sometimes be being viewed by a human being who
 knows the local language and may, but need not, know any other language. Let us call it a type 8002 device.

My first suggestion allows questions from a preset list of questions to be asked by a type 8002 device independently of any human language and a reply to be sent from a type 8001 device independently of any human language, yet also displayable in any human
 language that can be displayed using the Universal Character Set simply by having a sentence.dat file for the particular human language loaded into the type 8002 device.

As regards my second suggestion, suppose please that after some time it is decided that the format of the email sent in response to an enquiry should always begin by specifying the location at which the measurements of air temperature and air pressure have
 been made, even if not explicitly requested.

If the type 8001 devices all have to be altered by a service technician this could take a while and be expensive. Also, if a type 8001 device can be made by several manufacturers and some use one microprocessor and some use another and so on with either direct
 machine code programs, or an app running on one of a number of different operating system platforms the task could be enormous.

Yet suppose that each type 8001 device runs a program that is written in a portable interpretable object code, the same code on each type 8001 device. Certainly the interpreter software for a particular type 8001 device may well be different from the interpreter
 software for a type 8001 device made by another manufacturer; that is not a problem provided that each interpreter software program complies to the specification for how to interpret the portable interpretable object code by running it in a software construct
 known as a virtual machine.

William Overington

Thursday 12 July 2018

----Original message----

 

Dear William Overington,

Thanks for your email.

Thanks,

Jungha Hong