Subject: Re: [T2TRG] [T2TRG/Din] Discussion New draft for draft-hong-iot-edge-computing-00.txt

From: William_J_G Overington <[email-masked]>
Date: Wed, 11 Jul 2018 16:20:33 +0100 (BST)

Thorsten Dahm wrote:

> I read the document. What I miss are the solutions.

Well, the title of the document is as follows.

Problem Statement of IoT integrated with Edge Computing

The email announcing the post has the following.

>> We would like to start a discussion first on the mailing list before the Montreal meeting.

>> Please take a look and give us any comments.
 
>> We hope to get an enough comments for a side meeting in Montreal.

I just found out that the meeting in Montreal starts this Saturday, that is in three days time, and goes on for a week. So discussion needs to get going promptly if enough comments for a side meeting in Montreal as desired are to become gathered. 

I posted yesterday and thus far nobody has responded at all to my post, whether to comment or to ask a question.

It seems to me that Edge computing is potentially very important in relation to the Internet of Things and so the Problem Statement of IoT integrated with Edge Computing document is of significance.

Something that I have been wondering about is this: How will devices communicate? For example, will it be by email technology or what? Is email suitable for some applications but not for others: for example, if gathering temperature data for a weather map as a matter of record maybe email will be fast enough with measurements all taking place at a specified time and then results all sent in by email. What methods are available if faster communication is required?

For example, could an IoT device have a mobile telephone built into it so that it could send an email by a mobile telephone connection?

Maybe these are simplistic questions from a beginner but the best way to make progress is for people to build on previous comments and not get into ad hominem comments as to whether someone who knows so little of the field at present should be contributing to the discussion or anything like that.
Just imagine please that we are all sat in a common room having a cup of tea, or peppermint tea or whatever and chatting informally.

The authors of the Problem Statement of IoT integrated with Edge Computing document have provided a platform for discussion so how about let us have the discussion as they requested please.

William Overington

Wednesday 11 July 2018

---

From: Jungha Hong <[email-masked]>
Date: Thu, 12 Jul 2018 02:49:51 +0000

Dear William,

Thanks for your support on this discussion.

We actually asked T2TRG for a slot to present it but slot was not available.

So, the chairs recommended to start a discussion on the mailing list and they will arrange a side meeting if needed.

Yes, we don't have much time to discuss it before the Monteal meeting as you mentioned.

So, please keep giving any suggestions and comments on this draft.

We are also interested in discussing a IETF/IRTF role for IoT Edge computing.

Please jump in this discussion if you have any concerns on what IETF/IRTF to do for IoT Edge computing.

Thanks,

Jungha Hong

________________________________
보낸 사람 : "William_J_G Overington" <[email-masked]>
보낸 날짜 : 2018-07-12 00:20:49 ( +09:00 )
받는 사람 : [email-masked] <[email-masked]>, thorstendlux=[email-masked] <thorstendlux=[email-masked]>, [email-masked] <[email-masked]>, 홍정하 <[email-masked]>
참조 : [email-masked] <[email-masked]>, [email-masked] <[email-masked]>, 홍용근 <[email-masked]>
제목 : Re: [T2TRG] [T2TRG/Din] Discussion New draft for draft-hong-iot-edge-computing-00.txt

William Overington

Wednesday 11 July 2018

---

From: Jungha Hong <[email-masked]>
Date: Thu, 12 Jul 2018 02:58:55 +0000

Dear Mats,

Thanks for sharing the link on EdgeX.

Actually, we are developing a solution for smart constructios, where we are utilizing EdgeX and machine learning.

Thanks,

Jungha Hong

________________________________
보낸 사람 : "Mats Wichmann" <[email-masked]>
보낸 날짜 : 2018-07-12 00:47:29 ( +09:00 )
받는 사람 : [email-masked] <[email-masked]>
참조 :
제목 : Re: [Din] [T2TRG] [T2TRG/Din] Discussion New draft for draft-hong-iot-edge-computing-00.txt

> The authors of the Problem Statement of IoT integrated with Edge Computing document have provided a platform for discussion so how about let us have the discussion as they requested please.

Certainly a lot of thought about these topics has taken place in this

project, if people aren't familiar it might be worth a look:

https://wiki.edgexfoundry.org/display/FA/Executive+Summary

_______________________________________________

Din mailing list

[email-masked]

https://www.irtf.org/mailman/listinfo/din

---

From: William_J_G Overington <[email-masked]>
Date: Thu, 12 Jul 2018 10:14:31 +0100 (BST)

Hi
So I read the post and I wondered as to what is EdgeX.
I found https://www.edgexfoundry.org/ on the web.
Thus far I have not found where Mats has posted the link on EdgeX.
I am wondering if there might be a discussion there.
So where should I look please, or is it only for members of EdgeX?
I notice that EdgeX seems to be Linux based: I am using Windows 10 on a Lenovo ideapad 510 laptop computer, at home.
I notice that EdgeX has the following on the  web page.
> … OS-agnostic reference software platform …
This is interesting. Has anything been decided yet please?
William Overington
Thursday 12 July 2018
----Original message----
>From : [email-masked]
Date : 2018/07/12 - 03:58 (GMTDT)
To : [email-masked], [email-masked]
Cc : [email-masked], [email-masked], [email-masked]
Subject : Re: [T2TRG] [Din] [T2TRG/Din] Discussion New draft for draft-hong-iot-edge-computing-00.txt
Dear Mats,
Thanks for sharing the link on EdgeX. 
Actually, we are developing a solution for smart constructios, where we are utilizing EdgeX and machine learning.
Thanks,
Jungha Hong

 

 

 

 

 

 

 

 
 
> Something that I have been wondering about is this: How will devices communicate? For example, will it be by email technology or what? Is email suitable for some applications but not for others: for example, if gathering temperature data for a weather map
 as a matter of record maybe email will be fast enough with measurements all taking place at a specified time and then results all sent in by email. What methods are available if faster communication is required?

 

 

 

 
Din mailing list
 
[email-masked]

---

From: Thorsten Dahm <[email-masked]>
Date: Thu, 12 Jul 2018 12:55:31 +0100

Hi William,

Am Mi., 11. Juli 2018 um 16:20 Uhr schrieb William_J_G Overington
<wjgo_10009=[email-masked]>:

> Something that I have been wondering about is this: How will devices
> communicate? For example, will it be by email technology or what?

I'm sure no IoT device will use email as primary communication method. :-)
If you wonder what protocols are used by IoT, please have a look at COAP,
MQTT, BACnet, and things like CoRE.

> For example, could an IoT device have a mobile telephone built into it so
> that it could send an email by a mobile telephone connection?
>
>
too expensive, hard to manage (user would have to buy SIM cards / sign
mobile phone contracts for every device etc.). Most devices will use
Ethernet, Wifi or Bluetooth / BLE. Some will also use technologies like
ZigBee or Thread.

Maybe it would be more suitable to evaluate how well the protocols above
work with edge computing setups and if / how the protocols could be
improved?

Regards,
Thorsten

-- 
Thorsten Dahm

Network Engineer
Google Ireland Ltd.
The Gasworks, Barrow Street
Dublin 4,  Ireland

Registered in Dublin, Ireland
Registration Number: 368047

---

From: William_J_G Overington <[email-masked]>
Date: Thu, 12 Jul 2018 13:51:25 +0100 (BST)

Hi
For the avoidance of doubt I have only just received your email. I had been writing and sending my email that is listed in the archive after your email.
> If you wonder what protocols are used by IoT, please have a look at COAP, MQTT, BACnet, and things like CoRE.
Thank you for sending a list. I am a beginner on the Internet of Things. At present I know almost nothing about how the internet works. I just use emails and the web as an end user.
> too expensive
Well, I was wondering about something like things deployed in a rural area as part of a flood warning system to measure water depth. Maybe Pay as You Go phones?
I have posted a thought experiment and hopefully you and others will have a look at it and consider it and post comments.
William Overington
Thursday 12 July 2018
----Original message----
>From : thorstendlux=[email-masked]
Date : 2018/07/12 - 12:55 (GMTDT)
To : [email-masked]
Cc : [email-masked], [email-masked], [email-masked], [email-masked], [email-masked]
Subject : Re: [T2TRG] [T2TRG/Din] Discussion New draft for draft-hong-iot-edge-computing-00.txt
Hi William,
Am Mi., 11. Juli 2018 um 16:20 Uhr schrieb William_J_G Overington <wjgo_10009=[email-masked]>:
Something that I have been wondering about is this: How will devices communicate? For example, will it be by email technology or what? 
I'm sure no IoT device will use email as primary communication method. :-) If you wonder what protocols are used by IoT, please have a look at COAP, MQTT, BACnet, and things like CoRE. 
For example, could an IoT device have a mobile telephone built into it so that it could send an email by a mobile telephone connection?
too expensive, hard to manage (user would have to buy SIM cards / sign mobile phone contracts for every device etc.). Most devices will use Ethernet, Wifi or Bluetooth / BLE. Some will also use technologies like ZigBee or Thread. 
Maybe it would be more suitable to evaluate how well the protocols above work with edge computing setups and if / how the protocols could be improved?
Regards,
Thorsten
-- 
Thorsten Dahm
Network Engineer
Google Ireland Ltd.
The Gasworks, Barrow Street
Dublin 4,  Ireland
Registered in Dublin, Ireland
Registration Number: 368047

---

From: 홍용근 <[email-masked]>
Date: Fri, 13 Jul 2018 00:12:32 +0000

Dear William Overington.

Let me join this discussion and reply your answers.
EdgeX is a verner-neutral open source project building a common open framework for IOT edge computing and it is under the Linux Foundation Projects. (https://www.edgexfoundry.org/)
And EdgeX Wiki is a site for maintaining document and releasing source codes and other materials. It is also owned by the EdgeX Community. (https://wiki.edgexfoundry.org)
The web site where Mats has posted is in EdgeX Wiki site and you had better to check in the EdgeX wiki site.

EdgeX is a OS-agnostic reference software platform and the basic architecture of EdgeX is Docker/Container. So, you can run EdgeX on the Windows platform using Docker/Container.
Actually, we have tested EdgeX open source in the Linux and we don’t’ test EdgeX in the Windows platform but we believe that it can also works in the Windows platform .
For more information, you can refer the following page;
https://wiki.edgexfoundry.org/display/FA/Get+EdgeX+Foundry+-+Users#GetEdgeXFoundry-Users-WhatYouNeed\
If any other persons can succeed running EdgeX in the Windows platform, it is appreciate to share your experience..

Best regards.

Yong-Geun.

From: William_J_G Overington [mailto:[email-masked]]
Sent: Thursday, July 12, 2018 6:15 PM
To: [email-masked]; 홍정하; [email-masked]; [email-masked]
Cc: 홍용근; [email-masked]
Subject: Re: [T2TRG] [Din] [T2TRG/Din] Discussion New draft for draft-hong-iot-edge-computing-00.txt

Hi

William Overington

Thursday 12 July 2018

----Original message----
From : [email-masked]
Date : 2018/07/12 - 03:58 (GMTDT)
To : [email-masked], [email-masked]
Cc : [email-masked], [email-masked], [email-masked]
Subject : Re: [T2TRG] [Din] [T2TRG/Din] Discussion New draft for draft-hong-iot-edge-computing-00.txt

Dear Mats,

Thanks,

Jungha Hong

Din mailing list

[email-masked]