Subject: [T2TRG] Next WISHI call 17th or 20th of September (Doodle poll)

From: Ari Keränen <[email-masked]>
Date: Mon, 10 Sep 2018 16:46:12 +0000

Hi all,

We're planning to organise the next WISHI call next week, on September 17th or 20th (Monday or Thursday), 7:00-8:30 AM PDT (16:00-17:30 CEST). 

Please indicate your preference for the day in this Doodle by EOB Wednesday 12th:
https://doodle.com/poll/dpweh6qpuf5ddpsx

In this call we are planning to focus on how we can add semantics to existing instances of descriptive data/documents. We have a few examples of this for different purposes from the past WISHI hackathons and some of us are exploring new use cases on data translation and interoperability. What have we learned so far? Where are the main challenges and potential solutions? Where should we look for more inspiration? What kind of common tools can we build to address the variety of use cases?

For the latest draft agenda and call-in information see:
https://github.com/t2trg/wishi/wiki/Agenda-items

Cheers,
Ari

---

From: William_J_G Overington <[email-masked]>
Date: Wed, 12 Sep 2018 15:17:06 +0100 (BST)

Hi

Could you expand on this please? I am fairly new to this group.

The agenda includes "Adding semantics to existing (instances of) data". I am wondering quite what this means.

Without loss of generality of the above enquiry I am wondering how, if at all, my idea for using localizable sentences that can be used both by humans to communicatee through the language barrier and also for device to device communication interoperably regardless of the brand of the device and also for human to device and for device to human communication.

If it is determined that my idea is not relevant to the problem could you possibly explain why that is the case please?

I seem to remember reading somewhere as to what WISHI means, but I have not remembered. Could you possibly explain please?

Best regards,

William Overington

Wednesday 12 September 2018

----Original message----
>From : [email-masked]
Date : 2018/09/10 - 17:46 (GMTDT)
To : [email-masked]
Cc : [email-masked]
Subject : [T2TRG] Next WISHI call 17th or 20th of September (Doodle poll)

Hi all,

Cheers,
Ari
_______________________________________________
T2TRG mailing list
[email-masked]
https://www.irtf.org/mailman/listinfo/t2trg

---

From: Ari Keränen <[email-masked]>
Date: Thu, 13 Sep 2018 12:33:18 +0000

Hi William,

The agenda item is about how we can enrich data from existing systems (e.g., CoAP client using SenML or MQTT client publishing with arbitrary JSON payloads) with well-defined semantics (e.g., iot.schema.org<http://iot.schema.org> vocabularies or IPSO IDs) to enable data ingest, translation, etc.

For background on the WISHI work, you can find all information archived at our Github:
https://github.com/t2trg/wishi

In particular you may want to start from the workshop repository:
https://github.com/t2trg/2017-07-wishi

And the wiki:
https://github.com/t2trg/wishi/wiki

The localizable sentences seem to be a way to deliver information with constrained semantics. We have a set of mechanisms that achieve some of those aspects (see, e.g., the references in my previous e-mail), so I'm not sure what additional problems does the localizable sentences approach solve, and what would be the best approach there.

Cheers,
Ari

On 12 Sep 2018, at 17.17, William_J_G Overington <[email-masked]<mailto:[email-masked]>> wrote:

Hi

Best regards,

William Overington

----Original message----
>From : [email-masked]<mailto:[email-masked]>
Date : 2018/09/10 - 17:46 (GMTDT)
To : [email-masked]<mailto:[email-masked]>
Cc : [email-masked]<mailto:[email-masked]>
Subject : [T2TRG] Next WISHI call 17th or 20th of September (Doodle poll)

Hi all,

Cheers,
Ari

---

From: William_J_G Overington <[email-masked]>
Date: Sat, 15 Sep 2018 21:46:40 +0100 (BST)

Hi Ari
Thank you for your email. I have been following up some of the references that you kindly provided.
> …, so I'm not sure what additional problems
 does the localizable sentences approach solve, and what would be the best approach there.
Well neither am I at the present time.
Please consider the situation of a lock.
There could be number of localizable sentences, each represented by a particular sequence of an integral sign and a number of circled digits - the number of circled digits could typically be six, but could be from five to many more as desired. Each of the localizable sentences would have its own particular sequence different from the particular sequence for every other localizable sentence.
For example, the following sentences displayed here each by its English localization.
----
Please open the lock.
Please close the lock.
The lock is open.
The lock is closed.
What is the status of the lock please?
----
So a lock might only need to be able to react to three localizable sentences (Please open the lock. Please close the lock. What is the status of the lock please?) and to be able to send out three localizable sentences (The lock is open. The lock is closed. I do not understand that localizable sentence.)
The localizable sentence
I do not understand that localizable sentence.
would be from a general collection of localizable sentences and the lock could be programmed to send that localizable sentence if it receives a localizable sentence that is other than one of the three to which it is programmed to react.
Would that be useful? Can any other system do that? I am a researcher and maybe localizable sentences might be a good and useful solution or maybe they will not be, the research goes where it goes.
Best regards,
William Overington
Saturday 15 September 2018
 
----Original message----
>From : [email-masked]
Date : 2018/09/13 - 13:33 (GMTDT)
To : [email-masked]
Cc : [email-masked], [email-masked]
Subject : Re: [T2TRG] Next WISHI call 17th or 20th of September (Doodle poll)
Hi William,
The agenda item is about how we can enrich data from existing systems (e.g., CoAP client using SenML or MQTT client publishing with arbitrary JSON payloads) with well-defined semantics (e.g.,
iot.schema.org vocabularies or IPSO IDs) to enable data ingest, translation, etc. 
For background on the WISHI work, you can find all information archived at our Github: 
https://github.com/t2trg/wishi
In particular you may want to start from the workshop repository:
https://github.com/t2trg/2017-07-wishi
And the wiki:
https://github.com/t2trg/wishi/wiki
The localizable sentences seem to be a way to deliver information with constrained semantics. We have a set of mechanisms that achieve some of those aspects (see, e.g., the references in my previous e-mail), so I'm not sure what additional problems
 does the localizable sentences approach solve, and what would be the best approach there.
Cheers,
Ari
On 12 Sep 2018, at 17.17, William_J_G Overington <[email-masked]> wrote:
Hi
Could you expand on this please? I am fairly new to this group.
The agenda includes "Adding semantics to existing (instances of) data". I am wondering quite what this means.
Without loss of generality of the above enquiry I am wondering how, if at all, my idea for using localizable sentences that can be used both by humans to communicatee through the language barrier and also for device to device communication interoperably regardless
 of the brand of the device and also for human to device and for device to human communication.
If it is determined that my idea is not relevant to the problem could you possibly explain why that is the case please?
I seem to remember reading somewhere as to what WISHI means, but I have not remembered. Could you possibly explain please?
Best regards,
William Overington
Wednesday 12 September 2018
----Original message----
In this call we are planning to focus on how we can add semantics to existing instances of descriptive data/documents. We have a few examples of this for different purposes from the past WISHI hackathons and some of us are exploring new use cases on data translation
 and interoperability. What have we learned so far? Where are the main challenges and potential solutions? Where should we look for more inspiration? What kind of common tools can we build to address the variety of use cases?